Project

General

Profile

Actions

action #53750

closed

[opensuse][desktop] test fails in hexchat, search dialog from desktop-runner is shown instead of text field selected

Added by okurz almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-07-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-Updates-x86_64-gnome@uefi fails in
hexchat
typing "freenode" into gnome's search dialog of applications rather then in https://openqa.opensuse.org/tests/973240#step/hexchat/21 where it should type. However, the problem already appeared in https://openqa.opensuse.org/tests/973240#step/hexchat/21 because the search window is showing up in the background when it shouldn't.

This test failure started co-incidentially the day qemu switched from cirrus to std graphics - but that is supposedly only a side effect exposed.

From the looks of it, the test should be pressing 'alt-f2' to get to the desktop runner - but when looking at the screenshots, we seem to first have gotten an 'alt-f1' (or super) to get to the activities screen, followed by 'alt-f2' for the runner. The runner is perfectly functional in this case, BUT the activities overview does not close after launching something this way (works as designed).

OTOH, it is compleltely unclear why the activities screen is even launched

Reproducible

Fails since (at least) Build 20190703-1 (current job)
but also seen in current Tumbleweed tests. Either this is related to any update which is included in maintenance updates as well as Tumbleweed or because of the change of the qemu graphics adapter from "cirrus" to "std"?

Expected result

Last good: 20190702-4 (or more recent)

Further details

Always latest result in this scenario: latest

and for Tumbleweed latest


Related issues 1 (0 open1 closed)

Has duplicate openQA Tests - action #53744: test fails in hexchatRejectedokurz2019-07-03

Actions
Actions #1

Updated by okurz almost 5 years ago

  • Description updated (diff)
Actions #2

Updated by okurz almost 5 years ago

Actions #3

Updated by okurz almost 5 years ago

  • Description updated (diff)
Actions #4

Updated by okurz almost 5 years ago

  • Priority changed from High to Urgent

just observed that this fails a lot in e.g. the Leap upgrade tests so very likely not a change in the product but maybe due to change of the graphics adapter from "cirrus" to "std".

Actions #5

Updated by jorauch almost 5 years ago

  • Assignee set to jorauch
Actions #6

Updated by jorauch almost 5 years ago

  • Assignee deleted (jorauch)

I have found nothing new and as a non Gnome user I cannot investigate this easily

Actions #7

Updated by jbaier_cz almost 5 years ago

  • Assignee set to jbaier_cz
Actions #8

Updated by jbaier_cz almost 5 years ago

Follow-up:

  1. In QEMUVGA=cirrus case, desktop is x11 and the hexchat test is working: http://panigale.suse.cz/tests/2189#step/window_system/8
  2. In QEMUVGA=virtio case, desktop is wayland and the same test fails: http://panigale.suse.cz/tests/2188#step/window_system/8

I would say this is quite an evidence.

Apparently the two desktops have some differences how to respond to the mouse being suddenly in the top left corner. I will try to make a short and quick fix soon.

Actions #10

Updated by okurz almost 5 years ago

PR merged. However that does not seem to have worked. From https://openqa.opensuse.org/tests/984087/file/autoinst-log.txt I can see that the mouse is moved to 0,10 but just after trying to start hexchat again the mouse cursor is moved into another corner:

[2019-07-17T00:00:10.336 CEST] [debug] <<< testapi::mouse_set(x=0, y=10)
[2019-07-17T00:00:10.337 CEST] [debug] mouse_move 0, 10
[2019-07-17T00:00:10.337 CEST] [debug] send_pointer_event 0, 0, 10, 1
[2019-07-17T00:00:10.337 CEST] [debug] /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/tests/x11/hexchat.pm:37 called testapi::x11_start_program
[2019-07-17T00:00:10.338 CEST] [debug] <<< testapi::x11_start_program(program='hexchat', target_match='hexchat-network-select')
[2019-07-17T00:00:10.338 CEST] [debug] /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/tests/x11/hexchat.pm:37 called testapi::x11_start_program
[2019-07-17T00:00:10.338 CEST] [debug] <<< testapi::send_key(key='alt-f2', do_wait=0)
[2019-07-17T00:00:10.543 CEST] [debug] /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/tests/x11/hexchat.pm:37 called testapi::x11_start_program
[2019-07-17T00:00:10.543 CEST] [debug] <<< testapi::mouse_hide(border_offset=1)
[2019-07-17T00:00:10.544 CEST] [debug] mouse_move 1023, 767
[2019-07-17T00:00:10.544 CEST] [debug] send_pointer_event 0, 1023, 767, 1

I am giving it a try as well with:

openqa-clone-job --skip-chained-deps --within-instance https://openqa.opensuse.org 984087 _GROUP=0 TEST=gnome@okurz/os-autoinst-distri-opensuse#fix/hexchat BUILD=okurz/os-autoinst-distri-opensuse#fix/hexchat CASEDIR=https://github.com/okurz/os-autoinst-distri-opensuse.git#fix/hexchat PRODUCTDIR=os-autoinst-distri-opensuse/products/opensuse NEEDLES_DIR=/var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/products/opensuse/needles EXCLUDE_MODULES=shutdown,cleanup_before_shutdown,reboot_gnome,vlc,gimp,inkscape,desktop_mainmenu,evolution,gnome_music,nautilus,glxgears,oocalc,chromium,firefox_audio,firefox,gedit,sshxterm,gnome_tweak_tool,gnome_control_center,keymap_or_locale_x11,ssh_cleanup,_sshd,sshfs,yast2_bootloader,yast2_i,glibc_sanity,salt,curl_https

Created job #984499: opensuse-Tumbleweed-DVD-x86_64-Build20190713-gnome@64bit_std -> https://openqa.opensuse.org/t984499

Actions #11

Updated by okurz almost 5 years ago

  • Assignee changed from jbaier_cz to okurz

that seemed to have worked. I hope you don't mind if I take over here.

https://openqa.opensuse.org/tests/984499#step/hexchat/22 is soft-failed.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7909

Actions #12

Updated by okurz almost 5 years ago

merged. Retriggered the related test failures I could find on o3, waiting for verification on production.

Actions #13

Updated by dimstar almost 5 years ago

This issue has been fixed by pr#7909 - hexchat is now started correctly on screen without the interactivities screen interfering.

A followup issue has been filed, as hexchat itself fails to delete the username (ctrl-a being mistaken for a)
https://progress.opensuse.org/issues/54425

Different issue though, thus different ticket,

Actions #14

Updated by dimstar almost 5 years ago

  • Status changed from Feedback to Resolved
Actions #15

Updated by SLindoMansilla over 4 years ago

  • Subject changed from [functional][u][desktop] test fails in hexchat, search dialog from desktop-runner is shown instead of text field selected to [opensuse][desktop] test fails in hexchat, search dialog from desktop-runner is shown instead of text field selected

Not resolved by U-Team

Actions

Also available in: Atom PDF