Project

General

Profile

Actions

action #54425

closed

openQA Project - action #55703: send_keys() doesn't guarantee that the application will handle modifiers+normal_key properly

[functional][u] hexchat: ctrl-a mis-interpreted as 'a' since we switched to QEMUVGA "std"

Added by dimstar almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 28
Start date:
2019-07-18
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-gnome@64bit fails in
hexchat

Acceptance criteria

  • AC: The failure rate has been reduced to the minimum possible.

Suggestions

  • Use a prepared configuration file to skip typing connection information.

Reproducible

Fails since (at least) Build 20190702

Expected result

Last good: 20190701 (or more recent)

Further details

Always latest result in this scenario: latest

After clicking the window, we are supposedly pressing ctrl-a, followed by delete - but looking at the screenshot, 'ctrl' was missed, 'a' typed (and 'delete as no effect at the end of the word)

Actions #1

Updated by SLindoMansilla almost 5 years ago

  • Subject changed from hexchat: ctrl-a mis-interpreted as 'a' to [functional][u] hexchat: ctrl-a mis-interpreted as 'a'
  • Priority changed from Normal to High
Actions #2

Updated by SLindoMansilla almost 5 years ago

  • Description updated (diff)
Actions #3

Updated by SLindoMansilla almost 5 years ago

  • Parent task set to #55703
Actions #4

Updated by dimstar almost 5 years ago

A proposal: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8382

avoids using ctrl-a, but rather sends 'home' and then 'delete' until the input box is empty

Actions #5

Updated by coolo over 4 years ago

IMO this fails since GNOME tests runs under wayland (i.e. we removed the cirrus setting)

Actions #6

Updated by okurz over 4 years ago

  • Subject changed from [functional][u] hexchat: ctrl-a mis-interpreted as 'a' to [functional][u] hexchat: ctrl-a mis-interpreted as 'a' since we switched to QEMUVGA "std"

yes, this is correct.

Actions #7

Updated by SLindoMansilla over 4 years ago

  • Description updated (diff)

PR was merged

Actions #8

Updated by SLindoMansilla over 4 years ago

  • Status changed from New to Workable
  • Priority changed from High to Normal
  • Target version set to Milestone 28
  • Estimated time set to 42.00 h
Actions #9

Updated by SLindoMansilla over 4 years ago

Should be fixed by: https://github.com/os-autoinst/os-autoinst/pull/1260/files

To resolve, provide verification runs, set a proper value for VNC_TYPING_LIMIT if necessary.

Actions #10

Updated by okurz over 4 years ago

  • Project changed from openQA Project to openQA Tests
  • Category set to Bugs in existing tests
  • Status changed from Workable to Resolved
  • Assignee set to dimstar

Actually this has been resolved with DimStar's change in tests: fe4a4b7b7 , https://openqa.opensuse.org/tests/1107110#next_previous shows that this is stable now for 7 jobs in a row

Actions

Also available in: Atom PDF