Project

General

Profile

action #49622

[functional][y] Verify the wrong desktop will show up

Added by JERiveraMoya almost 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
SUSE QA - Milestone 33
Start date:
2018-12-12
Due date:
2020-04-21
% Done:

0%

Estimated time:
3.00 h
Difficulty:

Description

Motivation

As a follow-up of #45020, a mechanism was introduced to detect wrong systemd target: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7136/files#diff-ba06ceac413fe1a2d384ec7dd32ad033R79
Now we need to take into account all cases detected and exclude them, so we can use asset_screen_run or similar in case of failure, instead of info box.
According to discussion in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7109#issuecomment-475666974 most of them has already detected:
s390, hyperv, caasp/kubic, and upgrade scenario.

Acceptance criteria

  • AC1: List of scenarios where record_info is displayed is elaborated.
  • AC2: Detection mechanism fails if wrong systemd target is set.

Suggestions

Perform a wide search in OSD/O3 by module (using new feature to search for modules) installation_overview to see if contains the record_info box.

Further details

For example, one of the scenario where we detect it: sle-15-SP1-allmodules+allpatterns


Related issues

Related to openQA Tests - action #45020: [functional][y] tests should detect that the wrong desktop will show upResolved2018-12-122019-03-26

Related to openQA Tests - action #49703: [functional][y][timebox:8h] Evaluate how to switch between TTYs in specific scenarios (hyperv, ssh,vnc)Resolved2019-04-022020-06-02

Related to openQA Tests - action #49589: [functional][y] DESKTOP variable changes on s390, makes it unreliableRejected2019-03-222019-04-09

Blocked by qe-yast - action #50111: [functional][y] Switch between installation/install shell in vnc installationResolved2019-04-02

History

#1 Updated by JERiveraMoya almost 3 years ago

  • Copied from action #45020: [functional][y] tests should detect that the wrong desktop will show up added

#2 Updated by JERiveraMoya almost 3 years ago

  • Copied from deleted (action #45020: [functional][y] tests should detect that the wrong desktop will show up)

#3 Updated by JERiveraMoya almost 3 years ago

  • Related to action #45020: [functional][y] tests should detect that the wrong desktop will show up added

#4 Updated by JERiveraMoya almost 3 years ago

  • Description updated (diff)

#5 Updated by JERiveraMoya almost 3 years ago

  • Description updated (diff)
  • Due date set to 2019-04-09
  • Status changed from In Progress to Workable

#6 Updated by JRivrain almost 3 years ago

  • Related to action #49703: [functional][y][timebox:8h] Evaluate how to switch between TTYs in specific scenarios (hyperv, ssh,vnc) added

#7 Updated by riafarov almost 3 years ago

  • Target version changed from Milestone 23 to Milestone 24

#8 Updated by riafarov almost 3 years ago

Let's address #49589 first

#9 Updated by riafarov almost 3 years ago

  • Related to action #49589: [functional][y] DESKTOP variable changes on s390, makes it unreliable added

#10 Updated by riafarov almost 3 years ago

  • Due date changed from 2019-04-09 to 2019-04-23

#11 Updated by oorlov almost 3 years ago

  • Status changed from Workable to Blocked

#13 Updated by oorlov almost 3 years ago

  • Assignee set to riafarov

#14 Updated by riafarov almost 3 years ago

  • Due date changed from 2019-04-23 to 2019-05-07

#15 Updated by riafarov almost 3 years ago

  • Due date changed from 2019-05-07 to 2019-06-04
  • Status changed from Blocked to Workable
  • Assignee deleted (riafarov)
  • Target version changed from Milestone 24 to Milestone 25

We can work on this one once #50285 is resolved.

#17 Updated by riafarov over 2 years ago

  • Due date deleted (2019-06-04)
  • Assignee set to riafarov
  • Target version changed from Milestone 25 to Milestone 30+

I need to crosscheck what is current status of the related tickets and bugs.

#18 Updated by riafarov over 2 years ago

  • Blocked by action #50111: [functional][y] Switch between installation/install shell in vnc installation added

#19 Updated by riafarov over 2 years ago

  • Status changed from Workable to Blocked

After #50111 is resolved, we can apply the change for SLE 12 SP5, and then simply enable behavior for SLE 15 SP2, once bsc#1129412 is fixed.

#20 Updated by mgriessmeier about 2 years ago

  • Target version changed from Milestone 30+ to Milestone 30

bulk moved to M30 for revisiting

#21 Updated by riafarov almost 2 years ago

  • Due date set to 2020-04-07
  • Status changed from Blocked to New
  • Assignee deleted (riafarov)
  • Target version changed from Milestone 30 to Milestone 33

Bug is fixed.

#22 Updated by riafarov almost 2 years ago

  • Status changed from New to Workable
  • Estimated time set to 3.00 h

We actually have this code in place already, so we can check if it was showing the error in any of the runs. If not, we can convert this code into hard failure instead of just recording the info.

#23 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

#24 Updated by JERiveraMoya almost 2 years ago

In OSD searching in all groups for latest build:

Flavor: Full -> https://openqa.suse.de/tests/4015368#step/installation_overview/26
Flavor: Migration-from-SLE11-SP4-to-SLE15-SP2 -> none
Flavor: Migration-from-SLE12-SP5-to-SLE15-SP2 -> none
Flavor: Migration-from-SLE15-SPX-to-SLE15-SP2 -> none
Flavor: Migration-to-HPC15-SP2 -> none
Flavor: Online

Flavor: Regression-on-Migration-from-SLE11-SP4-to-SLE15-SP2: none
Flavor: Regression-on-Migration-from-SLE12-SP5-to-SLE15-SP2: none
Flavor: Regression-on-Migration-from-SLE15-SPX-to-SLE15-SP2: none

#25 Updated by JERiveraMoya almost 2 years ago

In O3 for latest builds searching in following groups:

openSUSE Leap 15 (All flavors) -> none
openSUSE Tumbleweed PowerPC (All flavors) -> none
openSUSE Tumbleweed AArch64 (All flavors) -> none
openSUSE Tumbleweed (All flavors) -> none

#26 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Feedback

#28 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Feedback to Blocked

#29 Updated by riafarov almost 2 years ago

Didn't we agree to enable hard failure if no patterns setting is set? As an alternative we can introduce some flag to make hard fail and add warning otherwise.

#30 Updated by JERiveraMoya almost 2 years ago

As far as I remember, agreement was to block the ticket by the bug instead of introduce another exclusion temporarily while there is some answer in the bug.
You still want to go for excluding patterns? I can proceed if you confirm

#31 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Blocked to Feedback

#32 Updated by riafarov almost 2 years ago

  • Due date changed from 2020-04-07 to 2020-04-21

#33 Updated by JERiveraMoya almost 2 years ago

Another bug not related with patterns: https://bugzilla.suse.com/show_bug.cgi?id=1169623

#34 Updated by JERiveraMoya almost 2 years ago

The problem seems to be narrowed to 'some s390x scenarios where specific selection of patterns is involved there is some non-default role selection applied', so that triggers a different behavior compared to other architectures.

#35 Updated by riafarov almost 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF