Project

General

Profile

action #47852

[qe-core][functional] test fails in firefox - use of milestones whenever possible to reduce waste

Added by szarate over 3 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Enhancement to existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2019-02-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-s390x-default@s390x-kvm-sle12 fails in
firefox

When this kind of tests fail, the test scenario is killed

Test suite description

Maintainer: okurz

The standard scenario where we mainly just follow installation suggestions without any adjustments.

Reproducible

Fails since (at least) Build 0109 or tests where only one application is being tested that would not affect further tests (i.e, firefox or nautilus are being open, and these don't affect the current test environment)

Expected result

Test scenario is able to finish by reverting to last good snapshot

History

#1 Updated by szarate over 3 years ago

Assigning to milestone 24 for the time being, but perhaps we could discuss this and bring it to an earlier milestone

#2 Updated by okurz over 3 years ago

  • Category changed from Bugs in existing tests to Enhancement to existing tests
  • Status changed from Workable to New

so you are basically asking for "snapshot support on s390x-kvm", right? I do not see it as "Workable" as it is far from clear what to do here, also not really "Bugs in existing tests" as we also do not have a "last good" where we see that a snapshot is loaded, or did I miss something?

#3 Updated by szarate about 3 years ago

  • Status changed from New to Workable

#4 Updated by okurz about 3 years ago

  • Status changed from Workable to Rejected
  • Assignee set to szarate
  • Priority changed from Normal to Low
  • Target version changed from Milestone 24 to Milestone 26

szarate no response on my answer. If you refine it feel free to reopen

#5 Updated by szarate about 3 years ago

  • Status changed from Rejected to Feedback
  • Assignee changed from szarate to okurz
  • Priority changed from Low to Normal

so you are basically asking for "snapshot support on s390x-kvm", right? I do not see it as "Workable" as it is far from clear what to do here, also not really "Bugs in existing tests" as we also do not have a "last good" where we see that a snapshot is loaded, or did I miss something?

Doesn't mean we can't do that on other architectures like ppc64, x86 and aarch64, which is what? 75% of the arches? :).

General idea is: If we got far enough to boot a system, why don't we use that to revert to a state where tests can be ran further?.

tests where only one application is being tested that would not affect further tests (i.e, firefox or nautilus are being open, and these don't affect the current test environment)

I think this paragraph explains the whole rational for this ticket.

#6 Updated by okurz about 3 years ago

Sorry, I am confused now and do not what you expect from me and what you think is missing. We use snapshots to revert to on backends where supported or do you know of examples where we don't?

#7 Updated by okurz about 3 years ago

  • Assignee changed from okurz to szarate

please see my last question. Afterwards please do not assign to myself due to my further absence :)

#8 Updated by SLindoMansilla about 3 years ago

  • Blocked by action #46349: [s390x] Add qemu backend support added

#9 Updated by SLindoMansilla about 3 years ago

  • Status changed from Feedback to Workable

This ticket is not yet blocked, since it can be prepared for non-s390x architectures. See the relation to the ticket as blocker, rather than actually blocked.

I think this can be worked on, even if we treat s390x different while we implement the qemu backend for s390x.

#10 Updated by riafarov almost 3 years ago

  • Subject changed from [functional][u][y] test fails in firefox - use of milestones whenever possible to reduce waste to [functional][u] test fails in firefox - use of milestones whenever possible to reduce waste

#11 Updated by mgriessmeier almost 3 years ago

@santi - any update here?

#12 Updated by mgriessmeier almost 3 years ago

  • Priority changed from Normal to High
  • Target version changed from Milestone 26 to Milestone 27

#13 Updated by mgriessmeier over 2 years ago

  • Target version changed from Milestone 27 to Milestone 28

#14 Updated by mgriessmeier over 2 years ago

  • Target version changed from Milestone 28 to Milestone 30

needs to be discussed offline

#15 Updated by tjyrinki_suse over 1 year ago

  • Subject changed from [functional][u] test fails in firefox - use of milestones whenever possible to reduce waste to [qe-core][functional] test fails in firefox - use of milestones whenever possible to reduce waste

#16 Updated by szarate over 1 year ago

  • Blocked by deleted (action #46349: [s390x] Add qemu backend support)

#17 Updated by szarate over 1 year ago

  • Status changed from Workable to Rejected

I will reject this ticket for now, it depended on having snapshot support on s390 and powerVM, but that won't likely happen anytime soon.

Also available in: Atom PDF