Project

General

Profile

Actions

coordination #43139

closed

Assess and improve automation coverage for yast2-network

Added by vsvecova over 5 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
80.00 h

Description

Initial plan:

  1. Check current existing related tests, assess their relevance and extendability
  2. Adapt test scenarios from https://bugzilla.suse.com/tr_list_cases.cgi?tags_type=anyexact&tags=packagename_yast2-network and from regression testing sections of past test reports.
Actions #1

Updated by vsvecova over 5 years ago

  • Status changed from New to In Progress
  • Target version set to QAM tests - current

Current progress: working on developing a suitable test scenario in line with initial plans.

Actions #2

Updated by brhavel over 5 years ago

  • Due date set to 2018-12-14
Actions #3

Updated by brhavel over 5 years ago

As far as I know, Veronika prepared the coverage to implement for this particular test (test plan) which is going to be implemented once she is back from vacation

Actions #4

Updated by vsvecova over 5 years ago

Currently working on extending yast2_lan.pm

Actions #5

Updated by vsvecova over 5 years ago

Current plan is to run the progress by Petr/Martin by this Friday and then proceed in line with their feedback/suggestions.

Actions #6

Updated by vsvecova over 5 years ago

Finishing touches, adding missing needles etc. Then gather feedback.

Actions #7

Updated by vsvecova over 5 years ago

As verification runs have revealed, the test code requires additional adjustments due to differences introduced into yast2-network in SLE15-SP1.

See relevant yast team trello card for details on the changes: https://trello.com/c/so0amSNp/342-sle-15-sp1-yast2-network-clarify-hostname-setup

Actions #8

Updated by brhavel over 5 years ago

  • Due date changed from 2018-12-14 to 2019-02-01
Actions #9

Updated by vsvecova over 5 years ago

  • Subject changed from [qam] Assess and improve automation coverage for yast2-network to [qam] [yellow] Assess and improve automation coverage for yast2-network
Actions #10

Updated by brhavel about 5 years ago

  • Subject changed from [qam] [yellow] Assess and improve automation coverage for yast2-network to [qam][yellow][urgent] Assess and improve automation coverage for yast2-network
Actions #11

Updated by brhavel almost 5 years ago

  • Priority changed from Normal to Urgent
Actions #12

Updated by brhavel over 4 years ago

as the test was already finished and is running, can we resolve the ticket and address maintenance in separated tickets?

Actions #13

Updated by brhavel over 4 years ago

  • Subject changed from [qam][yellow][urgent] Assess and improve automation coverage for yast2-network to [qam][maint][yast2-network][urgent] Assess and improve automation coverage for yast2-network
Actions #14

Updated by tjyrinki_suse over 4 years ago

  • Status changed from In Progress to Blocked
  • Assignee deleted (vsvecova)

Unassigning since no progress and not part of current sprint, assuming blocked. (please update with any information)

Actions #15

Updated by tjyrinki_suse over 4 years ago

  • Priority changed from Urgent to High

Readjusting priorities of several tasks to present them more hierarchically.

Actions #16

Updated by vpelcak over 4 years ago

  • Priority changed from High to Normal
Actions #17

Updated by vpelcak about 4 years ago

  • Subject changed from [qam][maint][yast2-network][urgent] Assess and improve automation coverage for yast2-network to [qam][maint][yast2-network] Assess and improve automation coverage for yast2-network
Actions #18

Updated by vpelcak about 4 years ago

  • Priority changed from Normal to Urgent
Actions #19

Updated by tjyrinki_suse about 4 years ago

  • Priority changed from Urgent to High

Adjusting priority orders of some tickets.

Actions #20

Updated by vpelcak about 4 years ago

  • Priority changed from High to Urgent
Actions #21

Updated by tjyrinki_suse about 4 years ago

  • Priority changed from Urgent to High

At most High priority for new package specific tests that have score <10. yast2-network is 8.

Actions #22

Updated by tjyrinki_suse over 3 years ago

  • Subject changed from [qam][maint][yast2-network] Assess and improve automation coverage for yast2-network to [qe-core][qam][maint][yast2-network] Assess and improve automation coverage for yast2-network
Actions #23

Updated by tjyrinki_suse over 3 years ago

  • Project changed from 119 to qe-yam
  • Due date deleted (2019-02-01)
  • Status changed from Blocked to New
  • Priority changed from High to Normal
  • Target version deleted (QAM tests - current)
  • Start date deleted (2018-10-30)

One more QE Yast issue found that likely is not more relevant than any other old/stale ones and could be, once time for cleaning up all the old tickets, evaluated together with the whole current setup.

Actions #24

Updated by tjyrinki_suse over 3 years ago

  • Subject changed from [qe-core][qam][maint][yast2-network] Assess and improve automation coverage for yast2-network to [qem][maint][yast2-network] Assess and improve automation coverage for yast2-network
Actions #25

Updated by riafarov over 3 years ago

  • Subject changed from [qem][maint][yast2-network] Assess and improve automation coverage for yast2-network to Assess and improve automation coverage for yast2-network
  • Target version set to future
Actions #26

Updated by riafarov over 3 years ago

  • Tracker changed from action to coordination
Actions #27

Updated by JERiveraMoya almost 2 years ago

  • Status changed from New to Rejected

For now we still don't plan to extend test coverage, and even less in the area of networking as libyui REST afik would not work out of the box.

Actions

Also available in: Atom PDF