Project

General

Profile

action #42800

[kernel] Require a two disk s390x machine type to run xfstests

Added by yosun almost 3 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
QE Kernel - QE Kernel Done
Start date:
2019-02-18
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

For now the s390x worker has only one disk(around 20GB), and it don't have enough place to get a 20GB /home partition(we need a 20GB partition to split to a 10GB test partition and 10GB scratch partition).
So now we need to test xfstests on s390x manually in each milestone.
After many try, we couldn't find a way to run xfstests in that worker. Could someone help with following solution? to make one of them will help this.

  • Add one more disk(>=20GB) for the s390x worker
  • Gives more space for s390x disk, and create a 20~30GB /home during installation.

Subtasks

action #48071: [functional][u][kernel]Transfer s390x-zVM-2disk machine type from zVM to KVMResolvedmgriessmeier

History

#1 Updated by mgriessmeier almost 3 years ago

is it about automation?
for manual testing we have some machines with two disks which can be used for this.
for bigger disk I need to involve Ihno

#2 Updated by yosun almost 3 years ago

Yes, for automation on openQA. Two disk is better than a big one, since with one disk, SLES didn't automatically create a new partition for /home during installation for s390x. That's the different in s390x with other arches.
For manually test I have linux154 with two disk could make xfstests.

#3 Updated by mgriessmeier almost 3 years ago

ok for that I need to open a request to infra to assign an additional disk to one or two openQA z/VM guests - right now we have that only for development guests.

#4 Updated by yosun almost 3 years ago

Thank you, after deploy it, will it named with a special machine type in osd?

#5 Updated by okurz almost 3 years ago

  • Category set to Infrastructure

#6 Updated by okurz almost 3 years ago

  • Subject changed from Require a two disk s390x machine type to run xfstests to [functional][u] Require a two disk s390x machine type to run xfstests
  • Status changed from New to In Progress
  • Assignee set to mgriessmeier
  • Target version set to Milestone 20

As mgriessmeier is fine to help with that let's reflect it properly on the qsf-u team's backlog

#7 Updated by mgriessmeier almost 3 years ago

  • Status changed from In Progress to Blocked

created https://infra.nue.suse.com/Ticket/Display.html?id=123556&results=a96893c74d69668160a805ef25046bc4
as request for an additional DASD to LINUX152 and LINUX153

#8 Updated by mgriessmeier almost 3 years ago

  • Status changed from Blocked to Workable
  • Assignee changed from mgriessmeier to yosun

Infra ticket is solved - we have two workers in production now, which have a second disk of the same size at 0.0.0200 (LINUX152 and LINUX153 - openqaworker2:1 and openqaworker2:2)
I suggest the following to ensure that the tests are running on one of those two machines:

#9 Updated by yosun almost 3 years ago

Thank you, but I'm not sure if I have the promission to create new machine type(s390x-zVM-2disk) in osd. I only feel good to modify in "testsuite" and "job group" pages ;)
Could some one in tools team help to do that please?

#10 Updated by cachen almost 3 years ago

yosun wrote:

Thank you, but I'm not sure if I have the promission to create new machine type(s390x-zVM-2disk) in osd. I only feel good to modify in "testsuite" and "job group" pages ;)
Could some one in tools team help to do that please?

@Sero, For sure you can create PR to gitlab for review/merge as well ;)

mgriessmeier, thank you for the help :)

#11 Updated by yosun almost 3 years ago

Good to know it :)

Merge request has created to add machine type
https://gitlab.suse.de/openqa/salt-pillars-openqa/merge_requests/141

#12 Updated by okurz almost 3 years ago

MR merged

#13 Updated by okurz almost 3 years ago

  • Subject changed from [functional][u] Require a two disk s390x machine type to run xfstests to [kernel] Require a two disk s390x machine type to run xfstests
  • Target version changed from Milestone 20 to Milestone 21

#14 Updated by mgriessmeier almost 3 years ago

hey,

I've noticed https://openqa.suse.de/tests/2291162 showing up as incomplete in the functional job group
The issue is that the machine was created with backend svirt instead of s390x.
also, the scheduled job is a create_hdd job which is not possible in z/VM.

I'd suggest the following for the future: please test those new tests/machines in the job development group to not pollute the functional group with incomplete tests

#15 Updated by yosun almost 3 years ago

Yes, sure, I disabled it in function job group. I didn't find a example to install zVM, any idea which job is for installing that?

#16 Updated by mgriessmeier almost 3 years ago

yosun wrote:

Yes, sure, I disabled it in function job group. I didn't find a example to install zVM, any idea which job is for installing that?

every job which is assigned to s390x-zVM* Machine - but you need to load your tests on top that installation, since we cannot boot from a qcow image there

#17 Updated by yosun over 2 years ago

  • Target version changed from Milestone 21 to 445

#18 Updated by metan over 2 years ago

  • Target version changed from 445 to 454

#19 Updated by yosun over 2 years ago

  • Status changed from Workable to Resolved

Resolved, deployed xfstests for s390x

#20 Updated by pcervinka 11 months ago

  • Target version changed from 454 to QE Kernel Done

Also available in: Atom PDF