Project

General

Profile

action #41849

coordination #42128: [functional][y][epic] Adjust partitioning tests to changes in storage-ng

[functional][y] test fails in partitioning_raid - RAID toolbar has changed thus shortcut is different

Added by mlin7442 almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 20
Start date:
2018-10-01
Due date:
2018-10-23
% Done:

0%

Estimated time:
8.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1:S:C-Staging-DVD-x86_64-RAID1@64bit fails in
partitioning_raid

Within newer storage-ng, the toolbar in RAID page only have 'Add Raid' button left, the shortcut has changed.

Note: this failure also appears in SLE15 SP1 last build.

Reproducible

Fails since (at least) Build 13.7

Expected result

Last good: 13.5 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #41945: [functional][y] Adapt the test to the new UI of the partitionerResolved2018-10-032018-11-20

Blocks openQA Tests - action #41852: [functional][y][sle] add more staging testsResolved2018-10-012018-11-20

Blocks openQA Tests - action #41300: [sle][functional][y][fast] test fails in partitioning_raid - xvdb cannot be selectedResolved2018-09-192018-10-23

Copied to openQA Tests - action #42902: [functional][y] Re-enable RAID tests in Leap 15.1 stagingResolved2018-10-012018-11-06

History

#1 Updated by okurz almost 4 years ago

  • Subject changed from test fails in partitioning_raid - RAID toolbar has changed thus shortcut is different to [functional][y] test fails in partitioning_raid - RAID toolbar has changed thus shortcut is different
  • Due date set to 2018-10-23
  • Priority changed from Normal to High
  • Target version set to Milestone 20

#2 Updated by riafarov over 3 years ago

  • Estimated time set to 8.00 h

#3 Updated by riafarov over 3 years ago

  • Status changed from New to Workable

#4 Updated by lnussel over 3 years ago

meanwhile I've removed the RAID1 test from leap 15.1 staging to unblock us there.

#5 Updated by riafarov over 3 years ago

  • Description updated (diff)

#6 Updated by okurz over 3 years ago

  • Description updated (diff)

dimstar and behlert asked for an ETA but they currently are fine with the ETA of 2 days - 1 week when we pick up this ticket as the next in queue.

#7 Updated by okurz over 3 years ago

  • Blocks action #41852: [functional][y][sle] add more staging tests added

#8 Updated by JERiveraMoya over 3 years ago

  • Assignee set to JERiveraMoya

#9 Updated by JERiveraMoya over 3 years ago

  • Related to action #41945: [functional][y] Adapt the test to the new UI of the partitioner added

#10 Updated by riafarov over 3 years ago

  • Parent task set to #42128

#11 Updated by JERiveraMoya over 3 years ago

  • Status changed from Workable to Feedback

#12 Updated by JERiveraMoya over 3 years ago

  • Status changed from Feedback to In Progress

#13 Updated by JERiveraMoya over 3 years ago

For the VR, I need to check RAID0 too (I was focus in RAID 1 and I think there are small changes needed, needles I hope)

#14 Updated by JERiveraMoya over 3 years ago

  • Verification run:

Expecting some missing needles for remaining RAID configurations, I'm going to try to create them before resolving this ticket.

#15 Updated by JERiveraMoya over 3 years ago

Needles created for all RAID configurations in sle15sp1.

PR - Fix partition raid for UI changes - rest of archs includes:

#16 Updated by okurz over 3 years ago

  • Blocks action #41300: [sle][functional][y][fast] test fails in partitioning_raid - xvdb cannot be selected added

#17 Updated by riafarov over 3 years ago

  • Blocks deleted (action #41300: [sle][functional][y][fast] test fails in partitioning_raid - xvdb cannot be selected)

#18 Updated by riafarov over 3 years ago

  • Blocks action #41300: [sle][functional][y][fast] test fails in partitioning_raid - xvdb cannot be selected added

#19 Updated by JERiveraMoya over 3 years ago

All needles created. No more job failing in the sle15sp1 overview page except for the ones which have LVM on top, which I dealing with in #41300

#20 Updated by riafarov over 3 years ago

  • Status changed from In Progress to Resolved

#21 Updated by okurz over 3 years ago

  • Due date changed from 2018-10-23 to 2018-11-06
  • Status changed from Resolved to In Progress

I think we have not yet re-enabled RAID1 in according staging tests, right? See #41849#note-4

#22 Updated by JERiveraMoya over 3 years ago

  • Copied to action #42902: [functional][y] Re-enable RAID tests in Leap 15.1 staging added

#23 Updated by JERiveraMoya over 3 years ago

  • Due date changed from 2018-11-06 to 2018-10-23

Created #42902 to tackle.

#24 Updated by JERiveraMoya over 3 years ago

  • Status changed from In Progress to Resolved

#25 Updated by okurz over 3 years ago

thx

Also available in: Atom PDF