Project

General

Profile

action #41300

coordination #42128: [functional][y][epic] Adjust partitioning tests to changes in storage-ng

[sle][functional][y][fast] test fails in partitioning_raid - xvdb cannot be selected

Added by zluo about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 20
Start date:
2018-09-19
Due date:
2018-10-23
% Done:

0%

Estimated time:
Difficulty:

Description

As I can see that xvdb cannot be selected so the needle match failed.

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-lvm+RAID1@svirt-xen-hvm fails in
partitioning_raid

Reproducible

Fails since (at least) Build 43.1 (current job)

Expected result

Last good: 41.4 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocked by openQA Tests - action #41849: [functional][y] test fails in partitioning_raid - RAID toolbar has changed thus shortcut is differentResolved2018-10-012018-10-23

History

#1 Updated by zluo about 4 years ago

this can be a sporadic issue...

#2 Updated by okurz about 4 years ago

  • Target version set to Milestone 20

so far happened only once. To be reviewed later.

#3 Updated by okurz about 4 years ago

  • Blocked by action #41849: [functional][y] test fails in partitioning_raid - RAID toolbar has changed thus shortcut is different added

#4 Updated by okurz about 4 years ago

  • Status changed from New to Blocked
  • Assignee set to JERiveraMoya

#5 Updated by riafarov about 4 years ago

  • Subject changed from [sle][functional][y] test fails in partitioning_raid - xvdb cannot be selected to [sle][functional][y][fast] test fails in partitioning_raid - xvdb cannot be selected
  • Due date set to 2018-10-23

#6 Updated by riafarov about 4 years ago

  • Blocked by deleted (action #41849: [functional][y] test fails in partitioning_raid - RAID toolbar has changed thus shortcut is different)

#7 Updated by riafarov about 4 years ago

  • Parent task set to #42128

#8 Updated by riafarov about 4 years ago

  • Blocked by action #41849: [functional][y] test fails in partitioning_raid - RAID toolbar has changed thus shortcut is different added

#9 Updated by riafarov about 4 years ago

https://openqa.suse.de/tests/2175049#settings now it fails on entering volume group name, not sure if that's because we have different performance on hyper-v or something else. If you could please take a look.

#11 Updated by riafarov about 4 years ago

  • Status changed from Blocked to Feedback

#12 Updated by JERiveraMoya about 4 years ago

  • Status changed from Feedback to In Progress

#13 Updated by JERiveraMoya about 4 years ago

Besides some needles, it requires a bit of adjustment in the drop-down menu:
PR - Fix lvm on top of raid partitioning

#14 Updated by JERiveraMoya about 4 years ago

  • Status changed from In Progress to Feedback

#15 Updated by JERiveraMoya about 4 years ago

  • Status changed from Feedback to In Progress

All lvm on top of raid passing, jobs restarted and missing needles created .
Now we need to wait for results after PR - Update LVM workflow to recent storage-ng updates from mloviska will be merged.

#16 Updated by JERiveraMoya about 4 years ago

  • Status changed from In Progress to Feedback

Forgot to branch code also for sle12sp4: PR - Fix partition raid for sle12sp4 to avoid this job failing Besides that, I think needs some other adjustment according last build sle12sp4.

#17 Updated by JERiveraMoya about 4 years ago

PR includes reverse of if/else logic we missed in PR review after mloviska PR was merged.

#18 Updated by JERiveraMoya about 4 years ago

  • Status changed from Feedback to In Progress

#19 Updated by riafarov about 4 years ago

  • Status changed from In Progress to Resolved

This is also already fixed. Thanks!
https://openqa.suse.de/tests/2197287

Also available in: Atom PDF