Project

General

Profile

action #40766

[functional][y] test fails in yast2_network_settings

Added by lnussel about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 19
Start date:
2018-09-10
Due date:
2018-09-25
% Done:

0%

Estimated time:
3.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-x86_64-yast2_gui@64bit fails in
yast2_network_settings

Needs to handle NetworkManager. NM is now default for desktop installs on 15.1

Reproducible

Fails since (at least) Build 300.2

Expected result

Last good: 299.2 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #41429: [functional][y] test fails in yast2_network_setup - another case related to NM is the default network managementResolved2018-09-212018-10-09

Related to openQA Tests - action #41564: [functional][y] test fails in yast2_network_setupRejected2018-09-252018-10-09

Has duplicate openQA Tests - action #41141: [functional][y] test fails in yast2_lan_restart_devices - related to recent default changed to network manager?Rejected2018-09-172018-10-09

History

#2 Updated by okurz about 4 years ago

  • Subject changed from test fails in yast2_network_settings to [functional][y] test fails in yast2_network_settings
  • Due date set to 2018-09-25
  • Priority changed from Normal to High
  • Target version set to Milestone 19

#3 Updated by riafarov about 4 years ago

  • Status changed from New to Workable

#4 Updated by JERiveraMoya about 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

#5 Updated by JERiveraMoya about 4 years ago

  • Status changed from In Progress to Feedback

#6 Updated by riafarov about 4 years ago

  • Estimated time set to 3.00 h

#7 Updated by JERiveraMoya about 4 years ago

  • Status changed from Feedback to In Progress

#8 Updated by mlin7442 about 4 years ago

same for TW now https://openqa.opensuse.org/tests/753439#step/yast2_network_settings/7 , no needs to be Leap 15.1+ specific.

#9 Updated by okurz about 4 years ago

could it be that yast2_lan_restart in https://openqa.opensuse.org/tests/753633#step/yast2_lan_restart/14 has the same problem?

#10 Updated by mlin7442 about 4 years ago

okurz wrote:

could it be that yast2_lan_restart in https://openqa.opensuse.org/tests/753633#step/yast2_lan_restart/14 has the same problem?

I thought so. And I found another one https://openqa.opensuse.org/tests/753961#step/yast2_lan_hostname/7

#11 Updated by JERiveraMoya about 4 years ago

  • Status changed from In Progress to Feedback

Thanks both for pointing me to those failures ;)

#13 Updated by JERiveraMoya about 4 years ago

PR - Unschedule yast2_lan_restart_devices when Network Manager-2nd try (I thought it will be easy the condition :( but it was not so straightforward, it needed more love :) )

#14 Updated by JERiveraMoya about 4 years ago

  • Status changed from Feedback to Resolved

#15 Updated by okurz about 4 years ago

  • Status changed from Resolved to In Progress

It's great you made sure the tests do not fail but I see one flaw unless I am really wrong here. https://openqa.opensuse.org/tests/751370#step/yast2_network_settings/7 fails because the assert_screen only expects "yast2-lan-ui" but https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/yast2_gui/yast2_network_settings.pm#L34 states that it should look for "yast2-lan-warning-network-manager" as well which it does not. I think the test code is not doing what it should and this is what we should look into.

#16 Updated by JERiveraMoya about 4 years ago

This example that you mentioned is outdated, I am ignoring Leap during last days, unfortunately I cannot get the parent image not even retrigering like other times I did as the qcows disappear really fast and end up failing in some zypper that cannot get stuff from current build.
The logic for the warning should be ok also for Leap as it is working for TW. "yast2-lan-ui", I am not expecting any difference and the solution in code I think should intercept this warning. If some needle is missing I can create on the fly in prod as the build arrives for Leap 15.1.

#17 Updated by okurz about 4 years ago

  • Status changed from In Progress to Resolved

Sorry, I think I confused the two test modules "yast2_lan_restart_devices" and "yast2_network_settings". I think we are good here.

#18 Updated by riafarov about 4 years ago

  • Has duplicate action #41141: [functional][y] test fails in yast2_lan_restart_devices - related to recent default changed to network manager? added

#19 Updated by riafarov about 4 years ago

  • Related to action #41429: [functional][y] test fails in yast2_network_setup - another case related to NM is the default network management added

#20 Updated by riafarov about 4 years ago

  • Related to action #41564: [functional][y] test fails in yast2_network_setup added

Also available in: Atom PDF