Project

General

Profile

action #38387

[functional][u][sporadic][medium] test fails in gnucash - window is not closed

Added by pcervinka over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 18
Start date:
2018-07-13
Due date:
2018-08-28
% Done:

0%

Estimated time:
3.00 h
Difficulty:
medium

Description

Observation

openQA test in scenario opensuse-15.0-DVD-Updates-x86_64-gnome@uefi fails in
gnucash

Reproducible

Fails since (at least) Build 20180713-1 (current job)

Expected result

Last good: 20180712-5 (or more recent)

Further details

Always latest result in this scenario: latest

Although was gnucash test updated recently, it stil sometimes fail to close window.


Related issues

Related to openQA Tests - action #38057: gnucash 3.2 does not ask to save when nothing happenedResolved2018-07-02

Related to openQA Tests - action #38114: [functional][u] GnuCash does not close on LXDEResolved2018-07-03

Related to openQA Tests - action #38702: [functional][u] apply workaround for bsc#1096401 "snapper terminates with core dump"Resolved2018-05-172018-08-14

Related to openQA Tests - action #39131: [functional][opensuse][u][easy] test fails in ooffice - turn off automatic suspend on gnomeResolved2018-08-032018-08-28

Related to openQA Tests - action #40172: [functional][opensuse][sporadic][u] automatic suspend affects several test modulesRejected2018-08-23

Related to openQA Tests - action #40319: [functional][u] test fails in gnucash - gnucash not closedResolved2018-08-282018-10-09

History

#1 Updated by pcervinka over 3 years ago

  • Related to action #38057: gnucash 3.2 does not ask to save when nothing happened added

#2 Updated by dimstar over 3 years ago

  • Related to action #38114: [functional][u] GnuCash does not close on LXDE added

#3 Updated by okurz over 3 years ago

  • Subject changed from test fails in gnucash - window is not closed to [functional][u][sporadic][fast] test fails in gnucash - window is not closed
  • Due date set to 2018-07-31
  • Status changed from New to In Progress
  • Target version set to Milestone 18

Hm, found one needle that did not match. Created that. Now let's see what the statistics will tell:

$ for i in {001..100} ; do openqa_clone_job_o3 --skip-chained-deps 709377 TEST=okurz_poo38387_$i BUILD=20180718-3:poo38387 _GROUP="Development Leap" ; done

-> https://openqa.opensuse.org/tests/overview?build=20180718-3%3Apoo38387&version=15.0&distri=opensuse&groupid=39

#4 Updated by okurz over 3 years ago

build was obsoleted, retriggered some jobs in the same build.

#5 Updated by okurz over 3 years ago

And now of course tests were not working anymore because the incident repo vanished. Retrying with more recent one:

for i in {001..100} ; do openqa_clone_job_o3 --skip-chained-deps 710696 TEST=okurz_poo38387_$i BUILD=20180721-3:poo38387 _GROUP="Development Leap" ; done

-> https://openqa.opensuse.org/tests/overview?groupid=39&distri=opensuse&version=15.0&build=20180721-3%3Apoo38387

#6 Updated by okurz over 3 years ago

again obsoleted by more recent update tests. This is not going to work this way. Nevertheless, taking a look at most recent production runs I could find https://openqa.opensuse.org/tests/711279#step/gnucash/22 where the "window" menu is activated after the dialog to "save file changes" is discarded. Looks like "alt-w" can cause this.

https://openqa.opensuse.org/tests/711074#step/gnucash/20 is another failure, openSUSE Tumbleweed gnome scenario, which shows the clock time 03:14 before start and also when seemingly the screen lock shows up, unless this is actually caused by the key presses?

#7 Updated by okurz over 3 years ago

  • Related to action #38702: [functional][u] apply workaround for bsc#1096401 "snapper terminates with core dump" added

#8 Updated by okurz over 3 years ago

Tried to test for stability locally again and hit another interesting/stupid/annoying/funny problem: http://lord.arch/tests/1729#step/gnucash/15 shows that the screen locked in the same minute that we installed packages, which is just one minute after we did the last typing so there should be no screenlock and not screen saver. However, taking a look at the journal in http://lord.arch/tests/1729/file/gnucash-journal.log one can see a sudden huge 3-day jump in the timestamps together with according output from chrony:

Jul 20 10:20:54 susetest PackageKit[18076]: install-packages transaction /4_edcceeaa from uid 1000 finished with success after 55100ms
Jul 20 10:20:54 susetest polkitd[838]: Unregistered Authentication Agent for unix-process:18082:168414 (system bus name :1.134, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Jul 20 10:20:56 susetest PackageKit[18076]: get-updates transaction /5_abcccacd from uid 1000 finished with success after 1471ms
Jul 20 10:20:57 susetest chronyd[713]: Selected source 217.114.59.3
Jul 20 10:20:57 susetest chronyd[713]: System clock wrong by 285436.951742 seconds, adjustment started
Jul 23 17:38:14 susetest chronyd[713]: System clock was stepped by 285436.951741 seconds
Jul 23 17:38:16 susetest chronyd[713]: Source 139.162.219.252 replaced with 178.79.160.57
Jul 23 17:38:33 susetest PackageKit[18076]: daemon quit
Jul 23 17:38:33 susetest packagekitd[18076]: Source ID 16 was not found when attempting to remove it
Jul 23 17:38:44 susetest unix2_chkpwd[20121]: pam_unix(xscreensaver:auth): authentication failure; logname= uid=1000 euid=0 tty= ruser= rhost=  user=bernhard
Jul 23 17:38:46 susetest unix2_chkpwd[20121]: pam_authenticate(xscreensaver, bernhard): Authentication failure

so what happened is that the test which I started from an older qcow snapshot for faster reproduction of good statistics ended up updating the time to the current time causing the screenlock to suddenly trigger which is certainly totally unexpected by the test. To ensure the test continuing in this very special – development approach specific – scenario would be disable the screensaver on lxde (we already do something similar on gnome and plasma). E.g. see https://unix.stackexchange.com/questions/356548/how-to-disable-screensaver-in-lxde and https://www.linuxquestions.org/questions/linux-desktop-74/disable-screensaver-in-lxde-745203/ or simply kill xscreensaver or something for the current session. Or I just reconduct the test from x11-user_gui_login I guess. What I tried for now is a local change

 sub handle_relogin {
     handle_logout;
+    assert_screen 'displaymanager', 90;
+    select_console 'root-console';
+    assert_script_run 'chronyc makestep';
+    select_console 'x11', await_console => 0;
     handle_login;
 }

#9 Updated by okurz about 3 years ago

20/20 jobs passed :(

Rebased test code and triggered run 21..60

#10 Updated by okurz about 3 years ago

Finally managed to reproduce some failures again: http://lord.arch/tests/overview?build=20180724:1&distri=opensuse&version=Tumbleweed shows now 6/60 jobs. I can identify one VLC needle that needs to be fixed and chromium failures. I guess it makes sense if I continue here because the current problem is not that I see how I could work any faster or need any help but just need to wait for long-running test jobs.

#11 Updated by okurz about 3 years ago

  • Subject changed from [functional][u][sporadic][fast] test fails in gnucash - window is not closed to [functional][u][sporadic] test fails in gnucash - window is not closed
  • Due date changed from 2018-07-31 to 2018-08-14

#12 Updated by okurz about 3 years ago

  • Status changed from In Progress to Workable
  • Assignee deleted (okurz)

And now my openQA installation on lord is not working anymore :( I need to give this back to the backlog.

What to do for whoever takes over:

  • Check current failures of mainly openSUSE Tumbleweed regarding gnucash failing
  • If any found, fix it

#13 Updated by okurz about 3 years ago

  • Due date changed from 2018-08-14 to 2018-08-28

bulk move to next sprint as could not be discussed in SR

#14 Updated by SLindoMansilla about 3 years ago

It may be a race condition on sending keys:

  • check-/assert_screen before sending key (sync point)

#15 Updated by SLindoMansilla about 3 years ago

  • Subject changed from [functional][u][sporadic] test fails in gnucash - window is not closed to [functional][u][sporadic][medium] test fails in gnucash - window is not closed
  • Estimated time set to 3.00 h
  • Difficulty set to medium

#16 Updated by SLindoMansilla about 3 years ago

  • Status changed from Workable to In Progress
  • Assignee set to SLindoMansilla

#17 Updated by SLindoMansilla about 3 years ago

  1. alt-f4 is pressed to close the help window
  2. alt-c is pressed to close the tips window
  3. ctrl-q is pressed to close gnucash

The problem is that sometimes ctrl-q seems to not take effect.
Trying asserting the screen before sending ctrl-q.

At the moment I need to figure out how to get this file on the worker /usr/share/qemu/ovmf-x86_64-ms-code.bin so I can verify locally (package qemu-ovmf).

#18 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Feedback

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5595

Merged. Waiting for verification run on O3.

As it was sporadic, trying 10 runs:

#19 Updated by okurz about 3 years ago

All failed in "zypper_add_repos" as the maintenance repo vanished in the mean time.

Let's try based on the latest aggregated repo:

$ for i in {001..100} ; do openqa_clone_job_o3 735474 TEST=sergio_poo38387_$i BUILD=20180817-3:poo38387 _GROUP="Development Leap" ; done

-> https://openqa.opensuse.org/tests/overview?version=15.0&build=20180817-3%3Apoo38387&groupid=39&distri=opensuse

#20 Updated by SLindoMansilla about 3 years ago

  • Status changed from Feedback to In Progress

Single verification on O3 (just verify that the changes doesn't brake anything): https://openqa.opensuse.org/tests/738356#step/gnucash/19

Trying multiple job runs again...

#21 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Resolved

#23 Updated by okurz about 3 years ago

#24 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Feedback

PR for KDE: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5621

Merged. Waiting for verification run on OSD.

#25 Updated by SLindoMansilla about 3 years ago

  • Related to action #39131: [functional][opensuse][u][easy] test fails in ooffice - turn off automatic suspend on gnome added

#26 Updated by SLindoMansilla about 3 years ago

  • Status changed from Feedback to In Progress

Auto suspend appears also on gnucash: https://openqa.opensuse.org/tests/739945#step/gnucash/18

Related to: #39131

#27 Updated by SLindoMansilla about 3 years ago

Automatic suspend is a different and sporadic issue that will be handled here: https://progress.opensuse.org/issues/40172

#28 Updated by SLindoMansilla about 3 years ago

  • Related to action #40172: [functional][opensuse][sporadic][u] automatic suspend affects several test modules added

#30 Updated by SLindoMansilla about 3 years ago

New needle for Leap (font type differs from tumbleweed): test-gnucash-1-tip-gnome-leap-20180823

#32 Updated by pcervinka about 3 years ago

Unfortunately, still fails on Leap 42.3: https://openqa.opensuse.org/tests/741153#step/gnucash/21.
Leap 15 is fine.

#33 Updated by SLindoMansilla about 3 years ago

That job started yesterday at 8:00~, my needle was created on the afternoon. My verification runs were canceled and the OBS repo removed. I am having problems to verify...

#34 Updated by SLindoMansilla about 3 years ago

ok, now it was about Leap 42.3, which also has a slightly different font type: test-gnucash-1-tip-gnome-leap-42.3-20180824

Waiting for verification run on O3: https://openqa.opensuse.org/tests/741205

#35 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Resolved

#36 Updated by okurz about 3 years ago

  • Related to action #40319: [functional][u] test fails in gnucash - gnucash not closed added

Also available in: Atom PDF