Project

General

Profile

action #38114

[functional][u] GnuCash does not close on LXDE

Added by dimstar over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 18
Start date:
2018-07-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-lxde@64bit fails in
gnucash

Reproducible

Fails since (at least) Build 20180629

Expected result

Last good: 20180628 (or more recent)

Further details

Always latest result in this scenario: latest

The GnuCash test works apparently on all desktops, but on LXDE, for some reason, the GnuCash window did not disappear (possibly timing?)


Related issues

Related to openQA Tests - action #35685: [opensuse][functional][u][sporadic][medium] Various unstable tests on o3 - user_gui_login + gnucashResolved2018-04-30

Related to openQA Tests - action #35604: [opensuse][functional][u] test fails in gnucash, not closing correctlyResolved2018-04-262018-07-17

Related to openQA Tests - action #34717: [functional][u][easy][fast] adjust gnucash test per gnucash 3.0 updateResolved2018-04-112018-06-19

Related to openQA Tests - action #38387: [functional][u][sporadic][medium] test fails in gnucash - window is not closedResolved2018-07-132018-08-28

History

#1 Updated by okurz over 3 years ago

  • Related to action #35685: [opensuse][functional][u][sporadic][medium] Various unstable tests on o3 - user_gui_login + gnucash added

#2 Updated by okurz over 3 years ago

  • Subject changed from GnuCash does not close on LXDE to [functional][u] GnuCash does not close on LXDE

#3 Updated by okurz over 3 years ago

  • Related to action #35604: [opensuse][functional][u] test fails in gnucash, not closing correctly added

#4 Updated by okurz over 3 years ago

Most likely the fix from #35604 needs to be applied again but properly without loosing the alternative match target.

#5 Updated by okurz over 3 years ago

  • Related to action #34717: [functional][u][easy][fast] adjust gnucash test per gnucash 3.0 update added

#6 Updated by okurz over 3 years ago

  • Target version set to future

#7 Updated by okurz over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz
  • Target version changed from future to Milestone 17

#9 Updated by dimstar over 3 years ago

  • Related to action #38387: [functional][u][sporadic][medium] test fails in gnucash - window is not closed added

#10 Updated by okurz over 3 years ago

  • Target version changed from Milestone 17 to Milestone 18

#11 Updated by okurz over 3 years ago

Let's see, as recent tests on lord.arch failed again because packages over pkcon can not be installed, probably because the tw snapshot from o3 got removed I triggered new tests based on the most recent TW snapshot 20180719:

sudo wget -c https://openqa.opensuse.org/tests/709859/asset/iso/openSUSE-Tumbleweed-DVD-x86_64-Snapshot201
80719-Media.iso -O /var/lib/openqa/factory/iso/openSUSE-Tumbleweed-DVD-x86_64-Snapshot20180719-Media.iso && sudo -u _openqa-worker sh -c '> /var/lib/openqa/po
ol/11/autoinst-log.txt; rm -f /var/lib/openqa/pool/11/ulogs/*' ; make test-compile-changed && sudo -u _openqa-worker perl /local/openQA/script/clone_job.pl --
skip-download --skip-chained-deps --from https://openqa.opensuse.org 709859 WORKER_CLASS=qemu_x86_64_tw REPO_OSS= REPO_NON_OSS= REPO_OSS_DEBUGINFO= EXCLUDE_MO
DULES=zypper_clear_repos,zypper_ar,salt MAKETESTSNAPSHOTS=1 _SKIP_POST_FAIL_HOOKS= TEST=lxde SKIPTO= TIMEOUT_SCALE=1 BUILD=20180719:1 ; for i in {001..20}; do
 sudo -u _openqa-worker perl /local/openQA/script/clone_job.pl --skip-download --skip-chained-deps --from https://openqa.opensuse.org 709859 WORKER_CLASS=qemu
_x86_64_tw REPO_OSS= REPO_NON_OSS= REPO_OSS_DEBUGINFO= EXCLUDE_MODULES=zypper_clear_repos,zypper_ar,salt _SKIP_POST_FAIL_HOOKS= TEST=lxde_$i SKIPTO=x11-user_g
ui_login TIMEOUT_SCALE=1 BUILD=20180719:1 ; done && tail -f /var/lib/openqa/pool/{33,10,11,12}/autoinst-log.txt

-> http://lord.arch/tests/overview?build=20180719%3A1&distri=opensuse&version=Tumbleweed

#12 Updated by okurz over 3 years ago

The results are … inconclusive. The screen lock kicked in all the time earlier then expected. Don't know what to do about it now.

#13 Updated by okurz over 3 years ago

  • Status changed from In Progress to Resolved

I consider my part done here for the LXDE specific part, however we have #38387 as a generic ticket still open about gnucash close problems.

Also available in: Atom PDF