Project

General

Profile

action #40319

[functional][u] test fails in gnucash - gnucash not closed

Added by mlin7442 about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 19
Start date:
2018-08-28
Due date:
2018-10-09
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-x86_64-kde@64bit-2G fails in
gnucash

gnucash not closed.

Reproducible

Fails since (at least) Build 297.2 (current job)

Expected result

Last good: 297.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #38387: [functional][u][sporadic][medium] test fails in gnucash - window is not closedResolved2018-07-132018-08-28

Blocked by openQA Project - action #41228: os-autoinst fails executing qemu-img info on the qcow2 imageResolved2018-09-19

History

#1 Updated by okurz about 3 years ago

  • Subject changed from test fails in gnucash to test fails in gnucash - gnucash not closed

#2 Updated by okurz about 3 years ago

  • Related to action #38387: [functional][u][sporadic][medium] test fails in gnucash - window is not closed added

#3 Updated by okurz about 3 years ago

  • Subject changed from test fails in gnucash - gnucash not closed to [functional][u] test fails in gnucash - gnucash not closed
  • Due date set to 2018-09-25
  • Status changed from New to Workable
  • Assignee set to SLindoMansilla
  • Priority changed from Normal to High
  • Target version set to Milestone 19

@SLindoMansilla please check if this is still an issue or resolved with your work on #38387

#4 Updated by SLindoMansilla about 3 years ago

  • Status changed from Workable to In Progress

checking

#5 Updated by SLindoMansilla about 3 years ago

The problem doesn't have to do with my changes, since the problem is that the main window of gnucash doesn't get the focus after closing the help window.

see: https://openqa.opensuse.org/tests/744023#step/gnucash/19

There is a post handling on a for loop to be sure that gnucash is closed. It detects the window open and sends ctrl-q

see: https://openqa.opensuse.org/tests/744023#step/gnucash/20

After that the popup confirmation is detected and alt-w is sent

see: https://openqa.opensuse.org/tests/744023#step/gnucash/21

the loop iterates faster than the display is refreshing causing a race condition, the popup is detected again and alt-w is sent, causing the window bar menu to open

see: https://openqa.opensuse.org/tests/744023#step/gnucash/22

Causing a fail.

Here is needed a sync point after each post handling event to avoid race conditions.

#8 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Feedback

#9 Updated by mlin7442 about 3 years ago

TW's gnucash does not show up 'saving window' after clicked close button in case have had empty content https://openqa.opensuse.org/tests/753777#step/gnucash/24 , I think the differ of behavior is depend on gnucash's version in this case, we should check whether 'saving window' appear. For the time being I created workaround needle below, those are just click on desktop actually, we can clean them up once we have a proper fix.

https://github.com/os-autoinst/os-autoinst-needles-opensuse/commit/fc270c4183d50902d05530465a2d94300c5136ed
https://github.com/os-autoinst/os-autoinst-needles-opensuse/commit/f8434cb337830feb22409e3725509119d84db23d

#11 Updated by SLindoMansilla about 3 years ago

  • Status changed from Feedback to In Progress

#12 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Feedback

Not able to test Leap 15.0 and Leap 42.3: https://progress.opensuse.org/issues/41228

But PR could be merged.

#13 Updated by SLindoMansilla about 3 years ago

  • Blocked by action #41228: os-autoinst fails executing qemu-img info on the qcow2 image added

#14 Updated by SLindoMansilla about 3 years ago

  • Due date changed from 2018-09-25 to 2018-10-09

Moving to sprint 27. Not able to finish during sprint 26.

#16 Updated by SLindoMansilla about 3 years ago

  • Status changed from Feedback to Resolved

Verified on OSD: https://openqa.opensuse.org/tests/overview?build=gnucash_poo40319

P.D.: Maintenance tests for gnucash on Leap 42.3 may still need needles.

#17 Updated by SLindoMansilla about 3 years ago

If gnucash fails again, check if it is problem of ensure_installed, and reuse this PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5830

Also available in: Atom PDF