Project

General

Profile

action #35641

[sle][functional][u][sporadic][mistyping] test fails in svirt_upload_assets - unchanged PS1

Added by mloviska over 3 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
Start date:
2018-04-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-s390x-create_hdd_gnome@zkvm fails in
svirt_upload_assets

PS1 prompt was not changed due to missed "which" from below command during execution of testapi::select_console(testapi_console='svirt').

testapi::type_string(string='which tput 2>&1 && PS1="\\[$(tput bold 2; tput setaf 1)\\]#\\[$(tput sgr0)\\] "', max_interval=250, wait_screen_changes=0, wait_still_screen=0)

This leads to unmatched needle at the end of this test module.

Reproducible

Fails since (at least) Build 589.1 (current job)

Expected result

Last good: 588.1 (or more recent)
Expected screen

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #34003: [tools] Better logging and error handling in case of remote console connections in consoles or backends, e.g. sshResolved2018-03-29

Related to openQA Tests - action #44339: [functional][u][mistyping] test fails in sshxterm - character missing in tput bold 2; tput setaf 1 making the test fail due to the needle not matching the expected promptRejected2018-11-26

Related to openQA Tests - action #25894: [sle][functional][opensuse]Mistyping in openQA again? - in kdeResolved2017-10-10

History

#1 Updated by okurz over 3 years ago

  • Related to action #34003: [tools] Better logging and error handling in case of remote console connections in consoles or backends, e.g. ssh added

#2 Updated by okurz over 3 years ago

  • Subject changed from [sle][functional][sporadic] test fails in svirt_upload_assets - unchanged PS1 to [sle][functional][u][sporadic] test fails in svirt_upload_assets - unchanged PS1
  • Status changed from New to Workable
  • Target version set to Milestone 17

#4 Updated by okurz about 3 years ago

  • Target version changed from Milestone 17 to future

please report when seen again, otherwise not planned to be worked on.

#5 Updated by okurz about 3 years ago

  • Target version changed from future to future

#6 Updated by okurz almost 3 years ago

  • Status changed from Workable to New

Bulk action to set status back to "New" for older tickets which are in "future". They would need to be revisited in time when we come up with a defined plan and assign to a milestone.

#7 Updated by okurz over 2 years ago

  • Related to action #44339: [functional][u][mistyping] test fails in sshxterm - character missing in tput bold 2; tput setaf 1 making the test fail due to the needle not matching the expected prompt added

#8 Updated by okurz over 2 years ago

  • Related to action #25894: [sle][functional][opensuse]Mistyping in openQA again? - in kde added

#9 Updated by okurz over 2 years ago

  • Subject changed from [sle][functional][u][sporadic] test fails in svirt_upload_assets - unchanged PS1 to [sle][functional][u][sporadic][mistyping] test fails in svirt_upload_assets - unchanged PS1

#10 Updated by szarate over 1 year ago

  • Status changed from New to Rejected

Also available in: Atom PDF