Project

General

Profile

action #25894

[sle][functional][opensuse]Mistyping in openQA again? - in kde

Added by dimstar almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Start date:
2017-10-10
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.1-kde@64bit fails in
updates_packagekit_kde

Reproducible

Fails since (at least) Build 20171009

Expected result

Last good: 20171008 (or more recent)

Further details

Always latest result in this scenario: latest

This is one that has repeatedly fired up wrong screens now - which so far I can't really explain (they make no sense)


Related issues

Related to openQA Tests - action #26852: [sle][functional][tools][BLOCKED][bsc#1041747] assert_script_run sometimes/randomly type a duplicate letter in the beginningResolved2017-10-192018-03-27

Related to openQA Tests - action #28657: [functional]Amarok rather frequently fails testResolved2017-11-302018-01-16

Related to openQA Tests - action #35641: [sle][functional][u][sporadic][mistyping] test fails in svirt_upload_assets - unchanged PS1Rejected2018-04-27

History

#1 Updated by okurz almost 4 years ago

  • Subject changed from Mistyping in openQA again? to [sle][functional][opensuse]Mistyping in openQA again? - in kde
  • Priority changed from Normal to Urgent

#2 Updated by okurz almost 4 years ago

‎[‎11 Oct 2017 13:19:53‏] ‎<‎okurz‎>‎ DimStar: but this is because in https://openqa.opensuse.org/tests/503187#step/updates_packagekit_kde/4 "help" is highlighted, right?
‎[‎11 Oct 2017 13:20:03‏] ‎<‎okurz‎>‎ so I don't think it's about typing or krunner but about focus
‎[‎11 Oct 2017 13:21:25‏] ‎<‎DimStar‎>‎ but help was also on focus in the screenshots that were stored to create needles - seems not to be new

#3 Updated by okurz almost 4 years ago

  • Due date set to 2017-11-08

#4 Updated by okurz almost 4 years ago

  • Related to action #26852: [sle][functional][tools][BLOCKED][bsc#1041747] assert_script_run sometimes/randomly type a duplicate letter in the beginning added

#5 Updated by okurz almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

Maybe I had a fix already for that? Need to check my own git log

#6 Updated by okurz almost 4 years ago

  • Due date changed from 2017-11-08 to 2017-11-22

#7 Updated by okurz almost 4 years ago

  • Target version set to Milestone 12

#8 Updated by okurz almost 4 years ago

  • Priority changed from Urgent to High

Couldn't see this problem in recent jobs that often. https://openqa.opensuse.org/tests/534455#step/prepare_system_for_update_tests/3 looks new because it is a problem in the console trying to type the user name "root" too early. I can try to look into that.

#9 Updated by okurz almost 4 years ago

that's interesting. Trying to reproduce the latest job on lord.arch failed for me consistently as incompletes already 10 times or so. Always in "post_zdup" and always without uploading the logfile, e.g. see http://lord.arch/tests/8050#downloads

What I see in the worker log is this:

[DEBUG] waitpid 6703 returned 0 with status -1
[ERROR] 500 response: Internal Server Error (remaining tries: 2)
[DEBUG] ## adding timer  5
[DEBUG] checking backend state
[DEBUG] waitpid 6703 returned 0 with status -1
[DEBUG] checking backend state
[DEBUG] waitpid 6703 returned 0 with status -1
[ERROR] 500 response: Internal Server Error (remaining tries: 1)
[DEBUG] ## adding timer  5
[DEBUG] checking backend state
[DEBUG] waitpid 6703 returned 0 with status -1
[DEBUG] checking backend state
[DEBUG] waitpid 6703 returned 0 with status -1
[DEBUG] checking backend state
[DEBUG] waitpid 6703 returned 0 with status -1
[ERROR] 500 response: Internal Server Error (remaining tries: 0)
[DEBUG] stop_job api-failure
[DEBUG] ## removing timer update_status
[DEBUG] ## removing timer check_backend
[DEBUG] ## removing timer job_timeout
[DEBUG] waiting for update_status to finish
[DEBUG] ## adding timer register_worker 10
[ERROR] Job aborted because web UI doesn't accept updates anymore (likely considers this job dead)
[DEBUG] stop_job 2nd part
[DEBUG] POST http://localhost/api/v1/jobs/8055/status
killed 6703

#10 Updated by okurz almost 4 years ago

  • Due date deleted (2017-11-22)

#11 Updated by okurz almost 4 years ago

  • Related to action #28657: [functional]Amarok rather frequently fails test added

#12 Updated by okurz almost 4 years ago

  • Priority changed from High to Low

should be addressed by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3941 and further PRs in the recent time. Looking at https://openqa.opensuse.org/tests/545051?limit_previous=100#previous the history looks more stable now and no failures of prepare_system_for_update_tests. Will keep on hold because I still want to run many more tests locally to check if there is maybe still another test module.

#14 Updated by okurz almost 4 years ago

  • Status changed from In Progress to Resolved

PR merged. zdup scenario seems to be very stable except for a sporadic failure of amarok which is tracked in #28657

#15 Updated by okurz over 2 years ago

  • Related to action #35641: [sle][functional][u][sporadic][mistyping] test fails in svirt_upload_assets - unchanged PS1 added

Also available in: Atom PDF