Project

General

Profile

action #35224

bootstrap 4: The message-box (pop-up) that shows failing needles stays forever

Added by SLindoMansilla over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2018-04-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Using google chrome and firefox.

Maybe the problem can be solved by showing the popup outside of the mouse over area.

Please, find screenshot attached.

forever_popup.jpg (356 KB) forever_popup.jpg SLindoMansilla, 2018-04-19 09:32
6037

Related issues

Related to openQA Project - action #35371: Tooltips are not working properlyRejected2018-04-23

History

#1 Updated by SLindoMansilla over 3 years ago

  • Description updated (diff)

#2 Updated by coolo over 3 years ago

  • Subject changed from [tools] The message-box (pop-up) that shows failing needles stays forever to bootstrap 4: The message-box (pop-up) that shows failing needles stays forever
  • Target version set to Current Sprint

this hinders reviewers a lot - but I don't have this problem. So finding out what triggers this is part of the fun

#3 Updated by mkittler over 3 years ago

  • Assignee set to mkittler

I tested this and even changed the code a little bit to make it work again. But it seems only in certain cases. I can reproducible under eg. https://openqa.suse.de/tests/overview?distri=sle&version=15&build=574.1&groupid=110).

Since it does not happen all the time, I first thought it might only concern older browser versions. It would be great if you could provide your version next time (on issues like that), eg.:

rpm -qf /usr/bin/{chromium,firefox} /opt/google/chrome/chrome
chromium-65.0.3325.181-2.1.x86_64
MozillaFirefox-59.0.2-1.2.x86_64
google-chrome-stable-55.0.2883.87-1.x86_64

Maybe the problem can be solved by showing the popup outside of the mouse over area.

Yes, the wrong positioning of the tooltip is the problem. I thought I fixed that but apparently not in all cases.

#4 Updated by mkittler over 3 years ago

  • Status changed from New to In Progress

PR: https://github.com/os-autoinst/openQA/pull/1624

This fix got hacky. I really don't know why the positioning is messed under Bootstrap 4. We should keep this in mind when upgrading Boostrap/jQuery because if the behavior of those libraries changes in the future, we might need to remove this hack again.

#5 Updated by dheidler over 3 years ago

Also the align in the popup should be left, not center - at least when we are showing a list.

#6 Updated by mkittler over 3 years ago

dheidler I also noticed the alignment and fixed it btw.

However, it turns out that my hack for the main issue doesn't work very well in all cases, too. So I still try to figure something out. I have to find the actual cause of the issue. Hacking around it doesn't seem to be a solution. Note that the current code for this tooltip is kind of messy.

If nothing works, I could try to re-implement this as popover.

#7 Updated by szarate over 3 years ago

  • Status changed from In Progress to Resolved

#8 Updated by szarate over 3 years ago

  • Target version changed from Current Sprint to Done

#9 Updated by szarate over 3 years ago

  • Related to action #35371: Tooltips are not working properly added

Also available in: Atom PDF