Project

General

Profile

action #33649

[sle][functional][u][medium] File /root/snapfile not found

Added by mlin7442 over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-22
Due date:
2018-04-10
% Done:

0%

Estimated time:
Difficulty:
medium

Description

Observation

openQA test in scenario opensuse-15.0-DVD-x86_64-extra_tests_filesystem@64bit fails in
snapper_undochange

/root/snapfile cannot be found, the tests in question use /root and assume it's not writable - /root is not a separate subvolume so it's writable even when loading a read-only filesystem. so the tests shouldn't use /root when testing if the filesystem is ro. It should use pretty much anywhere besides /root

Reproducible

Fails since (at least) Build 173.1

Expected result

Last good: 172.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #34018: [functional][fast][yast][y][easy]test fails in yast2_snapper - need to select different directory to unpack data to, e.g. '/'Resolved2018-03-292018-04-10

History

#1 Updated by lnussel over 4 years ago

This is due to /root on a separate subvolume: https://bugzilla.suse.com/show_bug.cgi?id=1085266

All tests that use /root for something related to snapshot rollback need to use a different directory.

#2 Updated by riafarov over 4 years ago

  • Description updated (diff)

#3 Updated by riafarov over 4 years ago

  • Subject changed from File /root/snapfile not found to [sle][functional] File /root/snapfile not found
  • Description updated (diff)
  • Due date set to 2018-04-10
  • Status changed from New to Workable

#4 Updated by dimstar over 4 years ago

Also impacted: Tumbleweed/boot_into_snapshot:
https://openqa.opensuse.org/tests/643977#step/boot_into_snapshot/11

#5 Updated by okurz over 4 years ago

  • Category set to Bugs in existing tests
  • Priority changed from Normal to Urgent
  • Target version set to Milestone 15

because of currently failing tests

#6 Updated by okurz over 4 years ago

  • Subject changed from [sle][functional] File /root/snapfile not found to [sle][functional][u][medium] File /root/snapfile not found

#7 Updated by oorlov over 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#8 Updated by cwh over 4 years ago

  • Difficulty set to medium

#9 Updated by okurz over 4 years ago

  • Related to action #34018: [functional][fast][yast][y][easy]test fails in yast2_snapper - need to select different directory to unpack data to, e.g. '/' added

#10 Updated by oorlov over 4 years ago

As /root is not a sub-volume by default on SUSE distributions, the /root folder is excluded by snapper while doing snapshots of the system.

I've changed the path to a dummy file, that is used to simulate system changing from '/root/snapfile' to '/etc/snapfile'.

Pull request: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4737

#11 Updated by oorlov over 4 years ago

  • Status changed from In Progress to Feedback

#12 Updated by okurz over 4 years ago

PR merged, now to "boot_to_snapshot" as mentioned in #33649#note-4

#14 Updated by okurz over 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF