Project

General

Profile

Actions

action #34018

closed

[functional][fast][yast][y][easy]test fails in yast2_snapper - need to select different directory to unpack data to, e.g. '/'

Added by okurz almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-29
Due date:
2018-04-10
% Done:

0%

Estimated time:
Difficulty:
easy

Description

Observation

openQA test in scenario sle-15-Installer-DVD-Staging:C-x86_64-gnome@64bit-staging fails in
yast2_snapper as well as in openSUSE Tumbleweed in https://openqa.opensuse.org/tests/645411#step/yast2_snapper_ncurses/26

Reproducible

Fails since (at least) Build C.436.2 (current job)

Expected result

Last good: C.435.1 (or more recent)

There is a change in SLE15 staging as well as openSUSE Tumbleweed to '/root' becomes a subvolume which is an accepted product change. Also see #33649. RMs and PO (okurz) have discussed and suggest to create a test dir under / directly to unpack test data there.

Tasks

Further details

Always latest result in this scenario: latest


Related issues 2 (0 open2 closed)

Related to openQA Tests - action #33649: [sle][functional][u][medium] File /root/snapfile not foundResolvedoorlov2018-03-222018-04-10

Actions
Copied to openQA Tests - action #34039: [functional][yast][y][easy]openSUSE staging tests do not execute yast2_snapper because HDDSIZEGB=10 whereas on SLE it is HDDSIZEGB=20 triggering the test -> adapt oS to SLE onesResolvedJERiveraMoya2018-03-292018-05-08

Actions
Actions #1

Updated by okurz almost 6 years ago

  • Status changed from Workable to In Progress
  • Assignee set to okurz

proposing a patch.

Actions #2

Updated by okurz almost 6 years ago

  • Related to action #33649: [sle][functional][u][medium] File /root/snapfile not found added
Actions #3

Updated by okurz almost 6 years ago

  • Subject changed from [functional][yast][y][easy]test fails in yast2_snapper - need to select different directory to unpack data to, e.g. '/' to [functional][fast][yast][y][easy]test fails in yast2_snapper - need to select different directory to unpack data to, e.g. '/'
Actions #4

Updated by okurz almost 6 years ago

while testing oorlov ran into https://github.com/openSUSE/snapper/issues/168 so we selected /etc as a directory. I created a change to the test code and SLE15 needles but because mainly all products we test, e.g. maintenance ones, are influenced we have to be a bit more careful. For now I will go with a backward compatible approach to be able to not impact older products but still roll out the fix today for TW and Leap/SLE 15.

Actions #5

Updated by okurz almost 6 years ago

  • Copied to action #34039: [functional][yast][y][easy]openSUSE staging tests do not execute yast2_snapper because HDDSIZEGB=10 whereas on SLE it is HDDSIZEGB=20 triggering the test -> adapt oS to SLE ones added
Actions #6

Updated by okurz almost 6 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4730 ready. So far I have only SLE15 needles for the GUI module yast2_snapper so TW, Leap 15.0, yast2_snapper_ncurses are all missing but IMHO can not be worse because these tests already fail. By merging the test PR now nevertheless (and the SLE needles) we can scale out the needle creation for the individual products and test modules

Actions #7

Updated by okurz almost 6 years ago

PR merged, monitoring jobs on osd and o3.

Actions

Also available in: Atom PDF