Project

General

Profile

action #28276

[sle][functional][medium][yast][y] test fails in iscsi_server - needs needle update and further investigation

Added by okurz over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-11-23
Due date:
2018-05-22
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 129

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-iscsi_server@64bit fails in
iscsi_server

Reproducible

Fails since (at least) Build 288.8

Expected result

Last good: SLE 12 SP3 GM

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #25308: [sle][functional][easy]test fails in iscsi_configuration - probably needle issueResolved2017-09-152017-12-19

Related to openQA Tests - action #23554: [sle][functional][tools][yast][y][hard] test fails in iscsi_configuration because of missing updated needle iscsi-ibft / missing iscsi server on osd?Resolved2017-08-232018-05-22

Related to openQA Tests - action #32452: [sle][funtional][y][easy] test fails in iscsi_client need adaptionResolved2018-02-28

Has duplicate openQA Tests - action #32104: [sles 15][functional] test fails in parent test iscsi server - and iscsi_client stoppedRejected2018-02-21

History

#1 Updated by okurz over 2 years ago

  • Related to action #25308: [sle][functional][easy]test fails in iscsi_configuration - probably needle issue added

#2 Updated by jorauch over 2 years ago

  • Assignee set to jorauch

#3 Updated by jorauch over 2 years ago

  • Subject changed from [sle][functional][easy]test fails in iscsi_server - needs needle update to [sle][functional][medium]test fails in iscsi_server - needs needle update and further investigation

#4 Updated by okurz over 2 years ago

agreed, very wrong ;) please try to reproduce with the latest build

#5 Updated by jorauch over 2 years ago

Still wrong in current build:
http://pinky.arch.suse.de/tests/275#step/iscsi_server/33
Next steps:

  • Verify if this firewall behaviour is wanted Either
  • create a workaround
  • wait for firewall to be fixed or
  • add the adaption of the firewall settings

#6 Updated by jorauch over 2 years ago

Popup might be because of my local networking settings, need to check that first

#7 Updated by jorauch over 2 years ago

Also happens in production, so no error in my setup
https://openqa.suse.de/tests/1320281

#8 Updated by jorauch over 2 years ago

  • Status changed from In Progress to Feedback

#9 Updated by okurz over 2 years ago

  • Due date changed from 2017-12-19 to 2018-01-31
  • Status changed from Feedback to Blocked
  • Target version changed from Milestone 12 to Milestone 13

Tracked by yast team in https://trello.com/c/99OkErr6, blocked by dev

#10 Updated by mgriessmeier over 2 years ago

  • Due date changed from 2018-01-31 to 2018-01-30

#11 Updated by riafarov over 2 years ago

  • Due date changed from 2018-01-30 to 2018-03-13
  • Target version changed from Milestone 13 to Milestone 14

Revisit when firewalld is implemented

#12 Updated by okurz over 2 years ago

  • Related to action #23554: [sle][functional][tools][yast][y][hard] test fails in iscsi_configuration because of missing updated needle iscsi-ibft / missing iscsi server on osd? added

#13 Updated by jorauch over 2 years ago

https://openqa.suse.de/tests/1447648#step/iscsi_server/42
Shortcut has changed from alt-p to alt-l furthermore it looks like not blocked anymore?

#14 Updated by okurz over 2 years ago

  • Status changed from Blocked to Workable

Yes, workable. I VERIFIED FIXED the bug. I suggest you can as a next step try it out manually and then update the test accordingly. Feel free to unassign from the ticket for the next sprint though as well.

#15 Updated by okurz over 2 years ago

  • Has duplicate action #32104: [sles 15][functional] test fails in parent test iscsi server - and iscsi_client stopped added

#16 Updated by jorauch about 2 years ago

  • Assignee deleted (jorauch)

Created PR to share progress:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4536
Unassigning myself since no further progress and unable to work on this until monday

#17 Updated by mgriessmeier about 2 years ago

happens in RC1C1

#18 Updated by jorauch about 2 years ago

  • Assignee set to jorauch

#19 Updated by jorauch about 2 years ago

  • Status changed from Workable to Feedback
  • Assignee changed from jorauch to riafarov

#20 Updated by riafarov about 2 years ago

  • Assignee changed from riafarov to jorauch

Run doesn't load fully, I'll come to you later to discuss what problem you face.

#21 Updated by okurz about 2 years ago

  • Due date changed from 2018-03-13 to 2018-03-27
  • Target version changed from Milestone 14 to Milestone 15

#22 Updated by jorauch about 2 years ago

  • Status changed from Feedback to In Progress

riafarov suggested replacing -1 by 0 for LUN number
Additionally report bug about about "plese" in error message

#23 Updated by jorauch about 2 years ago

  • Status changed from In Progress to Blocked

Manually testing settings showed that no combination is able to finish the module, therefore created:
https://bugzilla.suse.com/show_bug.cgi?id=1085421
IMHO we could merge the code anyway to monitor this on OSD

#24 Updated by okurz about 2 years ago

Please make sure to always mention a proper "expected result". If the bug reporter can not state what is the expected result anyone that likes to pick up the bug to fix it can have a very hard time

#25 Updated by jorauch about 2 years ago

Added the SLE12 SP3 run as reference:
https://openqa.suse.de/tests/1058602

#26 Updated by jorauch about 2 years ago

Actually the target name needs to contain a date in the format 2018-03 to be valid

Afterwards we fail in one of those bugs:
https://bugzilla.suse.com/show_bug.cgi?id=1086031
https://bugzilla.suse.com/show_bug.cgi?id=1085421

#27 Updated by jorauch about 2 years ago

According to the bugs a fix has been merged, should be revisited in next sprint

#28 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-03-27 to 2018-04-10

#29 Updated by okurz about 2 years ago

  • Status changed from Blocked to Workable

both bugs are RESOLVED FIXED, please verify them and then continue here.

#30 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][medium]test fails in iscsi_server - needs needle update and further investigation to [sle][functional][medium][yast][y] test fails in iscsi_server - needs needle update and further investigation

#31 Updated by cwh about 2 years ago

  • Difficulty set to medium

#32 Updated by riafarov about 2 years ago

  • Assignee deleted (jorauch)

Maybe something can pick it up.

#33 Updated by dheidler about 2 years ago

  • Status changed from Workable to Feedback

YaST2 iscsi-lio-server UI is broken:
https://bugzilla.suse.com/show_bug.cgi?id=1088677

#34 Updated by dheidler about 2 years ago

  • Related to action #32452: [sle][funtional][y][easy] test fails in iscsi_client need adaption added

#35 Updated by dheidler about 2 years ago

  • Assignee set to dheidler

#36 Updated by riafarov about 2 years ago

  • Status changed from Feedback to Blocked

#37 Updated by riafarov about 2 years ago

  • Due date changed from 2018-04-10 to 2018-05-08

Do not expect bug fix in the next sprint, let's check in the one sprint later.

#38 Updated by okurz about 2 years ago

  • Related to deleted (action #32452: [sle][funtional][y][easy] test fails in iscsi_client need adaption)

#39 Updated by okurz about 2 years ago

  • Related to action #32452: [sle][funtional][y][easy] test fails in iscsi_client need adaption added

#40 Updated by jorauch about 2 years ago

The bug is fixed, I adapted the tag for the test to this ticket

#41 Updated by okurz about 2 years ago

  • Status changed from Blocked to Workable

Well, the bug is RESOLVED FIXED, but could you verify it? Then please set the bug to VERIFIED FIXED if that is the case.

#43 Updated by dheidler about 2 years ago

  • Status changed from Workable to In Progress

#44 Updated by dheidler about 2 years ago

Test passes on SLE12SP4: https://openqa.suse.de/tests/1638590

#46 Updated by dheidler about 2 years ago

  • Status changed from In Progress to Feedback

#47 Updated by okurz about 2 years ago

  • Status changed from Feedback to Workable
  • Target version changed from Milestone 15 to Milestone 16

https://bugzilla.suse.com/show_bug.cgi?id=1090521#c2 provides the feedback with suggestion how to adjust the name. Please try if that works.

correcting milestone.

#48 Updated by dheidler about 2 years ago

  • Status changed from Workable to In Progress

#49 Updated by dheidler about 2 years ago

https://bugzilla.suse.com/show_bug.cgi?id=1091626 fixed & to be verified

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4968 merged.

SLE12SP4 iscsi test works (client and server).

Waiting for https://build.suse.de/request/show/164389 to appear in the SLE15 product.
Afterwards the SLE15 version of this test might need some additional needles.

#52 Updated by riafarov about 2 years ago

  • Due date changed from 2018-05-08 to 2018-05-22
  • Status changed from In Progress to Feedback

PR merged, missing verification run on osd.

#53 Updated by dheidler about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF