Project

General

Profile

action #26948

coordination #23650: [sle][functional][ipmi][epic][u] Fix test suite gnome to work on ipmi 12-SP3 and 15 (WAS: test fails in boot_from_pxe - connection refused trying to ipmi host over ssh?)

[sle][functional][ipmi][hard] Adjust boot_from_pxe to sanely handle multiple network interfaces

Added by nicksinger over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Enhancement to existing tests
Start date:
2017-10-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

boot/boot_from_pxe.pm just boots up the system without specifically adding a network device which the installer should use. This can result in somewhat random results if the machine has more then one interface (pretty common on real servers). From the linuxrc documentation:

Use netdevice to specify the interface (otherwise it tries all interfaces until things work).

Steps to reproduce

  • Ran an IPMI job on an IPMI-worker with multiple network interfaces connected
  • Observe how openQA gets stuck at bootup because there is a network-interface-selection showing

Problem

The test cannot continue because it does not expect this interface selection. Connecting always only one interface does not represent the real world all the times (especially on servers).

Suggestion

  1. way: Specifically add the configured device to the kernel parameters:

linuxrc supports defining so called "netdevice"s if it should use a specific device:
install=$repo?device=00:25:90:c0:0b:1a

Pro:

  • Simple to implement

Con:

  • Needs some way to map MAC -> IP while no IP is assigned yet (means: looking up in the ARP-table will not work ;)). Could be realized by adding another value into the worker config
  • Does not 100% represent how "real users" use the machines
  1. way: Adjust test to try all known interfaces

This requires to adjust the test to not fail if the first connect does not work. Besides that the workerconf has to be expanded to contain every possible interface of the server/SUT and also the DHCP/DNS config on qanet needs to be updated to handle every interface.

Ways to define all available interfaces:

  1. Multiple comma separated values for SUT_IP in the worker config
  2. Multiple A records behind the hostname of the SUT (dig host.name.qa.suse.de A +short would then return all configured IPs for that host)

    1. way: maybe there are smarter solutions?

Workaround

Use a worker with only one interface connected.


Related issues

Related to openQA Tests - action #23514: [labs][64bit-ipmi_debug worker] SLE15 shows interface selection (because 2 NICs are connected?)Resolved2017-08-22

Related to openQA Tests - action #27108: [sle][functional][ipmi][hard] test fails in qa_net_boot_from_hdd - No SOL updates anymore after installationResolved2017-10-302018-01-30

Blocked by openQA Tests - action #32146: [sle][functional][fast] Test incomplete because of missing tests/installation/qa_net.pmResolved2018-02-222018-02-27

History

#1 Updated by nicksinger over 4 years ago

  • Subject changed from [sle][functional][ipmi] Adjust ipmi test to specifically use a fixed network interface to [sle][functional][ipmi] Adjust boot_from_pxe to sanely handle multiple network interfaces

#2 Updated by nicksinger over 4 years ago

  • Priority changed from Normal to High

Raise to "High" since this makes ipmi tests inconsistent

#3 Updated by okurz over 4 years ago

  • Due date set to 2017-11-08

#4 Updated by okurz over 4 years ago

  • Target version set to Milestone 11

#5 Updated by okurz over 4 years ago

please update ticket to have it workable, apply workaround by restricting our current production tests to one machine only with consistent network card setup, optionally split into tickets and then probably remove the ticket again from sprint. With the workaround in place we can schedule it for later.

#6 Updated by nicksinger over 4 years ago

  • Related to action #23514: [labs][64bit-ipmi_debug worker] SLE15 shows interface selection (because 2 NICs are connected?) added

#7 Updated by nicksinger over 4 years ago

  • Description updated (diff)

#8 Updated by nicksinger over 4 years ago

  • Description updated (diff)

#9 Updated by nicksinger over 4 years ago

  • Related to action #27108: [sle][functional][ipmi][hard] test fails in qa_net_boot_from_hdd - No SOL updates anymore after installation added

#10 Updated by nicksinger over 4 years ago

  • Due date deleted (2017-11-08)
  • Priority changed from High to Normal

Crosschecked the production workers again and the network config seems sane there (as in: test can continue until it fails at https://progress.opensuse.org/issues/27108 ). IMHO this task here should be in a workable state and can be rescheduled for the next sprint.

#11 Updated by okurz over 4 years ago

  • Assignee set to nicksinger
  • Target version changed from Milestone 11 to Milestone 12

nicksinger could you please update this ticket using our ticket template, e.g. using the proper format for acceptance criteria and tasks as people are used to that format.

#12 Updated by nicksinger over 4 years ago

  • Description updated (diff)

#13 Updated by nicksinger over 4 years ago

  • Subject changed from [sle][functional][ipmi] Adjust boot_from_pxe to sanely handle multiple network interfaces to [sle][functional][ipmi][hard] Adjust boot_from_pxe to sanely handle multiple network interfaces
  • Assignee deleted (nicksinger)
  • Priority changed from Normal to High

#14 Updated by nicksinger over 4 years ago

  • Description updated (diff)

#15 Updated by okurz over 4 years ago

  • Due date set to 2018-01-16
  • Target version changed from Milestone 12 to Milestone 13

sorry, can't be done in this year

#16 Updated by okurz over 4 years ago

  • Due date changed from 2018-01-16 to 2018-02-27
  • Target version changed from Milestone 13 to Milestone 14

#17 Updated by riafarov over 4 years ago

  • Status changed from New to Workable

#18 Updated by SLindoMansilla about 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to SLindoMansilla

Depends on "Test incomplete because of missing tests/installation/qa_net.pm" poo#32146

#19 Updated by SLindoMansilla about 4 years ago

  • Blocked by action #32146: [sle][functional][fast] Test incomplete because of missing tests/installation/qa_net.pm added

#20 Updated by SLindoMansilla about 4 years ago

nsinger plugged a second network interface to a shared worker on loewe:100 (openqaw4-sp.qa.suse.de)

#21 Updated by SLindoMansilla about 4 years ago

  • Status changed from In Progress to Feedback

#22 Updated by riafarov about 4 years ago

  • Subject changed from [sle][functional][ipmi][hard] Adjust boot_from_pxe to sanely handle multiple network interfaces to [sle][functional][ipmi][medium] Adjust boot_from_pxe to sanely handle multiple network interfaces
  • Due date changed from 2018-02-27 to 2018-03-13
  • Priority changed from High to Normal

#23 Updated by riafarov about 4 years ago

  • Subject changed from [sle][functional][ipmi][medium] Adjust boot_from_pxe to sanely handle multiple network interfaces to [sle][functional][ipmi][hard] Adjust boot_from_pxe to sanely handle multiple network interfaces

#24 Updated by SLindoMansilla about 4 years ago

PR merged.

Verified on OSD: https://openqa.suse.de/tests/1510569

#25 Updated by SLindoMansilla about 4 years ago

  • Status changed from Feedback to Resolved

#26 Updated by SLindoMansilla almost 3 years ago

  • Due date deleted (2018-03-13)

Also available in: Atom PDF