Project

General

Profile

action #26112

[sle][functional] test fails in zypper_lifecycle - bash script fails

Added by jorauch over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Start date:
2017-10-17
Due date:
2018-02-13
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The call of a bash one line script fails in Line 43 of the module.
"Error: Unexpected Token '('" seems like the command substitution failed

openQA test in scenario sle-15-Installer-DVD-aarch64-gnome+proxy_SCC+allmodules@aarch64 fails in
zypper_lifecycle

Reproducible

Fails since (at least) Build 288.8

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #26080: [sle][functional] zypper_lifecycle fails because of (maybe?) broken regexResolved2017-10-162017-11-22

Related to openQA Tests - action #16646: test fails in zypper_lifecycle to execute `curl...script` as the command is not typed completelyRejected2017-02-10

Related to openQA Tests - action #25618: [tools] test fails in zypper_lifecycle - Missing keys on openqaworker-arm-3Rejected2017-09-27

Related to openQA Tests - action #25716: [sle][functional][demo][hard] different test-modules fail because of "unexpected token" in the scriptResolved2017-10-022017-11-22

Related to openQA Tests - action #28198: [sle][functional][medium] test fails in zypper_lifecycle - for repo in SLE-Products-SLES15-Pool"/> <solvable...Resolved2017-11-22

Related to openQA Project - action #30613: [functional][y][hard] script_output might include extra serial outputResolved2018-01-222018-08-28

Related to openQA Tests - action #29646: [sle][functional][medium]test fails in zypper_lifecycle due to script_output is not always reliableResolved2017-12-202018-02-13

History

#1 Updated by okurz over 4 years ago

  • Related to action #26080: [sle][functional] zypper_lifecycle fails because of (maybe?) broken regex added

#2 Updated by okurz over 4 years ago

  • Related to action #16646: test fails in zypper_lifecycle to execute `curl...script` as the command is not typed completely added

#3 Updated by okurz over 4 years ago

  • Related to action #25618: [tools] test fails in zypper_lifecycle - Missing keys on openqaworker-arm-3 added

#4 Updated by okurz over 4 years ago

  • Related to action #25716: [sle][functional][demo][hard] different test-modules fail because of "unexpected token" in the script added

#5 Updated by okurz over 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: USBinstall@uefi
https://openqa.suse.de/tests/1236603

#6 Updated by okurz over 4 years ago

  • Target version set to Milestone 12

#7 Updated by okurz over 4 years ago

  • Related to action #28198: [sle][functional][medium] test fails in zypper_lifecycle - for repo in SLE-Products-SLES15-Pool"/> <solvable... added

#8 Updated by nicksinger over 4 years ago

This happened on each architecture (except s390) once in the most recent build (422.1):
ppc64le: https://openqa.suse.de/tests/1403750
x86_64: https://openqa.suse.de/tests/1404080
aarch64: https://openqa.suse.de/tests/1403555

#9 Updated by okurz over 4 years ago

  • Due date set to 2018-02-13
  • Target version changed from Milestone 12 to Milestone 14

#10 Updated by JERiveraMoya over 4 years ago

Cannot find the error in latest builds but I am taking a look to make this test green again, there is some package problem: https://openqa.suse.de/tests/1445627#step/zypper_lifecycle/15
In order to reproduce it in local I need to take into account this workaround: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4327

#11 Updated by JERiveraMoya over 4 years ago

  • Assignee set to JERiveraMoya

#12 Updated by JERiveraMoya over 4 years ago

  • Related to action #30613: [functional][y][hard] script_output might include extra serial output added

#13 Updated by JERiveraMoya over 4 years ago

  • Assignee deleted (JERiveraMoya)

Package problem was just a temporal issue in one build.
In latest build 442.3 the error persists (even after the workaround is merged) https://openqa.suse.de/tests/1447268#step/zypper_lifecycle/10 but I will unassign myself due to there is work ongoing for solving this https://progress.opensuse.org/issues/30613 and falls a little bit of my scope.

#14 Updated by riafarov over 4 years ago

  • Related to action #29646: [sle][functional][medium]test fails in zypper_lifecycle due to script_output is not always reliable added

#15 Updated by riafarov over 4 years ago

  • Status changed from New to Workable

#16 Updated by riafarov over 4 years ago

  • Status changed from Workable to Rejected

Also available in: Atom PDF