Project

General

Profile

action #25626

[sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE

Added by SLindoMansilla about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-09-27
Due date:
2017-10-25
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Invalid add-on ftp url for WE

openQA test in scenario sle-15-Leanos-DVD-x86_64-we-ftp@64bit fails in
addon_products_sle

Reproducible

Fails since (at least) Build 93.17

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #25896: [sle][functional] Create test suite to test adding addon medium on SLE 15Resolved2017-10-102017-10-25

History

#2 Updated by okurz about 4 years ago

  • Assignee set to sebchlad
  • Priority changed from Normal to High
  • Target version set to Milestone 11

sebchlad: can we assign the ticket to the sprint because it's related to the existing issue about "WE"? -> #23818

#3 Updated by okurz about 4 years ago

  • Related to action #23818: [sles][functional][sle15] Adapt WE and related test scenarios to SLE15 added

#4 Updated by SLindoMansilla about 4 years ago

  • Related to deleted (action #23818: [sles][functional][sle15] Adapt WE and related test scenarios to SLE15)

#5 Updated by SLindoMansilla about 4 years ago

  • Blocked by action #23818: [sles][functional][sle15] Adapt WE and related test scenarios to SLE15 added

#6 Updated by SLindoMansilla about 4 years ago

From SCRUM perspective, since this is a blocker of a current planned "story"*, it has to be implicitly done within the sprint without needing to change the planned ones. Changing the planning always blurs the overview of planned ticket and doesn't help for review & retro.

  • * poo#23818 is actually an epic that should be splitted into stories

#7 Updated by SLindoMansilla about 4 years ago

  • Blocked by deleted (action #23818: [sles][functional][sle15] Adapt WE and related test scenarios to SLE15)

#8 Updated by SLindoMansilla about 4 years ago

  • Blocks action #23818: [sles][functional][sle15] Adapt WE and related test scenarios to SLE15 added

#10 Updated by mgriessmeier about 4 years ago

  • Status changed from New to Feedback

YaST-change is in the product, so fixed and not blocking our sprint ticket anymore
Don't know if anyone wants to verify that, by entering an invalid URL, but the yast2-packager version is > 4.0.7 in Build 280.1, setting to feedback

#11 Updated by mgriessmeier about 4 years ago

  • Blocks deleted (action #23818: [sles][functional][sle15] Adapt WE and related test scenarios to SLE15)

#12 Updated by okurz about 4 years ago

  • Due date set to 2017-10-11
  • Assignee deleted (sebchlad)

#13 Updated by okurz about 4 years ago

  • Due date changed from 2017-10-11 to 2017-10-25
  • Status changed from Feedback to In Progress
  • Assignee set to riafarov

So for WE on SLE15 we have we-module now and don't trigger we-ftp at all anymore. But we want to test the use of any addon as a network repository which we should not miss. I suggest we check that we have this, e.g. with HA addon medium. It's not about the specific addon or module but about the yast installer feature so we could choose any.

suggestions

  • look for current state of SLE15 test to verify we have at least one testsuite testing adding addons from an external medium, http, ftp, etc.
  • update ticket description
  • if necessary: adapt/add corresponding test suites for SLE15

#14 Updated by riafarov about 4 years ago

  • Related to action #25896: [sle][functional] Create test suite to test adding addon medium on SLE 15 added

#15 Updated by riafarov about 4 years ago

  • Status changed from In Progress to Resolved

Resolving and work on outcome of this ticket in https://progress.opensuse.org/issues/25896

Also available in: Atom PDF