Project

General

Profile

Actions

action #23818

closed

[sles][functional][sle15] Adapt WE and related test scenarios to SLE15

Added by mgriessmeier over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Infrastructure
Start date:
2017-08-31
Due date:
2017-10-11
% Done:

0%

Estimated time:
Difficulty:

Description

acceptance criteria

  • AC1 "we" as addon or module is tested for SLE12 as it was.

  • AC2 "we" as addon or module is tested for SLE15 with new procedure, for details refer to PRD.

  • AC3 Test scenarios we, we+allpatterns, we-ftp, we-http are adjusted to be able to test SLE12 or earlier and SLE15 and later prducts.

observation

https://openqa.suse.de/tests/1138009 and https://openqa.suse.de/tests/1137978
are incomplete and fail due to following error:

CACHE: Content has not changed, not downloading the /var/lib/openqa/cache/SLE-15-Leanos-DVD-x86_64-Build173.8-Media1.iso but updating last use
Downloading SLE-15-WE-DVD-x86_64-Build%BUILD_WE%-Media1.iso from openqa.suse.de/tests/1138009/asset/iso/SLE-15-WE-DVD-x86_64-Build%BUILD_WE%-Media1.iso
CACHE: Download of /var/lib/openqa/cache/SLE-15-WE-DVD-x86_64-Build%BUILD_WE%-Media1.iso failed with: 400 - Bad Request

when looking at "settings" there is no BUILD_WE variable set.
Checking previous runs, it was there, e.g https://openqa.suse.de/tests/1136635

Actions #2

Updated by okurz over 6 years ago

  • Priority changed from Normal to Urgent

incomplete tests are very annoying because of missing label carry over -> bump prio

Actions #3

Updated by qkzhu over 6 years ago

  • Is duplicate of action #25266: BUILD_WE is missing for we testsuite added
Actions #4

Updated by qkzhu over 6 years ago

  • Status changed from New to Closed
Actions #5

Updated by qkzhu over 6 years ago

  • Is duplicate of deleted (action #25266: BUILD_WE is missing for we testsuite)
Actions #6

Updated by qkzhu over 6 years ago

Sorry I messed it up, please reopen it :(

Actions #7

Updated by okurz over 6 years ago

the problem is not a missing variable but that the whole approach does not make sense using an ISO for SLE15 when we should use modules over proxy SCC instead but keep SLE12 in mind so don't destroy the test suite.

Actions #8

Updated by okurz over 6 years ago

  • Status changed from Closed to In Progress
Actions #9

Updated by okurz over 6 years ago

  • Description updated (diff)

Removed both scenarios "we" and "we+allpatterns" for now from SLE15 functional group. Please readd an according testsuite after revisiting this ticket.

Actions #10

Updated by okurz over 6 years ago

  • Assignee set to Anonymous

as discussed during standup 2017-09-20

Actions #11

Updated by okurz over 6 years ago

I sent you the PRD. Please read and update this ticket accordingly

Actions #12

Updated by Anonymous over 6 years ago

  • Subject changed from [sles][functional] Test is incomplete because "BUILD_WE" variable is not set to [sles][functional] Adapt WE and related test scenarios to SLE15
  • Description updated (diff)
  • Priority changed from Urgent to High
Actions #13

Updated by Anonymous over 6 years ago

  • Description updated (diff)
Actions #14

Updated by Anonymous over 6 years ago

  • Description updated (diff)
Actions #15

Updated by okurz over 6 years ago

  • Target version set to Milestone 11
Actions #16

Updated by okurz over 6 years ago

I suggest a new testsuite for SLE15, e.g. "we-module", because we still need the setting with ISO for SLE12 testing. I suggest you try setting "SCC_ADDONS=base,we". If installation continues maybe there is a pattern to be activated, see SLE12 tests for reference.

Actions #17

Updated by okurz over 6 years ago

  • Due date set to 2017-10-11
Actions #18

Updated by okurz over 6 years ago

  • Subject changed from [sles][functional] Adapt WE and related test scenarios to SLE15 to [sles][functional][sle15] Adapt WE and related test scenarios to SLE15
  • Category changed from Infrastructure to Bugs in existing tests

actually not "infrastructure" because there will not be WE isos for SLE15.

Actions #19

Updated by okurz over 6 years ago

  • Related to action #25626: [sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE added
Actions #20

Updated by SLindoMansilla over 6 years ago

  • Related to deleted (action #25626: [sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE)
Actions #21

Updated by SLindoMansilla over 6 years ago

  • Blocks action #25626: [sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE added
Actions #22

Updated by Anonymous over 6 years ago

PR created: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3643
First step is to register WE as a module for SLE15. Testrun: http://f146.suse.de/tests/1288

Actions #23

Updated by SLindoMansilla over 6 years ago

From SCRUM perspective, since this is a blocker of a current planned "story"*, it has to be implicitly done within the sprint without needing to change the planned ones. Changing the planning always blurs the overview of planned ticket and doesn't help for review & retro.

* this ticket is actually an epic that should be splitted into stories

Sorry, I commented the wrong ticket

Actions #24

Updated by SLindoMansilla over 6 years ago

  • Blocks deleted (action #25626: [sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE)
Actions #25

Updated by SLindoMansilla over 6 years ago

  • Blocked by action #25626: [sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE added
Actions #26

Updated by SLindoMansilla over 6 years ago

This ticket is actually an epic that should be splitted into stories

Actions #27

Updated by Anonymous over 6 years ago

Set parameter ADDONS=0 ADDONURL=0 ADDONURL_WE=0 in order to continue atm.
Testrun: http://f146.suse.de/tests/1290

Actions #28

Updated by Anonymous over 6 years ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Status changed from In Progress to Feedback

With workarounds we-ftp is able to run: http://f146.suse.de/tests/1301#step/scc_registration/28. I'll use we-ftp as a base to create test scenario we-module for SLE15.

After verifying different situations there is no major change necessary except for test module addon_products_sle, which is skipped in the testrun, because the URL is not correct.

Actions #29

Updated by Anonymous over 6 years ago

  • Status changed from Feedback to In Progress
Actions #30

Updated by Anonymous over 6 years ago

PR updated.
Verifying with: /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de 1187150 ADDONS=0 ADDONURL=0 ADDONURL_WE=0 SCC_ADDONS=we

Verification testrun: http://f146.suse.de/tests/1324

Actions #31

Updated by mgriessmeier over 6 years ago

PE is merged,
Yi created a testsuite on o.s.d together with anton:
https://openqa.suse.de/tests/1195342#step/scc_registration/31

Unfortunately it's failing right now, which I don't understand yet, because the regcode Yi was using in her local instance is the same and it worked there, but I've asked in the irc channel of SCC team if they changed the regcode for sle15

It's failing because there was a space behind the regcode, I removed it - but didn't retrigger it, since the medium was already renamed - so let's wait for the next build
-> setting to feedback

Actions #32

Updated by mgriessmeier over 6 years ago

  • Status changed from In Progress to Feedback
Actions #33

Updated by mgriessmeier over 6 years ago

  • Blocked by deleted (action #25626: [sle][functional] test fails in addon_products_sle - Invalid add-on ftp url for WE)
Actions #34

Updated by mgriessmeier over 6 years ago

  • Status changed from Feedback to Resolved

SLE 15, new test case ┬┤we-module┬┤ is 'working' in production (fails are not related to we setup afaics):
https://openqa.suse.de/tests/1196290#live

closing ticket as resolved

Actions #35

Updated by okurz over 6 years ago

It seems all failed test modules are failing either for product bugs, e.g. missing packages, or what looks like modules that miss some update for SLE15 so agreed with "resolved". Good work.

Actions

Also available in: Atom PDF