Project

General

Profile

action #19862

[sle][functional][s390x] test fails in addon_products_sle

Added by dzedro over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-s390x-sles12_minimal_base+sdk_create_hdd@zkvm-image fails in
addon_products_sle

Reproducible

Fails since (at least) Build 0424

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocks openQA Tests - action #18936: [tools][sles][functional] Enable 3 stress acceptance on s390xResolved2017-05-042017-11-08

History

#1 Updated by okurz over 4 years ago

  • Blocks action #18936: [tools][sles][functional] Enable 3 stress acceptance on s390x added

#2 Updated by okurz over 4 years ago

  • Status changed from New to Feedback
  • Assignee set to okurz

I don'th this could have ever made sense because the scenario tries to add a DVD which is not existant within the s390x instance: https://openqa.suse.de/tests/1003577#step/addon_products_sle/3 so the scenario should not be scheduled at all for s390x.

RBrownSUSE you scheduled the scenario initially to allow performance tests as described in #18936 . I don't think we can use this scenario. Maybe minimal+base+sdk+fakescc-postreg@zkvm-image could be a better alternative anyway but that job fails trying to select the right modules anyway, e.g. see https://openqa.suse.de/tests/1002157 and no one seems to care now so I will take a look.

#3 Updated by okurz over 4 years ago

Disabled triggering of "sles12_minimal_base+sdk_create_hdd" again. AFAIU it can't work because s390x would try to access the ISO when it can't. Actually when triggering on s390x we should fail hard in these cases as it can't work.

wait for https://openqa.suse.de/tests/1004866 , proxyscc job with new needle for yast-scc

#4 Updated by okurz over 4 years ago

  • Status changed from Feedback to In Progress
  • Assignee deleted (okurz)

stuck in https://openqa.suse.de/tests/1004866#step/yast_scc/14 now expecting a license agreement but the beta notification is shown. This can't work either and should be checked first locally in a textmode installation what other changes are necessary.

#5 Updated by okurz about 4 years ago

created new needle: scc-addon-license-sdk-text-beta-20170628

#6 Updated by okurz about 4 years ago

  • Status changed from In Progress to Feedback
  • Assignee set to okurz

#7 Updated by okurz about 4 years ago

  • Status changed from Feedback to Resolved

build 0457 image generation job https://openqa.suse.de/tests/1036295 passed now

#8 Updated by okurz about 4 years ago

  • Status changed from Resolved to In Progress

Added description to minimal+base+sdk+proxy_SCC-postreg and moved it from test development job group to Functional: Server, waiting for next build to show verification.

I will check one more thing: If the image can be published correctly. Then we could use it e.g. for #18936
I am wondering though we I did not consider the alternative of adding an FTP SDK repo during installation instead of the DVD as that does not work (see #19862#note-2) and I wonder if the postreg scenario can actually work for our purposes because the SDK might be the "old" version on SCC when we probably want to test the new version. Isn't it? Maybe I can discuss with mgriessmeier about adding SDK repos on s390x zkvm images.

Image generation on the above job testing with

openqa_clone_job_osd 1036295 _GROUP=0 PUBLISH_HDD_1=SLES-12-SP3-s390x-0457-minimal_with_sdk0252_installed-postreg.qcow2

-> @waitfor https://openqa.suse.de/tests/1038331#live

the variable for later should probably be

PUBLISH_HDD_1=SLES-%VERSION%-%ARCH%-%BUILD%-minimal_with_sdk%BUILD_SDK%_installed-postreg.qcow2

passed now.

#9 Updated by mgriessmeier about 4 years ago

without reading any comment now (I see this ticket for the first time to be honest)

you can't use DVD on s390 as a source, you have to use ftp
see for example:
https://openqa.suse.de/tests/1036266

so either put a PUBLISH_HDD here or use ADDONURL=sdk and ADDONURL_SDK in the creation job

both should work just out of the box

#10 Updated by okurz about 4 years ago

The way to go for the dependant scenarios is to setup a new scenario which can create an image based on sdk from remote repo, e.g. minimal-base+sdk, etc.

#11 Updated by okurz about 4 years ago

  • Assignee deleted (okurz)

Not doing that currently.

#12 Updated by riafarov about 4 years ago

  • Assignee set to riafarov

#13 Updated by okurz about 4 years ago

Maybe that helps

openqa_clone_job_osd 1058167 ADDONURL=sdk ADDONURL_SDK=ftp://openqa.suse.de/SLE-12-SP3-SDK-POOL-s390x-Build0263-Media1/ WORKER_CLASS=zkvm-images PUBLISH_HDD_1=SLES-12-SP3-s390x-0473-minimal_with_sdk0263_installed.qcow2 TEST=try_sdk_create_thingy _GROUP=0 MACHINE=zkvm-image
Created job #1066810: sle-12-SP3-Server-DVD-s390x-Build0473-textmode@zkvm -> https://openqa.suse.de/t1066810

#14 Updated by riafarov about 4 years ago

  • Status changed from In Progress to Feedback

I've created job with required parameters: https://openqa.suse.de/tests/1067430#live
Currently it's under dev job group. Also, we need to specify REPO_0 parameter, and I'm not sure where is it coming from, I've passed it in isos post.

#15 Updated by okurz about 4 years ago

REPO_0 is coming from rsync.pl so that should be provided on each call. What else do you see missing? What do you plan next?

#16 Updated by riafarov about 4 years ago

okurz I don't have an overview of the related tasks, but I would consider this one to be resolved and next steps have to be aimed in https://progress.opensuse.org/issues/18936 I've pasted the link with successful run, so no changes were required in the code.

#17 Updated by riafarov about 4 years ago

  • Status changed from Feedback to Resolved

Command to trigger the build.
/usr/share/openqa/script/client isos post ARCH=s390x \
DISTRI=sle FLAVOR=Server-DVD VERSION=12-SP3 \
ISO=SLE-12-SP3-Server-DVD-s390x-Build0473-Media1.iso BUILD=0473 \
BUILD_SDK=0263 \
TEST=create_hdd_minimal_base+sdk_s390x \
REPO_0=SLE-12-SP3-Server-DVD-s390x-Build0473-Media1 \
--host openqa.suse.de \
--apikey $api_key \
--apisecret $api_secret

Also available in: Atom PDF