Project

General

Profile

Actions

action #19836

closed

[tools]test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64

Added by SLindoMansilla almost 7 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2017-06-14
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test on module yast2_snapper in scenarios

The test failed to assert serial output, but the verification string can be found on https://openqa.suse.de/tests/999221/file/serial0.txt
It seems like somehow it lose the connection to serial.

Reproducible

Fails since Build 0428:

  • sle-12-SP3-Server-DVD-ppc64le-allpatterns@ppc64le
  • sle-12-SP3-Server-DVD-aarch64-Build0428-allpatterns@aarch64

Expected result

Last good:

  • sle-12-SP3-Server-DVD-ppc64le-allpatterns@ppc64le
  • sle-12-SP3-Server-DVD-aarch64-Build0428-allpatterns@aarch64

Further details

Always latest result in these scenarios:


Related issues 4 (0 open4 closed)

Related to openQA Tests - action #32956: [sle][functional][u][medium] test fails in yast2_snapper - Improve loggingRejected2018-03-09

Actions
Related to openQA Tests - action #40421: [functional][u][opensuse] test fails in hwsim_wpa2_enterprise_setup for ppc64leRejectedzluo2018-08-29

Actions
Has duplicate openQA Tests - action #20020: [sle][functional][sporadic] test fails in yast2_snapper due to timed out wait_serialRejected2017-06-23

Actions
Has duplicate openQA Tests - action #19912: soft failed in yast2_snapper not working wellRejectedRBrownSUSE2017-06-20

Actions
Actions #1

Updated by SLindoMansilla almost 7 years ago

  • Subject changed from [sles][functional] test fails in yast2_snapper - failed to assert serial output to [sles][functional] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
  • Description updated (diff)
Actions #2

Updated by riafarov almost 7 years ago

  • Has duplicate action #20020: [sle][functional][sporadic] test fails in yast2_snapper due to timed out wait_serial added
Actions #3

Updated by okurz almost 7 years ago

  • Priority changed from Normal to Urgent

Current issue, failing in tests reproducibly, (slightly) impacting RC validation

Actions #4

Updated by asmorodskyi almost 7 years ago

  • Assignee set to asmorodskyi
Actions #5

Updated by asmorodskyi almost 7 years ago

  • Subject changed from [sles][functional] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64 to [tools] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
  • Assignee deleted (asmorodskyi)
  1. Closer look into logs showing that issue is happening somewhere in backend so reassign to tools team
  2. If you are curious why postfail_hook executed twice we already found an answer - because failure_analysis called first time due to soft_failure and later when failure_analysis fails it calls postfail_hook which calls again failure_analysis :). I will fix this right now
Actions #7

Updated by okurz almost 7 years ago

  • Has duplicate action #19912: soft failed in yast2_snapper not working well added
Actions #9

Updated by okurz over 6 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: om_proxyscc_sled12sp2_allpatterns_full_update_by_yast
http://openqa.suse.de/tests/1057899

Actions #10

Updated by szarate over 6 years ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from [tools] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64 to [tools][Sprint 1]] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
  • Category changed from Infrastructure to Regressions/Crashes
  • Target version set to future

Target version set to future, as this is more about investigating what is happening that fixing it (We know for sure that this can take a while to fix)

Actions #11

Updated by szarate over 6 years ago

  • Subject changed from [tools][Sprint 1]] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64 to [tools][Sprint 1] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
Actions #12

Updated by szarate over 6 years ago

  • Subject changed from [tools][Sprint 1] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64 to [tools][sprint 201709.1] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
Actions #13

Updated by szarate over 6 years ago

  • Subject changed from [tools][sprint 201709.1] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64 to [tools][sprint 201709.2] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
Actions #14

Updated by szarate over 6 years ago

  • Subject changed from [tools][sprint 201709.2] test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64 to [tools]test fails in yast2_snapper - failed to assert serial output - ppc64 and aarch64
  • Priority changed from Urgent to Normal
Actions #15

Updated by okurz about 6 years ago

  • Priority changed from Normal to High

That is a severe problem for aarch64 now, more than 50% failing in https://openqa.suse.de/tests/overview?arch=&failed_modules=&arch=aarch64&distri=sle&version=15&groupid=110# which I assume is because of this issue

and more:

I saw now that all these jobs happen on seattle15, the other workers do not show any of these problems.

Please take seattle15 down for now

Actions #16

Updated by okurz about 6 years ago

  • Priority changed from High to Urgent
Actions #17

Updated by szarate about 6 years ago

  • Priority changed from Urgent to Normal

Lowering priority, Seattle 15 is down for now. I will double check through the day and make sure it doesn't comes back later :)

Actions #18

Updated by okurz about 6 years ago

  • Related to action #32956: [sle][functional][u][medium] test fails in yast2_snapper - Improve logging added
Actions #19

Updated by okurz almost 6 years ago

  • Target version changed from future to future
Actions #20

Updated by okurz about 5 years ago

  • Related to action #40421: [functional][u][opensuse] test fails in hwsim_wpa2_enterprise_setup for ppc64le added
Actions #21

Updated by okurz over 4 years ago

  • Status changed from New to Resolved
  • Assignee set to okurz

It seems that with our current worker setup, e.g. openqaworker-arm-1…3, as well as with the ppc64le machines we use we did not encounter this again. Assumed fixed.

Actions

Also available in: Atom PDF