Project

General

Profile

Actions

action #1789

closed

openqa test coverage

Added by lnussel about 10 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Feature requests
Target version:
Start date:
2014-03-04
Due date:
% Done:

0%

Estimated time:
8.00 h

Description

We may want to add test coverage checking to our test suite

http://article.gmane.org/gmane.comp.lang.perl.perl-mongers.moscow/9302


Related issues 1 (0 open1 closed)

Related to openQA Project - action #10262: Prevent further test coverage dropResolvedokurz2016-01-17

Actions
Actions #1

Updated by ancorgs about 10 years ago

  • Priority changed from Normal to High
Actions #2

Updated by coolo over 9 years ago

  • Category set to 124
  • Target version set to Easy hacks
Actions #3

Updated by coolo over 8 years ago

  • Priority changed from High to Normal
Actions #4

Updated by okurz over 8 years ago

In which project exactly do you want to gather test coverage? openQA itself gathers some coverage, see badge here: https://github.com/os-autoinst/openQA#openqa--

What I would like to do is gather coverage for os-autoinst itself, at best locally as well as with coveralls.io . Do you have anything else in mind?

Actions #5

Updated by lnussel over 8 years ago

the issue is two years old. might well be that I was referring to openQA itself. os-autoinst would be good of course.

Also reminds me that the coveralls hook to github is broken since monthgs. Who has the coveralls account data?

Actions #6

Updated by okurz about 8 years ago

  • Related to action #10262: Prevent further test coverage drop added
Actions #7

Updated by oholecek about 8 years ago

How is it broken? I just logged in coveralls and it seems it works fine for openQA. Fine in sense it does something on each commit/PR.

Actions #8

Updated by okurz about 8 years ago

results from irc discussion:

  • everyone with commit access to github repo has access to setup coveralls
  • openQA coveralls is still active but it does not comment PRs

e.g. https://travis-ci.org/os-autoinst/openQA/builds/103067657 pushed https://coveralls.io/jobs/11276927, but no comment is seen in https://github.com/os-autoinst/openQA/pull/509
according the build log the coverage is actually the same

[18/01/2016 10:48:40] perhaps I need to try harder to regress :)

Actions #9

Updated by okurz about 8 years ago

Situation improved a bit with https://github.com/os-autoinst/openQA/pull/513
We can enable hard check by setting a threshold in .travis.yml at least for openQA, os-autoinst needs to be done as well as tests distribution itself if this is feasible. coveralls got reconfigured by oholecek but still stays silent

Actions #10

Updated by okurz over 7 years ago

  • Status changed from New to Resolved

we have a coverage check with threshold plus the coveralls reports working for openQA. Since that, the test coverage improved a lot already.

Actions

Also available in: Atom PDF