Project

General

Profile

action #17886

coordination #13812: [epic][dashboard] openQA Dashboard ideas

[dashboard] Create full screen view for openQA dashboard

Added by asmorodskyi over 4 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2017-03-22
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

User story

As openQA test reviewer I would like to have special mode of Dashboard mode which allow to see summary of all job groups in optimized to full screen view. Something similar to what Jenkins has https://jenkins.io/blog/2016/01/10/beautiful-jenkins-dashboard/

acceptance criteria

  • DONE: main page have a switcher which allow to switch between "normal" and "fullscreen" dashboard representations
  • DONE: "fullscreen" use same filter settings as "normal"
  • DONE: there is a full screen view for both the index as well as group overview page
  • there is configurable auto-refresh for "fullscreen" mode

History

#1 Updated by okurz over 4 years ago

  • Category set to Feature requests
  • Status changed from New to Rejected

That is what we want to cover with #13812. I incorporated your ideas there. Please continue there.

#2 Updated by okurz over 4 years ago

#3 Updated by okurz over 4 years ago

#4 Updated by okurz over 4 years ago

  • Status changed from Rejected to New
  • Parent task set to #13812

let's keep it open because it covers a part of the parent ticket good enough.

#5 Updated by RBrownSUSE over 4 years ago

  • Subject changed from [tools] Create full screen view for openQA dashboard to [tools][dashboard] Create full screen view for openQA dashboard

#6 Updated by okurz over 4 years ago

  • Assignee set to krauselukas

as discussed together

#7 Updated by krauselukas over 4 years ago

  • Status changed from New to In Progress

Currently working on the fullscreen-view itself. Idea is just to display the most necessary informations in a size
where it is possible to see it even if the screen is not nearby.

#8 Updated by krauselukas over 4 years ago

https://github.com/os-autoinst/openQA/pull/1301

Have a look on the screenshots there to see the current status of the fullscreen view.
Next step will be to increase the size to make everything more visible and auto-update the page
without user interaction.

#9 Updated by krauselukas over 4 years ago

next steps:

  • getting current status to a merge
  • autorefresh (ajax)
  • having a fullscreen view in the group overview (just showing the latest comment)
  • alternative view-mods (having something like a graph instead of progressbars)
  • filter for subgroups

#10 Updated by krauselukas about 4 years ago

#11 Updated by krauselukas about 4 years ago

Current state of the ticket:

PR's open for:

  • Full screen mode on group overview page
  • Adjustable autorefresh rates for comments and build (currently only in full screen on group overview)

In progress:

  • Possibility to limit comments to a certain amount

Further ideas:

  • alternative view-mods (having something like a graph instead of progressbars)
  • add auto-refresh to index page as well

#12 Updated by okurz over 3 years ago

  • Description updated (diff)
  • Status changed from In Progress to Workable
  • Assignee deleted (krauselukas)

commit 2b3885a6
Author: Lukas Krause lkrause@suse.de
Date: Tue Aug 22 18:40:33 2017 +0200

Make auto refresh rate adjustable

added auto-refresh for the job group page. If we would have that feature for the index page as well we can also use the full screen view without any custom tweaks on our QSF (QA SLE functional) dashboard displays.

I assume lkrause is not really "working" on this ticket so I unassign. @lkrause feel free to take it again if I was wrong.

Updated descriptions to detail what is missing. All other parts are crossed off.

#13 Updated by mkittler over 1 year ago

When implementing an auto-reload feature for the dashboard we've noticed that there are a few details which should still be improved:

  1. The auto-reload interval should be configurable via a from control (similar to the fullscreen mode).
  2. The auto-reload on the group overview should use the same code as the index page. For that the group overview needs to be ported to use an AJAX query for loading the build results, too.
  3. The time-ago rendering on the group overview is currently broken when enabling the auto-reload. (That is likely fixed when implementing 2. anyways.)

#14 Updated by okurz over 1 year ago

  • Subject changed from [tools][dashboard] Create full screen view for openQA dashboard to [dashboard] Create full screen view for openQA dashboard
  • Priority changed from Normal to Low

trying to set prio of parent to "Low" implicitly.

#15 Updated by ilausuch over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to ilausuch

#16 Updated by ilausuch over 1 year ago

I found several additional problems

  1. When you change from different intervals, all of them are added to the url
    .../group_overview/110?fullscreen=1&interval=30&interval=60
    .../group_overview/110?fullscreen=1&interval=30&interval=60&interval=90

  2. When the autoupdate refresh the page is doing 2 refresh at the same time

#17 Updated by ilausuch over 1 year ago

About problem 2. The problem is here
https://github.com/os-autoinst/openQA/blob/d58e73ed410bf07e325d7318f0c12abb4dccf2ac/assets/javascripts/fullscreen.js#L37
$("#build-results").load(location.href + " #build-results");
$("#comments-preview").load(location.href + " #comments-preview");

The call adding #build-results is really not a different call than the second one, is the same, and both returns the progress and the comments, so in the screen is painting it twice.

Note, in ttp://127.0.0.1:9526/parent_group_overview allows to setup fullscreen but doesn't work

#18 Updated by ilausuch over 1 year ago

Initial PR to start solving things
https://github.com/os-autoinst/openQA/pull/3124

The best way to solve the repainting of the web should be have a screen part loading in base one parameter. Now I added a simple solution that repaints all

#19 Updated by ilausuch over 1 year ago

Autorefresh in index page
https://github.com/os-autoinst/openQA/pull/3141

This PR contains 3 commits

  • First solves the problem
  • Second, the autorefresh only works on fullscreen mode, and the filter is only selector when fullscreen mode is checked
  • third, Fix the problem to open the filter panel when the page is in fullscreen mode

#20 Updated by okurz over 1 year ago

Hi ilausuch, the mentioned PR is merged and also deployed on osd now. What are your further plans for this?

Also one thing: Is there a reason why to use radio buttons for different refresh intervals instead of just a number field to select the value? As we have two number fields for "limit builds" I prefer to use the same for auto-refresh

#21 Updated by cdywan over 1 year ago

9979

okurz wrote:

Also one thing: Is there a reason why to use radio buttons for different refresh intervals instead of just a number field to select the value? As we have two number fields for "limit builds" I prefer to use the same for auto-refresh

It looks like the radio buttons were already changed to links? Although the respective code change disagrees with what I'm seeing in production. I might be confused as to what's covered here?

  • DONE: "fullscreen" use same filter settings as "normal"

This doesn't seem to be what I see. The fullscreen mode is required to reveal new options.

#22 Updated by okurz over 1 year ago

cdywan wrote:

okurz wrote:

Also one thing: Is there a reason why to use radio buttons for different refresh intervals instead of just a number field to select the value? As we have two number fields for "limit builds" I prefer to use the same for auto-refresh

It looks like the radio buttons were already changed to links? Although the respective code change disagrees with what I'm seeing in production. I might be confused as to what's covered here?

Check yourself on https://openqa.opensuse.org/ , radio buttons with hardcoded choices whereas for "limit builds" we have number fields which I would prefer.

ilausuch is it ok for you to do this change?

#23 Updated by okurz about 1 year ago

  • Target version set to Ready

#24 Updated by okurz about 1 year ago

  • Status changed from Feedback to Workable
  • Assignee deleted (ilausuch)

no response. Let's give it back to backlog to be picked up again.

#25 Updated by cdywan about 1 year ago

  • there is configurable auto-refresh for "fullscreen" mode

So gh#os-autoinst/openQA#3141 seems to have implemented this?

Should it be considered DONE?

There was also the open question of the use of "number fields" to make the refresh options consistent with build limits.

I'd update the list of tasks, but it might be best for the OP (asmorodskyi) to confirm.

#26 Updated by ilausuch about 1 year ago

  • Status changed from Workable to Resolved
  • Assignee set to ilausuch

#27 Updated by okurz about 1 year ago

  • Status changed from Resolved to Feedback

But #17886#note-22 is still missing, right?

#28 Updated by ilausuch about 1 year ago

PR for to change the automatic refresh selector
https://github.com/os-autoinst/openQA/pull/3368

#29 Updated by okurz about 1 year ago

  • Status changed from Feedback to Resolved

PR was merged. The auto-refresh can be selected and the value also appears as URL query parameter. Enabling the setting shows in the browser network debug view that a refresh happens in the background in the selected intervals. Good job and thank you.

Also available in: Atom PDF