Project

General

Profile

action #16542

[ipmi][sles][functional][virtualization] 'alt-s' did not stop countdown in install_and_reboot, again

Added by okurz over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-11-30
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

issue described in #15164 happened again, previous approach not working: https://openqa.suse.de/tests/758680#step/install_and_reboot/1

Reproducible

Fails since this build 0234 and not the last 10 jobs in before so only once so far.

Expected result

Reboot countdown should be stopped.

Problem

H1. wait_still_screen(2, 4) is checking same image for 2 seconds but might still catch two images within one second why the countdown did not actually stop

Suggestion

S1-1. Check for more than 2 seconds, e.g. 3s
S1-2. Extend testapi to add no_wait on wait_still_screen, too

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #18634: [sles][functional]textmode install_and_reboot fails to stop the reboot countdownResolved2017-04-19

Related to openQA Tests - action #18514: [sles][functional][ipmi] keys missingResolved2017-04-12

Related to openQA Tests - action #19092: [sles][functional] test fails in install_and_reboot - not posible to detect still screen after stoping the reboot countdownResolved2017-05-10

Copied from openQA Tests - action #15164: ipmi: looks like 'alt-s' did not stop countdown in install_and_rebootResolved2016-11-30

History

#1 Updated by okurz over 5 years ago

  • Copied from action #15164: ipmi: looks like 'alt-s' did not stop countdown in install_and_reboot added

#2 Updated by okurz over 5 years ago

  • Status changed from New to In Progress

#3 Updated by szarate over 5 years ago

  • Status changed from In Progress to Feedback

Setting to feedback, this was solved with an apparent workaround in the test itself, but still.

#4 Updated by okurz over 5 years ago

The most recent job as of now failed in https://openqa.suse.de/tests/767897#step/install_and_reboot/5 but it seems to be a different problem. So looks ok so far, let's wait for a bit more jobs to verify it's fixed or we need to use the new feature in os-autoinst to check more than once per second.

#5 Updated by okurz over 5 years ago

https://openqa.suse.de/tests/808765#step/install_and_reboot/1 failed exactly the same, now for some 'no_wait' magic …

Need to adapt os-autoinst to support no_wait also on wait_still_screen because this is what we use in install_and_reboot

#6 Updated by okurz over 5 years ago

failing less now but still, last one was 13 days ago: https://openqa.suse.de/tests/808765#step/install_and_reboot/1

I think the "no_wait" on "wait_still_screen" is still a good idea

#7 Updated by okurz over 5 years ago

  • Status changed from Feedback to In Progress

#9 Updated by okurz about 5 years ago

  • Assignee deleted (okurz)

would need no_wait on wait_still_screen I guess, not currently working on this

#10 Updated by okurz about 5 years ago

  • Subject changed from ipmi: 'alt-s' did not stop countdown in install_and_reboot, again to [ipmi][sles][functional][virtualization] 'alt-s' did not stop countdown in install_and_reboot, again

#11 Updated by okurz about 5 years ago

  • Related to action #18634: [sles][functional]textmode install_and_reboot fails to stop the reboot countdown added

#12 Updated by okurz about 5 years ago

  • Related to action #18514: [sles][functional][ipmi] keys missing added

#15 Updated by okurz about 5 years ago

  • Related to action #19092: [sles][functional] test fails in install_and_reboot - not posible to detect still screen after stoping the reboot countdown added

#16 Updated by okurz about 5 years ago

  • Status changed from In Progress to Feedback
  • Assignee set to okurz

see #19092#note-3. Let's monitor if this is fixed for good.

#17 Updated by okurz about 5 years ago

  • Status changed from Feedback to Resolved

see related tickets.

The originally mentioned job is still very unstable but did not fail to stop the countdown.

Also available in: Atom PDF