action #16354

Unambiguous lookup of "preferred machine" for same amount of multiple machine types

Added by ktsamis about 3 years ago. Updated 8 months ago.

Status:ResolvedStart date:31/01/2017
Priority:NormalDue date:
Assignee:mkittler% Done:

0%

Category:Feature requests
Target version:Current Sprint
Difficulty:
Duration:

Description

User story

As a user of /tests/overview I want to have consistent display of test names to not confuse a changing name with a differing machine type

acceptance criteria

  • AC1: On reload of the same URL the display of test names should not differ on a random base

tasks

  • investigate the reason for the seemingly "random behavior", probably when there are as many tests of one machine type as for the other
  • make it unambiguous in any way, e.g. just always select the "first machine type" if that is also not random

further details

original observation by ktsamis:
Display of hostname jumps randomly between scheduled tests and switches the test in another row

On: https://openqa.suse.de/tests/overview?distri=sle&version=12-SP2&build=%3A127401.java-1_8_0-openjdk.4082&groupid=53
I have:
qam-minimal@s390x-zVM-hsi-l3 and qam-minimal-full scheduled
and on reload (maybe a couple reloads)
I have:
qam-minimal and qam-minimal-full@s390x-zVM scheduled
and that causes the test with the hostname to be moved into a new row.

I am attaching screenshots of both cases.

Screenshot from 2017-01-31 14-21-13.png (100 KB) ktsamis, 31/01/2017 01:23 pm

Screenshot from 2017-01-31 14-21-07.png (100 KB) ktsamis, 31/01/2017 01:24 pm

2826
2828

Related issues

Related to openQA Project - action #54008: [web ui] test result not alignment to test name Resolved 09/07/2019
Related to openQA Project - action #52493: Filter according to machine in 'Test result overview' Resolved 03/06/2019

History

#1 Updated by okurz about 3 years ago

  • Subject changed from Display of hostname jumps randomly between scheduled tests and switches the test in another row to Unambiguous lookup of "preferred machine" for same amount of multiple machine types
  • Description updated (diff)
  • Category set to Feature requests
  • Target version set to Milestone 6

#2 Updated by okurz almost 3 years ago

  • Target version deleted (Milestone 6)

M6 is over

#3 Updated by coolo over 2 years ago

  • Target version set to Ready

sounds like a good entrance level issue

#4 Updated by mkittler about 1 year ago

It this still happening? Can you provide a more recent example? Because the error is not easy to spot in the source code.

#5 Updated by ktsamis about 1 year ago

mkittler wrote:

It this still happening? Can you provide a more recent example? Because the error is not easy to spot in the source code.

I have no idea. I opened this 2 years ago and I haven't done much openqa since then. I don't have any instance to check this. I can't provide more info on this.

#6 Updated by coolo 11 months ago

https://openqa.suse.de/tests/overview?distri=sle&version=15&build=%3A10940%3Asystemd&groupid=159 - reload the page to see the Server-DVD-Incidents-Install flavor jump

#7 Updated by mkittler 8 months ago

  • Assignee set to mkittler

That one I can reproduce locally. Sometimes qam-incidentinstall@zkvm is in its own row and sometimes shown together with qam-incidentinstall. Which one is the behavior we want? I'd say it should be shown together to use the space more efficiently.

#8 Updated by mkittler 8 months ago

  • Status changed from New to In Progress
  • Target version changed from Ready to Current Sprint

PR: https://github.com/os-autoinst/openQA/pull/2249

When looking at the code I understand now why the machines are sometimes rendered differently. There is no general way to be always in favor of one of the variants (which are that s390 gets its own row or that it is shown in the same row as the other archs). But at least one of the variants is now used consistently.

I'm wondering what the purpose of this "preferred machine" behavior is (https://github.com/os-autoinst/openQA/pull/224 has not much info on it). At least here is seems arbitrary that we sometimes append the machine and sometimes not - even though this arbitrary decision now done in a consistent way with my PR. The most space efficient way would be removing that "preferred machine" feature completely and just show all archs for the same test in the same row.

#9 Updated by okurz 8 months ago

  • Related to action #54008: [web ui] test result not alignment to test name added

#10 Updated by okurz 8 months ago

  • Related to action #52493: Filter according to machine in 'Test result overview' added

#11 Updated by okurz 8 months ago

  • Status changed from In Progress to Feedback

PR merged, I guess this is Feedback now?

#12 Updated by okurz 8 months ago

  • Status changed from Feedback to Resolved

good on osd

Also available in: Atom PDF