Project

General

Profile

action #54008

[web ui] test result not alignment to test name

Added by lansuse about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Support
Target version:
-
Start date:
2019-07-09
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

In "Test result overview" page, the result under platform such as x86 or aarch and test name in same line.
But refresh or press F5 several times, result in XXX@64bit-smp maybe switch to line XXX
Details in attached picture.

Steps to reproduce

step1:
https://openqa.suse.de/tests/overview?result=failed&arch=&modules=&distri=sle&version=12-SP5&build=0216&groupid=240#

step2:
click first result of btrfs_progs-cli, it should be btrfs_progs-cli@64bit

If not reproduce the issue, refresh or press F5 and then return to step1

My browser is firefox 60

webui.png (17.9 KB) webui.png lansuse, 2019-07-09 09:38
8282

Related issues

Related to openQA Project - action #16354: Unambiguous lookup of "preferred machine" for same amount of multiple machine typesResolved2017-01-31

History

#1 Updated by okurz about 2 years ago

  • Project changed from openQA Infrastructure to openQA Project
  • Category set to Support
  • Status changed from New to Feedback
  • Assignee set to okurz

Are you sure that the label at the front of the line does not change along with the link? Because this is what I observe but you have to carefully look to realize :)

It is true that the order can switch on refresh and also the "default machine type" is computed based on visible results. That is the "feature" about preferred machine types. Imagine the scenario when there are 20 scenarios assigned to "64bit" and only a single one to "uefi" to act as a special scenario then the extension is only displayed for the "…@uefi" case but not for the others. Only in the special case as you have when there are the same amount of scenarios for each machine type the computation can randomly come up with one of the available machine types as the "preferred" one. I guess though making that reproducible as well would be a good feature.

side-question: why do you need the exact amount of test scenarios for each machine, isn't that a bit redundant and wasteful?

#2 Updated by lansuse about 2 years ago

I mean test result not alignment to test name, not machine types. Picture has attached for details.
So I dont need the exact amount of test scenarios for each machine, I just used to refresh to check my comments.

#3 Updated by okurz about 2 years ago

Can you try to narrow down the original problem e.g. by limiting the search using one of the available filter settings?

lansuse wrote:

So I dont need the exact amount of test scenarios for each machine, I just used to refresh to check my comments.

Sorry, I missed a word in my question. What I actually meant: What is the benefit of having each test scenario in https://openqa.suse.de/tests/overview?distri=sle&version=12-SP5&build=0216&groupid=240 at least twice, one time for 64bit and once again for 64bit-smp?

#4 Updated by lansuse about 2 years ago

okurz wrote:

Can you try to narrow down the original problem e.g. by limiting the search using one of the available filter settings?

lansuse wrote:

So I dont need the exact amount of test scenarios for each machine, I just used to refresh to check my comments.

Sorry, I missed a word in my question. What I actually meant: What is the benefit of having each test scenario in https://openqa.suse.de/tests/overview?distri=sle&version=12-SP5&build=0216&groupid=240 at least twice, one time for 64bit and once again for 64bit-smp?

I have try with filter to reduce lines in a page, but still reproduce the issue.
For the two machine types, because their kernel config are different, and we need to cover various senarios, such as cloud user.

#5 Updated by okurz about 2 years ago

  • Assignee changed from okurz to lansuse

please update the description of the ticket according to the bug defect template with the most minimal way to reproduce the issue, e.g. a URL pointing to the filtered page where the issue still shows up.

#6 Updated by lansuse about 2 years ago

  • Description updated (diff)

#7 Updated by lansuse about 2 years ago

  • Description updated (diff)

#8 Updated by lansuse about 2 years ago

  • Description updated (diff)

#9 Updated by lansuse about 2 years ago

  • Status changed from Feedback to New
  • Assignee changed from lansuse to okurz

#10 Updated by okurz about 2 years ago

  • Related to action #16354: Unambiguous lookup of "preferred machine" for same amount of multiple machine types added

#11 Updated by okurz about 2 years ago

  • Status changed from New to Feedback

thanks for the update, let's see how it looks after #16354

#12 Updated by okurz about 2 years ago

  • Status changed from Feedback to Blocked

#13 Updated by mkittler about 2 years ago

That really sounds like an exact duplicate of the issue mentioned by @okurz.

#14 Updated by okurz about 2 years ago

  • Status changed from Blocked to Resolved

change from #16354 is effective on both o3 and osd now. I checked the link from the description refreshing and clicking the first link like 10 times and it's unambiguous now.

Also available in: Atom PDF