Project

General

Profile

Actions

action #139055

closed

Comments mentioning bugrefs as part of a sentence are treated like bug refs and taken over size:S

Added by livdywan 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2023-10-27
Due date:
2023-11-17
% Done:

0%

Estimated time:

Description

Observation

I was using openqa-advanced-retrigger-jobs to retrigger failed jobs and also include a comment

  1. See how https://openqa.suse.de/tests/12753455#comments has a comment Re-running to verify connection with poo#138698
  2. See how the clone has a takeover message https://openqa.suse.de/tests/12754970#comments
  3. See how the build also includes the "bugref" https://openqa.suse.de/tests/overview?groupid=439&distri=sle&version=15-SP4&build=%3A31277%3Apostgresql

As far as I was aware bugs/tickets/issues must be separate or they won't be treated as bugrefs. I'm not sure if this is a regression. It caught me by surprise at the least.

Acceptance criteria

  • AC1: It is clear from the docs how bugref semantics work

Suggestions

  • Confirm if this behavior is a regression
  • Add documentation to clarify the behavior - it seems like we don't have any specific examples that would help find out if this was expected or not
  • Decide if this is desirable or not, and change the code accordingly
  • Consider #136244 which is also discussing the semantics of bugrefs

Related issues 2 (0 open2 closed)

Related to openQA Project - action #136244: Ensure arbitrary comments can be taken over to new jobs size:MResolveddheidler2023-09-212023-11-17

Actions
Copied from openQA Project - action #138698: significant increase in multi-machine test failures on OSD since 2023-10-25, e.g. test fails in support_server/setup size:MResolvedmkittler2023-10-27

Actions
Actions #1

Updated by livdywan 5 months ago

  • Copied from action #138698: significant increase in multi-machine test failures on OSD since 2023-10-25, e.g. test fails in support_server/setup size:M added
Actions #2

Updated by livdywan 5 months ago

  • Description updated (diff)
Actions #3

Updated by livdywan 5 months ago

  • Description updated (diff)
Actions #4

Updated by livdywan 5 months ago

  • Related to action #136244: Ensure arbitrary comments can be taken over to new jobs size:M added
Actions #5

Updated by okurz 5 months ago

  • Category set to Feature requests
  • Assignee set to okurz
  • Target version set to Ready
Actions #6

Updated by okurz 5 months ago

  • Due date changed from 2023-11-11 to 2023-11-17
  • Status changed from New to Feedback
Actions #7

Updated by livdywan 5 months ago

  • Subject changed from Comments mentioning bugrefs as part of a sentence are treated like bug refs and taken over to Comments mentioning bugrefs as part of a sentence are treated like bug refs and taken over size:S
  • Description updated (diff)
Actions #8

Updated by okurz 5 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF