Project

General

Profile

action #13252

enable yast2_nis test

Added by lnussel about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Start date:
2016-08-19
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

there is a yast2 nis test but it's not used anywhere AFAICS.

Guess what is broken in Leap that we could have detected already with that ...


Related issues

Related to openQA Tests - action #9900: [sle][functional][hard][opensuse][y] nis+autofsResolved2020-04-06

History

#1 Updated by okurz almost 5 years ago

  • Category set to New test

#2 Updated by maritawerner almost 5 years ago

  • Assignee set to dzedro

Jozef are you working on that?

#3 Updated by dzedro almost 5 years ago

I'm not sure what could this test detect as it doesn't test NIS functionality, at best it's testing UI

#4 Updated by okurz almost 5 years ago

  • Category changed from New test to Bugs in existing tests
  • Assignee changed from dzedro to zluo
  • Priority changed from High to Normal

yes, the test does not test NIS but that is not the problem here. The problem is that the module is not called in any main.pm. That should be fixed after checking that the test module still works. Assigning to zluo as the original author.

#5 Updated by okurz almost 5 years ago

Discussed with zluo: The addition to the test plan was initially rejected because we wanted to find a common solution for both SLE and openSUSE (and in the process failed to add it for any ;-) ). I suggest to do the following steps in this order:

  • add module to SLE test plan as is
  • check module works for SLE using the production NIS instance (nis.suse.de)
  • merge this test
  • next step: Add NIS server in "supportserver"
  • use supportserver in yast2_nis test instead of nis.suse.de
  • add yast2_nis for both sle and opensuse

agreed?

#6 Updated by maritawerner almost 5 years ago

  • Target version set to Milestone 4

#7 Updated by zluo almost 5 years ago

  • Category changed from Bugs in existing tests to Enhancement to existing tests
  • Status changed from New to In Progress

#8 Updated by zluo almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

test case works fine:
reference test (yast2_nis): https://openqa.suse.de/tests/647250

#9 Updated by lnussel almost 5 years ago

that one uses an internal server so that cannot be used for openSUSE. is there a separate issue to improve that?

#10 Updated by zluo almost 5 years ago

Since I cannot provide a working support server(using tap device) for multi machine testing. As discussed with okurz we add this simple nis test for sles only. If you know someone can help with tap device, please let me know.

#11 Updated by lnussel almost 5 years ago

you mean for a test setup on your workstation? I'm sure there's someone among your colleagues who could take a look at the openqa.suse.de workers to duplicate their setup on a test system.

#12 Updated by zluo almost 5 years ago

Unfortunately no. I tried so long and the documentation on openQA for tap setup is not really useful.

#13 Updated by okurz almost 5 years ago

So commit 81d71f3 makes use of the module which was previously unused. That is very good. Btw, the always latest can be found here. Thank you zluo for this.

Keep in mind that this ticket here focuses on the yast configuration interface even though it uses a nis server. There is still #9900 which dzedro is working on and is still in progress. I will link these tickets accordingly.

As mentioned in #13252#note-5 the way to go after we now have the module used in SLE is either

  • next step: Add NIS server in "supportserver"
  • use supportserver in yast2_nis test instead of nis.suse.de
  • add yast2_nis for both sle and opensuse

OR

  • continue on tests/x11/nis_client.pm and tests/x11/nis_server.pm as started by dzedro, see #9900

Let's concentrate on one ticket and not duplicate work. We can still later one consolidate on making yast2_nis focus more on the interface and the others on functionality and keep both for SLE as well as openSUSE.

#14 Updated by okurz almost 5 years ago

  • Related to action #9900: [sle][functional][hard][opensuse][y] nis+autofs added

Also available in: Atom PDF