Project

General

Profile

Actions

action #126680

closed

[openQA-in-openQA] no candidate needle with tag(s) 'boot-menu, openqa-desktop' matched in worker size:M

Added by livdywan over 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Observation

Apparently the worker tests in openQA-in-openQA are broken:

# Test died: no candidate needle with tag(s) 'boot-menu, openqa-desktop' matched

https://openqa.opensuse.org/tests/3193538#step/worker/3

Acceptance criteria

  • AC1: openQA-in-openQA worker module passes consistently
  • AC2: The test is less dependent on GNOME design changes

Suggestions

  • Look into providing the missing needle
  • Adapt the test case accordingly
  • Don't use a GNOME desktop which frequently undergoes design changes e.g. gmrun, icewm, openbox

Related issues 4 (0 open4 closed)

Related to openQA Project - action #133025: Configure Virtual Interfaces instructions do not work on Leap 15.5 size:MResolveddheidler2023-07-192023-10-31

Actions
Related to openQA Project - action #138203: [openQA-in-openQA] CI jobs show error but don't fail the CI job as they should *and* openqa_install+publish missing size:MResolvedjbaier_cz2023-10-18

Actions
Related to openQA Tests - action #135143: [tools] test fails in openqa_from_git -> dashboard size:M auto_review:"no candidate needle.*boot-menu, openqa-desktop":retryResolvedjbaier_cz2023-09-04

Actions
Related to openQA Tests - action #152667: openQA-in-openQA tests fail since 2023-12-14 in gnome login dialogResolvedjbaier_cz2023-12-15

Actions
Actions #1

Updated by okurz over 1 year ago

  • Tags set to openQA-in-openQA, needle, gnome
  • Status changed from New to In Progress
  • Assignee set to okurz

The jobs passed again with https://github.com/os-autoinst/os-autoinst-needles-openQA/commit/499a3292bf9a2b48a4da9fa2d219d61f5fe00770 applied but IMHO we can improve because we don't want to care about how gnome looks in an openQA test. We could switch to icewm or something which is much less likely to change in behavior and look than gnome.

I triggered a job based on the HDD image created by https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=NET&machine=64bit&test=create_hdd_minimalx&version=Tumbleweed with

openqa-clone-job --within-instance https://openqa.opensuse.org/tests/3193538 --skip-chained-deps BUILD= _GROUP=0 TEST+=okurz-try_minimalx_base_image HDD_1=opensuse-Tumbleweed-x86_64-20230325-minimalx@64bit.qcow2

this fails in
https://openqa.opensuse.org/tests/3194088#step/boot/4 showing that the image boots icewm (actually quite fast) and then expects a login in contrast to the gnome image which has "auto-login". I created a new needle "openqa-desktop-minimalx-login-20230327" as our function "wait_for_desktop" supports handling the login.

There is one point where we apply gnome-specifics so we need to change code for that as well: https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/112

openqa-clone-custom-git-refspec https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/112 https://openqa.opensuse.org/tests/3194109

-> https://openqa.opensuse.org/tests/3194152

Actions #2

Updated by okurz over 1 year ago

  • Status changed from In Progress to New
  • Priority changed from High to Normal

The urgency was already initially removed. I plan to continue the following days

Actions #3

Updated by osukup over 1 year ago

new gnome/ new needles needed ?

Actions #4

Updated by okurz over 1 year ago

osukup wrote:

new gnome/ new needles needed ?

Yes, that was the case. That is what mkittler did yesterday. I am trying to use icewm as base

Actions #5

Updated by livdywan over 1 year ago

  • Subject changed from [openQA-in-openQA] no candidate needle with tag(s) 'boot-menu, openqa-desktop' matched in worker to [openQA-in-openQA] no candidate needle with tag(s) 'boot-menu, openqa-desktop' matched in worker size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #6

Updated by okurz over 1 year ago

  • Status changed from Workable to Blocked

I'd like to continue after #126950 and #126704 so that I have a good example scenario where I can verify and try those fixes/features.

Actions #7

Updated by tinita 11 months ago

link to latest failure for reference: https://openqa.opensuse.org/tests/3567464

Actions #9

Updated by okurz 10 months ago

  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)

unblocked

Actions #10

Updated by okurz 10 months ago

  • Target version changed from Ready to Tools - Next
Actions #11

Updated by okurz 9 months ago

  • Target version changed from Tools - Next to Ready
Actions #12

Updated by okurz 8 months ago

  • Priority changed from Normal to High
Actions #13

Updated by jbaier_cz 8 months ago

  • Assignee set to jbaier_cz
Actions #14

Updated by jbaier_cz 8 months ago

  • Related to action #133025: Configure Virtual Interfaces instructions do not work on Leap 15.5 size:M added
Actions #15

Updated by jbaier_cz 8 months ago

  • Status changed from Workable to In Progress

First complication ahead, since https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/147 we need to use wicked which is unfortunately only in the Gnome image (as the default is afaik NM). I will ignore it for now and will continue with my initial experiments, but we will definitely need to discuss further steps.

Actions #16

Updated by openqa_review 8 months ago

  • Due date set to 2023-12-05

Setting due date based on mean cycle time of SUSE QE Tools

Actions #17

Updated by jbaier_cz 8 months ago

As a first step, I tried to enhance our support to also allow NetworkManager in multi-machine setup script: https://github.com/os-autoinst/os-autoinst/pull/2407 This will allow us to use other pre-made HDDs with different desktops, where wicked is not installed by default.

Actions #18

Updated by jbaier_cz 8 months ago

  • Status changed from In Progress to Feedback

I created some minor updates inspired by what was already done by okurz and put it all together. The main PR (which links to other needed work) is at https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/154. Feedback welcomed.

Actions #19

Updated by jbaier_cz 8 months ago

Add the PR tests are currently not working due to #138203

Actions #20

Updated by jbaier_cz 8 months ago

  • Related to action #138203: [openQA-in-openQA] CI jobs show error but don't fail the CI job as they should *and* openqa_install+publish missing size:M added
Actions #21

Updated by okurz 8 months ago

  • Due date deleted (2023-12-05)
  • Status changed from Feedback to Blocked
  • Priority changed from High to Normal

blocking on #138203

Actions #22

Updated by jbaier_cz 8 months ago

  • Related to action #135143: [tools] test fails in openqa_from_git -> dashboard size:M auto_review:"no candidate needle.*boot-menu, openqa-desktop":retry added
Actions #23

Updated by jbaier_cz 8 months ago

  • Status changed from Blocked to Feedback

No longer blocked, pipeline should be working again.

Actions #24

Updated by jbaier_cz 8 months ago

The actual switch away from Gnome should be possible by https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/156

Actions #25

Updated by jbaier_cz 7 months ago

  • Status changed from Feedback to In Progress
Actions #26

Updated by jbaier_cz 7 months ago

  • Status changed from In Progress to Feedback

I added a simple workaround as part of https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/156; now it should be safe and possible to switch the desktop environment if we want.

Actions #27

Updated by jbaier_cz 7 months ago

  • Status changed from Feedback to Resolved
Actions #28

Updated by jbaier_cz 7 months ago

Also added a fix for jenkins jobs https://github.com/os-autoinst/scripts/pull/277

Actions #29

Updated by jbaier_cz 7 months ago

  • Related to action #152667: openQA-in-openQA tests fail since 2023-12-14 in gnome login dialog added
Actions #30

Updated by okurz 7 months ago

jbaier_cz wrote in #note-28:

Also added a fix for jenkins jobs https://github.com/os-autoinst/scripts/pull/277

merged

Actions

Also available in: Atom PDF