Project

General

Profile

Actions

action #135143

closed

[tools] test fails in openqa_from_git -> dashboard size:M auto_review:"no candidate needle.*boot-menu, openqa-desktop":retry

Added by osukup 9 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2023-09-04
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_from_git@64bit-2G fails in
dashboard

Test suite description

test fails in ensure_unlocked_desktop .. send first click in login screen to show password prompt but not type password.
I tried create needle -> needle correctly saved, but it looks like ensure_unlocked_desktop has problem in main loop :(

Reproducible

Fails since (at least) Build :TW.22712

Expected result

Last good: :TW.22711 (or more recent)

Further details

Always latest result in this scenario: latest

Acceptance criteria

AC1: test successfully unlocks desktop


Related issues 2 (1 open1 closed)

Related to openQA Project - coordination #106922: [epic][sporadic] openqa_from_git fails in dashboard due to ensure_unlocked_desktop not expecting password entry screen in case of locked desktop auto_review:"match=desktop-runner,screenlock timed out.*":retryBlockedokurz2022-02-16

Actions
Related to openQA Project - action #126680: [openQA-in-openQA] no candidate needle with tag(s) 'boot-menu, openqa-desktop' matched in worker size:MResolvedjbaier_cz

Actions
Actions #1

Updated by osukup 9 months ago

  • Related to coordination #106922: [epic][sporadic] openqa_from_git fails in dashboard due to ensure_unlocked_desktop not expecting password entry screen in case of locked desktop auto_review:"match=desktop-runner,screenlock timed out.*":retry added
Actions #2

Updated by okurz 9 months ago

  • Target version set to Ready
Actions #3

Updated by livdywan 9 months ago

  • Subject changed from [tools] test fails in openqa_from_git -> dashboard to [tools] test fails in openqa_from_git -> dashboard size:M
  • Status changed from New to Workable
Actions #4

Updated by osukup 9 months ago

  • Assignee set to osukup

looks like main problem are wrongly tagged needles ..

Actions #6

Updated by osukup 9 months ago

  • Status changed from Workable to In Progress
Actions #7

Updated by openqa_review 9 months ago

  • Due date set to 2023-09-27

Setting due date based on mean cycle time of SUSE QE Tools

Actions #8

Updated by osukup 9 months ago

  • Status changed from In Progress to Resolved

changes merged. So now ensure_unlocked_desktop should work as excepted

Actions #9

Updated by okurz 8 months ago

  • Status changed from Resolved to Workable
  • Assignee deleted (osukup)
  • Priority changed from Normal to Urgent

I think this broke other tests, see https://openqa.opensuse.org/tests/3580801#step/worker/1 where we need the generic desktop needles in the "locked" variant. https://github.com/os-autoinst/os-autoinst-needles-openQA/pull/20 removed the according tags.

The problem is only apparent in the "full" scenario which takes long enough to clone the test distribution and install dependencies that the desktop is always locked before being able to return to the desktop from the text terminal. Likely the problem was not seen in before due to the scenario not being referenced properly which was fixed by https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/145

Actions #10

Updated by okurz 8 months ago

  • Subject changed from [tools] test fails in openqa_from_git -> dashboard size:M to [tools] test fails in openqa_from_git -> dashboard size:M auto_review:"no candidate needle.*boot-menu, openqa-desktop":retry
Actions #12

Updated by okurz 8 months ago

  • Priority changed from Urgent to Normal
Actions #13

Updated by okurz 8 months ago

  • Due date deleted (2023-09-27)
  • Target version changed from Ready to Tools - Next
Actions #14

Updated by osukup 6 months ago

okurz wrote in #note-9:

I think this broke other tests, see https://openqa.opensuse.org/tests/3580801#step/worker/1 where we need the generic desktop needles in the "locked" variant. https://github.com/os-autoinst/os-autoinst-needles-openQA/pull/20 removed the according tags.

The problem is only apparent in the "full" scenario which takes long enough to clone the test distribution and install dependencies that the desktop is always locked before being able to return to the desktop from the text terminal. Likely the problem was not seen in before due to the scenario not being referenced properly which was fixed by https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/145

no. we need the correct needles with the correct tag and generic-desktop isn't locked desktop.

Actions #15

Updated by okurz 6 months ago

  • Target version changed from Tools - Next to Ready
Actions #16

Updated by jbaier_cz 6 months ago

  • Assignee set to jbaier_cz
Actions #17

Updated by jbaier_cz 6 months ago

  • Related to action #126680: [openQA-in-openQA] no candidate needle with tag(s) 'boot-menu, openqa-desktop' matched in worker size:M added
Actions #18

Updated by jbaier_cz 6 months ago

  • Status changed from Workable to In Progress

Will try to replicate the issue; this might be also already resolved or/and it might be also mitigated with #126680

Actions #19

Updated by jbaier_cz 6 months ago

  • Status changed from In Progress to Feedback

After looking at the code, I think the issue is (as hinted above) that generic-desktop and screenlock shouldn't be on used on the same needle. The code expects generic-desktop to be the unlocked, usable, target screen. https://github.com/os-autoinst/os-autoinst-needles-openQA/pull/23 should make the situation right for cases, where the installation is long enough for the screen to be locked.

Actions

Also available in: Atom PDF