Project

General

Profile

Actions

coordination #121855

closed

[epic] Agama web interactive installation

Added by JERiveraMoya over 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2023-01-23
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

Motivation

Having a clear strategy to apply integration testing with Agama is becoming more relevant. Because testing the full installation workflow for at least TW and ALP is a time-consuming task and we need to find new bugs ASAP.
The problem is that openQA is not a good fit for checking the UI (driving the browser), although it is a good option for the rest.
Developers are working on this strategy in https://trello.com/c/x01mLJzy/3223-8-research-design-a-qa-strategy and Yam squad plan to collaborate closely with them.

Acceptance criteria

AC1: Learn and share knowledge about Web Automation for Agama
AC2: Create web automation with corresponding tool


Subtasks 26 (0 open26 closed)

action #123553: Sync D-Installer snapshots from OBS in O3ResolvedJERiveraMoya2023-01-23

Actions
action #124550: PoC running Playwright tests directly from the Live ISO in openQAResolvedleli2023-02-15

Actions
action #128192: Synchronize Agama OBS images to openQARejectedsyrianidou_sofia2023-04-24

Actions
action #128495: [Timebox: 24h] Investigate how to run Agama in s390xResolvedcoolgw2023-05-02

Actions
action #130000: Integrate yupdate script in openQA in order to get e2e playwright tests from a different repoResolvedcoolgw2023-05-29

Actions
action #130003: Add test for Full-disk encryption installationResolvedrainerkoenig2023-05-29

Actions
action #130045: Create POM to define user and root authenticationResolvedsyrianidou_sofia2023-05-29

Actions
action #130054: Add test for LVM installationResolvedleli2023-05-29

Actions
action #130709: Synchronize Agama staging project with O3 using OBS Sync pluginResolvedcoolgw2023-06-12

Actions
action #132548: Run manual testing for Agama on s390x z/VMResolvedsyrianidou_sofia2023-07-11

Actions
action #132593: Run manual testing for Agama on powerpc64le kvmResolvedJRivrain

Actions
action #132884: Create POM for product selection in AgamaResolvedleli2023-07-17

Actions
action #132887: Create POM for the main screen in agamaResolvedleli2023-07-17

Actions
action #132890: Create POM for 'Confirm Installation', 'Installing' and 'Installation Finished' screens in AgamaResolvedrainerkoenig2023-07-17

Actions
action #132989: Unify interactive installations in tests/yam/agama and its respective schedulesResolvedtinawang1232023-08-28

Actions
action #133010: Create an agama-playwright installation with LVM and encryption testsuiteResolvedsyrianidou_sofia2023-07-19

Actions
action #133073: Create test and POM for selecting another installation deviceResolvedJRivrain2023-07-20

Actions
action #133103: Create test and POM for adding a home file systemResolvedlmanfredi2023-07-20

Actions
action #133445: Consolidate pages directories in agama-playwright testsResolvedlmanfredi2023-07-27

Actions
action #133562: Change hard coded product names in playwright test specsResolvedleli2023-07-31

Actions
action #134117: Agama Dolomite auto installation fails due to product changesResolvedleli2023-08-11

Actions
action #134228: Create a Dolomite default installation and modify Tumbleweed default installation without using CI testsResolvedsyrianidou_sofia2023-08-15

Actions
action #134318: Synchronize Agama Devel project with O3 using OBS Sync pluginResolvedsyrianidou_sofia2023-06-12

Actions
action #134690: Enable logs upload for agama playwright testsResolvedlmanfredi2023-08-28

Actions
action #134798: Replace repeating code for user and root password in playwright testsResolvedlmanfredi2023-08-30

Actions
action #135131: Adapt method to use getByLabel for user POM in agama playwright testResolvedleli2023-09-04

Actions

Related issues 1 (0 open1 closed)

Related to qe-yam - coordination #121933: [saga] Innovation in Yam squadResolvedJERiveraMoya2022-09-12

Actions
Actions #1

Updated by JERiveraMoya over 1 year ago

  • Subject changed from [Epic] Web automation of D-Installer to [Epic] Web automation for D-Installer
Actions #2

Updated by JERiveraMoya over 1 year ago

  • Subject changed from [Epic] Web automation for D-Installer to [epic] Web automation for D-Installer
Actions #3

Updated by JERiveraMoya over 1 year ago

Actions #4

Updated by JERiveraMoya over 1 year ago

  • Tags deleted (qe-yam-refinement)
Actions #5

Updated by JERiveraMoya over 1 year ago

  • Parent task deleted (#121837)
Actions #6

Updated by JERiveraMoya over 1 year ago

Actions #7

Updated by JERiveraMoya over 1 year ago

Actions #8

Updated by JERiveraMoya over 1 year ago

  • Subject changed from [epic] Web automation for D-Installer to [epic] D-Installer web interactive installation
Actions #9

Updated by JERiveraMoya about 1 year ago

  • Status changed from New to In Progress
Actions #10

Updated by JERiveraMoya about 1 year ago

  • Subject changed from [epic] D-Installer web interactive installation to [epic] Agama web interactive installation
Actions #11

Updated by JERiveraMoya about 1 year ago

  • Description updated (diff)
Actions #12

Updated by JERiveraMoya 11 months ago

  • Subtask #134690 added
Actions #13

Updated by rainerkoenig 11 months ago

  • Subtask #135131 added
Actions #14

Updated by rainerkoenig 11 months ago

  • Subtask #134798 added
Actions #15

Updated by leli 9 months ago

  • Subtask #135374 added
Actions #16

Updated by JERiveraMoya 7 months ago

  • Subtask deleted (#135374)
Actions #17

Updated by JERiveraMoya 7 months ago

  • Subtask deleted (#130573)
Actions #18

Updated by JERiveraMoya 7 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF