Project

General

Profile

Actions

action #116914

open

[qe-core] recent uefi changes makes test fail

Added by dimstar almost 2 years ago. Updated 3 months ago.

Status:
Workable
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-09-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-upgrade_Leap_15.0_cryptlvm@uefi fails in
bootloader_uefi

There are quite recent changes around UEFI handling (mostly for grub resolution)

The referenced test now fails with both provided UEFI PFLASH_VARS:

  • ovmf-x86_64-ms-vars-800x600.qcow2 => system does not boot at all
  • /usr/share/qemu/ovmf-x86_64-ms-vars.bin => system boots, installs, but later fails on user GUI login

Test suite description

Upgrade scenario with cryptlvm for Leap 15.0.

Reproducible

Fails since (at least) Build 20220915

Expected result

Last good: 20220914 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 5 (1 open4 closed)

Related to openQA Project - action #113794: Use prepared OVMF image with expected settings size:MResolvedtinita2022-06-03

Actions
Related to openQA Project - action #111992: Deal with QEMU and OVMF default resolution being 1280x800, affecting (at least) qxl size:MResolvedtinita2022-06-03

Actions
Related to openQA Tests - action #116812: [qe-core] Leap 15.5 uefi console switch fail size:MBlockedokurz2022-09-19

Actions
Related to openQA Tests - action #116704: [qe-core] nvme@uefi: boot from DVD post install instead of from HDDResolvedtinita2022-09-16

Actions
Related to openQA Tests - action #117400: [qe-core] cryptlvm - all tests fail to boot Resolvedpdostal2022-09-29

Actions
Actions #1

Updated by maritawerner almost 2 years ago

  • Subject changed from recent uefi changes makes test fail to [qe-core] recent uefi changes makes test fail
Actions #2

Updated by maritawerner almost 2 years ago

might be also for the qe yast team

Actions #3

Updated by okurz almost 2 years ago

  • Related to action #113794: Use prepared OVMF image with expected settings size:M added
Actions #4

Updated by okurz almost 2 years ago

  • Related to action #111992: Deal with QEMU and OVMF default resolution being 1280x800, affecting (at least) qxl size:M added
Actions #5

Updated by okurz almost 2 years ago

  • Related to action #116812: [qe-core] Leap 15.5 uefi console switch fail size:M added
Actions #6

Updated by okurz almost 2 years ago

  • Related to action #116704: [qe-core] nvme@uefi: boot from DVD post install instead of from HDD added
Actions #7

Updated by tinita almost 2 years ago

Just to confirm the relation to ovmf:
I scheduled this test: https://openqa.opensuse.org/tests/2774162 on openqaworker19 with a downgraded package and it passed (well, softfailed somewhere else).

Actions #8

Updated by pdostal almost 2 years ago

When I change the UEFI_PFLASH_VARS variable from ovmf-x86_64-ms-vars-800x600.qcow2 to /usr/share/qemu/ovmf-x86_64-ms-vars.bin then it works. See before and after and compare the UEFI_PFLASH_VARS variables.

Actions #9

Updated by pdostal almost 2 years ago

  • Related to action #117400: [qe-core] cryptlvm - all tests fail to boot added
Actions #10

Updated by tinita almost 2 years ago

Yeah, but https://openqa.opensuse.org/tests/2774190#step/user_gui_login/13 fails in user_gui_login, that's also mentioned in the ticket description.
I don't know how that is related to the ovmf package, but if I downgrade, everything passes.

I don't know who changed the UEFI_PFLASH_VARS setting for uefi, it's not mentioned in https://progress.opensuse.org/issues/113794

Actions #11

Updated by tinita almost 2 years ago

I downgraded qemu-ovmf-x86_64 on all workers again.

I set back UEFI_PFLASH_VARS to /usr/share/qemu/ovmf-x86_64-ms-vars.bin

We are waiting for feedback on https://bugzilla.opensuse.org/show_bug.cgi?id=1204067

Actions #12

Updated by tinita over 1 year ago

  • Status changed from New to Feedback
  • Assignee set to tinita

@dimstar @pdostal Could you run the previously failing tests on openqaworker19?

I upgraded there to ovmf-202202-150400.5.5.1.src which has several patches that might fix the issues.

The original linked tests are delete by now, so I'm not sure how to test.

Actions #13

Updated by tinita over 1 year ago

  • Status changed from Feedback to Workable
  • Assignee deleted (tinita)

We had to downgrade the package again on all workers. I can't find the ticket right now where @okurz wrote that.
Unassigning myself

Actions #14

Updated by slo-gin 4 months ago

This ticket was set to Normal priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

Actions #15

Updated by mgrifalconi 3 months ago

  • Subject changed from [qe-core] recent uefi changes makes test fail to [tools] recent uefi changes makes test fail

As I understand, tools did some change to workers. So moving to tools: is the workaround still in place since 1 year? Please let us know what qe-core should do to solve the issue entirely.
Is the problem solved? Please resolve the ticket :)

Actions #16

Updated by okurz 3 months ago

  • Subject changed from [tools] recent uefi changes makes test fail to [qe-core] recent uefi changes makes test fail

No, we removed the workaround after
https://bugzilla.opensuse.org/show_bug.cgi?id=1204067
was verified fixed so it's assumed that the original problem is fixed but there might be certainly other issues that you can look into

Actions

Also available in: Atom PDF