Project

General

Profile

Actions

action #111752

closed

[leap][qe-core] test fails in xterm - mistyping test string due to lost focus

Added by mloviska almost 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-05-30
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.4-Leap-DVD-Incidents-x86_64-gnome@64bit fails in
xterm

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Maintainer: slindomansilla

The standard scenario where we mainly just follow installation suggestions without any adjustments as long as the default desktop is gnome.

Reproducible

Fails since (at least) Build :24410:vim (current job)

Expected result

Last good: :24409:vim (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Project - action #110542: Try to mitigate "VNC typing issues" with disabled key repeatResolvedokurz2022-05-02

Actions
Actions #1

Updated by punkioudi almost 2 years ago

  • Tags set to bugbusters
  • Status changed from New to Workable
  • Target version set to QE-Core: Ready

It seems to me like a sporadical issue. I will add it in the bugbusters list, but with a normal priority :)

Actions #2

Updated by mloviska over 1 year ago

Actions #3

Updated by mloviska over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to mloviska
Actions #4

Updated by okurz over 1 year ago

  • Related to action #110542: Try to mitigate "VNC typing issues" with disabled key repeat added
Actions #6

Updated by mloviska over 1 year ago

Haven't seen a xterm failure lately

Actions #7

Updated by mloviska over 1 year ago

  • Status changed from In Progress to Resolved
Actions #9

Updated by mloviska over 1 year ago

xterm does not run as native Wayland application, but as XWayland.

localhost  gsd-xsettings
localhost.localdomain  gnome-shell
localhost.localdomain  spice-vdagent
localhost.localdomain  xterm
localhost.localdomain  xterm

AFAICT, the lost focus appears mostly right after reboot of the machine.
Adding a sleep call in updates_packagekit_gpk::setup_system before executing x11_start_program does not show the issue anymore. Maybe we are dealing with some race condition, however I have not reproduced the issue outside openQA

Actions #10

Updated by mloviska over 1 year ago

Seems like the lost focus happens when a X11 application is started before Xwayland

UID        PID  PPID  C STIME TTY          TIME CMD
bernhard  1683  1253  0 09:29 ?        00:00:00 xcalc ---> started w/o focus
bernhard  1684  1253  0 09:29 ?        00:00:00 /usr/bin/Xwayland :0 -rootless -
bernhard  1824  1253  0 09:30 ?        00:00:00 xterm ---> started w/ focus

they all have a common parent

UID        PID  PPID  C STIME TTY          TIME CMD
bernhard  1253  1172  2 09:29 ?        00:00:13 /usr/bin/gnome-shell
Actions #11

Updated by mloviska over 1 year ago

GNOME focus default settings for new windows is set to smart, seemingly changing the option to strict might fix our sporadic stealing windows focus issue.

Actions #13

Updated by mloviska over 1 year ago

  • Subject changed from [leap][qe-core] test fails in xterm - mistyping test string to [leap][qe-core] test fails in xterm - mistyping test string due to lost focus
Actions #14

Updated by mloviska over 1 year ago

  • Status changed from In Progress to Feedback
Actions #16

Updated by apappas over 1 year ago

  • Status changed from Feedback to Workable

This has been appearing a log lately, and the PR has stalled, so, after discussing it with Martin I am putting this back to the bug buster queue.

Actions #17

Updated by apappas over 1 year ago

  • Assignee deleted (mloviska)
Actions #18

Updated by apappas over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to apappas
Actions #19

Updated by VANASTASIADIS about 1 year ago

  • Status changed from In Progress to Workable
  • Assignee deleted (apappas)
Actions #20

Updated by apappas about 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to apappas
Actions #21

Updated by dzedro about 1 year ago

  • Assignee changed from apappas to dzedro
Actions #22

Updated by zcjia about 1 year ago

  • Status changed from In Progress to Resolved

I added 'x11_start_program_xterm' in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/16339 .

I use it instead of 'x11_start_program(xterm)' in 'ensure_installed' already.

If this problem persists, for example in "updates_packagekit_gpk", then we do the replace there again to resolve the problem.

Actions

Also available in: Atom PDF