Project

General

Profile

action #99375

[qe-yast] test fails in yast_keyboard

Added by mgrifalconi 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-mau-extratests-yast2ui-textmode@64bit fails in
yast_keyboard

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Run console tests against aggregated test repo

Reproducible

Fails since (at least) Build 20210928-1 (current job)

Expected result

Last good: 20210927-2 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by tjyrinki_suse about 2 months ago

  • Project changed from openQA Tests to qe-yast
  • Subject changed from [qe-core] test fails in yast_keyboard to [qe-yast] test fails in yast_keyboard
  • Category deleted (Bugs in existing tests)
  • Start date deleted (2021-09-28)

Yast related, and module states QE Yast is the maintainer.

#2 Updated by tjyrinki_suse about 2 months ago

  • Status changed from New to Resolved
  • Target version set to QE-Core: Ready

MR merged.

#3 Updated by szarate about 2 months ago

  • Status changed from Resolved to Feedback

pr missing

#4 Updated by mgrifalconi about 2 months ago

  • Assignee deleted (mgrifalconi)

PR was https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13364
but did not help.

One suggestion could be to switch to serial console for better performance.
In any case, since it's wasn't a very quick fix, handing over to owners at qe-yast.

#5 Updated by mgrifalconi about 2 months ago

  • Target version deleted (QE-Core: Ready)

#6 Updated by syrianidou_sofia about 2 months ago

  • Status changed from Feedback to Workable

what the test module does is to install yast2-country and then run
yast keyboard list
yast keyboard set layout=korean
In y2logs:

2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:1022 Not setting X keyboard due to text mode
2021-09-28 00:13:19 <2> susetest(22377) [ui-shortcuts] YShortcutManager.cc(checkShortcuts):85 Not enough widgets with valid shortcut characters - no check
2021-09-28 00:13:19 <3> susetest(22377) [Ruby] modules/Linuxrc.rb:55 Reading install.inf, but file doesn't exist!!!
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:1556 Making X11 keyboard persistent: /usr/bin/localectl --no-convert set-x11-keymap "" pc104
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:933 Marked keyboard <nLyy.+49ps10DtUF> as configured = no
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:935 Marked keyboard <nLyy.+49ps10DtUF> as needed = no
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:956 NOT marking keyboard as configured (no unique_key)
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:959 Saved data for keyboard: <english-us>
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Keyboard.rb:1446 Regenerating initrd to make the change persistent
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Initrd.rb:151 Reseting initrd settings
2021-09-28 00:13:19 <3> susetest(22377) [Ruby] modules/Initrd.rb:171 sysconfig/kernel not found
2021-09-28 00:13:19 <1> susetest(22377) [Ruby] modules/Initrd.rb:332 Initrd::Write called, changed: true, list: []
2021-09-28 00:14:04 <1> susetest(22377) [Ruby] modules/Service.rb:154 Restarting service 'kbd'
2021-09-28 00:14:04 <1> susetest(22377) [Ruby] yast2/systemd_unit.rb:122 `systemctl show kbd.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath `
2021-09-28 00:14:04 <1> susetest(22377) [Ruby] yast2/systemd_unit.rb:122 `systemctl is-enabled kbd.service `
2021-09-28 00:14:04 <3> susetest(22377) [bash] ShellCommand.cc(shellcommand):78 Failed to get unit file state for kbd.service: No such file or directory
2021-09-28 00:14:04 <3> susetest(22377) [Ruby] modules/Service.rb:443 Service 'kbd' not found
2021-09-28 00:14:04 <1> susetest(22377) [Ruby] modules/CommandLine.rb:1597 Commandline interface finished
2021-09-28 00:14:04 <1> susetest(22377) [Ruby] modules/CommandLine.rb:1598 ----------------------------------------
2021-09-28 00:14:04 <1> susetest(22377) [ncurses] YNCursesUI.cc(~YNCursesUI):113 Stop YNCursesUI
2021-09-28 00:14:04 <1> susetest(22377) [ncurses] NCurses.cc(~NCurses):145 Shutdown NCurses...
2021-09-28 00:14:04 <1> susetest(22377) [ncurses] NCurses.cc(~NCurses):164 NCurses down
2021-09-28 00:14:04 <1> susetest(22377) [liby2] genericfrontend.cc(main):820 Finished YaST2 component 'y2base'
2021-09-28 00:14:04 <1> susetest(22377) [liby2] genericfrontend.cc(main):825 Exiting with client return value 'true'
2021-09-28 00:14:04 <1> susetest(22377) [Y2Ruby] binary/YRuby.cc(~YRuby):117 Shutting down ruby interpreter.

"Failed to get unit file state for kbd.service: No such file or directory" is quite a strange message according to YaST team. We should try to reproduce the issue with more RAM, before opening a bug for it. Cloning of the job has a problem with the repositories though. Disabling from schedule for now until solution is verified. We also need to create a yaml schedule for the job and remove all yast related modules from lib/main_common.pm.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13407

#7 Updated by dzedro about 2 months ago

Not sure what failure are you describing, because you try to exclude 12 SP5, but fail here is on 12 SP2.

#8 Updated by dzedro about 2 months ago

12-SP2 does not have this fix
https://bugzilla.suse.com/show_bug.cgi?id=1170292 yast keyboard tries to restart not existing kbd.service

#9 Updated by syrianidou_sofia about 2 months ago

dzedro wrote:

Not sure what failure are you describing, because you try to exclude 12 SP5, but fail here is on 12 SP2.

Oops.. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13412

#10 Updated by dzedro about 1 month ago

mgrifalconi wrote:

PR was https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13364
but did not help.

One suggestion could be to switch to serial console for better performance.
In any case, since it's wasn't a very quick fix, handing over to owners at qe-yast.

I guess this fixed the issue with static (30) timeout & this failure. https://github.com/os-autoinst/os-autoinst/pull/1819

#11 Updated by syrianidou_sofia about 1 month ago

  • Status changed from Workable to Closed

Increasing timeout seems to have fixed the issue for SLE12SP2 latest builds, let's close this ticket for now.

Also available in: Atom PDF