Project

General

Profile

action #99072

[qe-core] Make Leap 15.3 on osd green

Added by apappas 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-09-22
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Motivation

Leap 15.3 was added to osd, but no run has ever finished green. At time of creation the tests were stuck at the installer, however after qe-yast makes it work, we will have to intervene, with the ultimate goal of moving them away from the parent group.

Acceptance criteria

  • AC1: A run is fully green
  • AC2: Move the tests to production groups

Suggestions

  • Create a YAML schedule
  • Add all tests from o3 that are applicable

History

#1 Updated by apappas 2 months ago

  • Status changed from New to Feedback
  • Assignee set to apappas

The tests are now green.

As mentioned in Slack, the only thing remaining is to figure out who is doing the reviewing and define it's scope.

#2 Updated by apappas 2 months ago

  • Parent task changed from #72202 to #92563

#3 Updated by okurz 2 months ago

Topic was discussed in weekly QE sync 2021-09-29. Current state of tests with the existing two scenarios looks promising. IMHO no more scenarios should be added right now but only after people grew to really trust these tests over the next couple of months.

Looking at https://openqa.suse.de/group_overview/393 I saw not all tests green. There had been one occurence of https://progress.opensuse.org/issues/77728 which I reopened and retriggered the incomplete test. Such problems will be automatically handled as soon as the tests are not in the "development" job group anymore.

Problems I saw currently in the tests that look like should be looked into by QE-Core:

I suggest to diligently investigate and fix these problems before putting the tests into production where such failures would prevent auto-approval of maintenance updates.

#4 Updated by apappas about 2 months ago

  • Status changed from Feedback to Resolved

The chromium failure was caused by openqa failing to make type chrome://version and typing only chromium.
The failures have stopped happening during the last week, and they seem more like stall related to openqa load.
Furthermore these failures are happening on mature tests for a released product and so I believe the should be treated like failures in production. Not failures in development.

As a result I moved the tests to production and I am resolving the ticket.

#5 Updated by okurz about 2 months ago

  • Status changed from Resolved to Feedback

hi, great to see an improvement in stability. Just to be sure we are not introducing additional load on openQA reviewers: What helped to reduce the openQA load so that tests would not fail anymore in shutdown, chromium or updates_packagekit_gpk ? I am not sure I understand your statement "I believe the should be treated like failures in production. Not failures in development.". Does that mean there are according tickets for that? If yes, please reference them.

#6 Updated by szarate about 2 months ago

  • Status changed from Feedback to Resolved

I believe that the failure anton is mentioning is https://progress.opensuse.org/issues/43889 #43889. This ticket is done.

Also available in: Atom PDF