Project

General

Profile

action #93222

[qem][partitioning][maint] test fails in partitioning_raid - partitioning guide looks different in 15-SP3

Added by vsvecova 2 months ago. Updated about 2 months ago.

Status:
New
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-05-28
Due date:
% Done:

50%

Estimated time:
Difficulty:

Description

Needles and possibly other adjustments need to be done.

Observation

openQA test in scenario sle-15-SP3-Server-DVD-Incidents-Minimal-x86_64-qam-minimal-RAID1@64bit-smp fails in
partitioning_raid

Test suite description

Installation of RAID1 using expert partitioner
minimal = base pattern, minimal (enhanced base) pattern are additional convenience paclkages

Reproducible

Fails since (at least) Build :19526:shim

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dzedro 2 months ago

#3 Updated by JERiveraMoya about 2 months ago

dzedro wrote:

This is same or partitioning related issues https://openqa.suse.de/tests/6157328#step/partitioning_lvm_thin_provisioning/46

seems that they way to clone it is different with this one as it is pointing to branch instead of production, but the settings specified in the PR should help.

#4 Updated by dzedro about 2 months ago

  • Status changed from New to In Progress

#5 Updated by dzedro about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Tests are defined via webui, added YAML_SCHEDULE & in lvm_thin_provisioning YAML_TEST_DATA=test_data/yast/lvm_thin_provisioning/lvm_thin_provisioning.yaml

https://openqa.suse.de/tests/6165608 qam-minimal-RAID1
https://openqa.suse.de/tests/6165770 lvm_thin_provisioning

https://gitlab.suse.de/qa-maintenance/qam-openqa-yml/-/merge_requests/132

#6 Updated by dzedro about 2 months ago

  • Status changed from Resolved to New
  • Assignee set to JERiveraMoya
  • % Done changed from 100 to 50

Please make sure the profile does work on all SLE versions. YAML profile is now used only on 15 SP3 https://gitlab.suse.de/qa-maintenance/qam-openqa-yml/-/merge_requests/135
due to libyui not being "supported" on older versions https://openqa.suse.de/tests/6195032#step/setup_libyui/4

#7 Updated by JERiveraMoya about 2 months ago

This change is only for SP3, for older version is required the original schedule file or main.pm. UI only changed drastically in SP3.
I can see here you are running it in the correct way without the libyui: https://openqa.suse.de/tests/6203314

#8 Updated by dzedro about 2 months ago

Yes because it is not using yaml, but when you create yaml for test it should cover all versions.

#9 Updated by JERiveraMoya about 2 months ago

dzedro wrote:

Yes because it is not using yaml, but when you create yaml for test it should cover all versions.

It cannot cover all versions if the modules that are used are different, and they are different because of the switch to libyui REST api.
yaml file also contains test data which could be changed, for example when there is duplicated information. There is not guarantee at the moment to have that expectation (technically speaking) and get the benefit of this more stable approach with the modules not containing branching (if/else etc.) We are working to have that expectation in the future making more small and meaningful steps in the tests so any product can apply the same (schedule/ business logic), but it is a long way.

#10 Updated by dzedro about 2 months ago

Somobody removed YAML_SCHEDULE from https://openqa.suse.de/tests/6230175

#11 Updated by tjyrinki_suse about 2 months ago

https://gitlab.suse.de/qa-maintenance/qam-openqa-yml/-/merge_requests/140 for that case. The YAML_SCHEDULE was erronously added to test suites so removed from there, but when removing only added to QU SP3 job group (https://gitlab.suse.de/qa-maintenance/qam-openqa-yml/-/merge_requests/136).

Also available in: Atom PDF