Project

General

Profile

Actions

action #89755

closed

coordination #80142: [saga][epic] Scale out: Redundant/load-balancing deployments of openQA, easy containers, containers on kubernetes

container: Fix missing shared directories and its permissions

Added by ilausuch about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Regressions/Crashes
Target version:
Start date:
2021-03-09
Due date:
% Done:

0%

Estimated time:

Description

Observation

Some directories are missing generating errors like this

gru_1          | Can not create MOJO_TMPDIR : mkdir /var/lib/openqa/share/factory/tmp: Permission denied at /usr/share/openqa/script/../lib/OpenQA/Setup.pm line 306.

The directories has to be:

/data/factory/iso:rw
/data/factory/hdd:rw
/data/factory/other:rw
/data/factory/tmp:rw
/data/testresults:rw
/data/tests:ro
/data/conf:ro

Also the factory and testresults directories have to be writable by geekotest user in the container

Acceptance criteria

  • AC 1: Ensure factory/testresults directories are created
  • AC 2: Ensure container user has permissions for these directories

Suggestions


Related issues 2 (1 open1 closed)

Related to openQA Project - action #76978: How to run an openQA test in 5 minutes size:MResolvedjbaier_cz2020-11-04

Actions
Related to openQA Project - action #90989: containers: Configurable workdir location in docker-composeWorkable2021-04-12

Actions
Actions #1

Updated by ilausuch about 3 years ago

  • Description updated (diff)
Actions #2

Updated by livdywan about 3 years ago

  • Description updated (diff)
Actions #3

Updated by livdywan about 3 years ago

  • Description updated (diff)

Note:

  • I re-phrased it to not assume that the problem is on the container side. Maybe it is, but let's not prescribe the solution here.
  • I removed the explicit AC for tests since I think it's implied for a bug fix.
Actions #4

Updated by livdywan about 3 years ago

  • Related to action #76978: How to run an openQA test in 5 minutes size:M added
Actions #5

Updated by okurz about 3 years ago

  • Status changed from New to Workable
  • Target version set to future
  • Parent task set to #80142

thanks, looks good. We can consider taking this story onto our backlog as soon as the current task related to automatic tests for the current state are completed unless of course the automatic tests already reproduce the problem visible within this ticket.

Actions #6

Updated by ilausuch about 3 years ago

  • Assignee set to ilausuch
Actions #7

Updated by ilausuch about 3 years ago

  • Status changed from Workable to In Progress
Actions #8

Updated by ilausuch about 3 years ago

Actions #9

Updated by livdywan about 3 years ago

ilausuch wrote:

https://github.com/os-autoinst/openQA/pull/3783
still incomplete because AC3

what AC3?

Actions #10

Updated by okurz about 3 years ago

Please stop working on "future" tickets!

Actions #11

Updated by openqa_review about 3 years ago

  • Due date set to 2021-03-26

Setting due date based on mean cycle time of SUSE QE Tools

Actions #12

Updated by okurz about 3 years ago

  • Due date deleted (2021-03-26)
  • Status changed from In Progress to Workable
  • Assignee deleted (ilausuch)

As discussed in chat. We should focus on the tasks that are in our backlog for now.

Actions #13

Updated by ilausuch about 3 years ago

The directories declaration was fixed on the commit https://github.com/os-autoinst/openQA/commit/8a210eeacf09df21cfe7de632cafcb9c43bcc06e
Also the permissions over these directories.

However I would like to refer to this task #90989

Actions #14

Updated by ilausuch about 3 years ago

  • Related to action #90989: containers: Configurable workdir location in docker-compose added
Actions #15

Updated by livdywan about 3 years ago

ilausuch wrote:

The directories declaration was fixed on the commit https://github.com/os-autoinst/openQA/commit/8a210eeacf09df21cfe7de632cafcb9c43bcc06e
Also the permissions over these directories.

However I would like to refer to this task #90989

So the way I read the commit, I think this ticket is Resolved. And #90989 would probably be an improvement.

Actions #16

Updated by ilausuch about 3 years ago

I agree

Actions #17

Updated by ilausuch about 3 years ago

  • Status changed from Workable to Resolved
Actions

Also available in: Atom PDF