Project

General

Profile

action #89401

[qe-core][clamav] create local mirror for CVD updates auto_review:"console/clamav.pm line 55."

Added by mgrifalconi about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-03-03
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

We have many clamav tests updating database, it would be faster to use our own local mirror.
https://www.clamav.net/documents/private-local-mirrors
I guess it could be setup on osd and ooo.

Fails in multiple SLE versions

openQA test in scenario sle-15-Server-DVD-Updates-x86_64-mau-extratests1@64bit fails in
clamav

Reproducible

Fails since (at least) Build 20210303-1

Expected result

Last good: 20210302-1 (or more recent)

Further details

Always latest result in this scenario: latest

Jozef suggests to setup a local mirror to workaround this issue: https://www.clamav.net/documents/private-local-mirrors

History

#1 Updated by mgrifalconi about 1 year ago

  • Subject changed from test fails in clamav: too many requests to [qe-core][clamav] test fails in clamav: too many requests

#2 Updated by dzedro about 1 year ago

  • Subject changed from [qe-core][clamav] test fails in clamav: too many requests to [qe-core][clamav] create local mirror for CVD updates
  • Description updated (diff)

#3 Updated by mgrifalconi about 1 year ago

  • Subject changed from [qe-core][clamav] create local mirror for CVD updates to [qe-core][clamav] create local mirror for CVD updates auto_review:"console/clamav.pm line 55."

#4 Updated by openqa_review about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-extratests1
https://openqa.suse.de/tests/5689960

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#5 Updated by dzedro about 1 year ago

  • Status changed from New to In Progress
  • Assignee set to dzedro

#6 Updated by dzedro about 1 year ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12189

On osd and o3 is cron updating the database every hour.

#7 Updated by favogt about 1 year ago

This breaks all clamav tests on openqa.opensuse.org:

Reading CVD header (main.cld): WARNING: remote_cvdhead: file not found: http://openqa.opensuse.org/assets/repo/cvd/main.cld
Reading CVD header (main.cvd): WARNING: remote_cvdhead: file not found: http://openqa.opensuse.org/assets/repo/cvd/main.cvd

Probably caused by asset cleanup?

BTW, /usr/bin/cvdupdate doesn't seem to be owned by any package, where is that from?

#8 Updated by dzedro about 1 year ago

o3 assets are not accessible at all, but still the db was cleaned.
cvdupdate is instaled via pip

#9 Updated by favogt about 1 year ago

dzedro wrote:

o3 assets are not accessible at all, but still the db was cleaned.

What do you mean by that?

I had to force a refresh of the database to trigger a redownload, after that it worked fine, at least until the asset cleanup deletes the cvd directory again. This has to be excluded from cleanup to work properly.

cvdupdate is instaled via pip

System wide? If so, that can cause conflicts and will most certainly break on python upgrades.

#10 Updated by dzedro about 1 year ago

I thought I could access assets from o3 one week ago, but maybe it was osd.
You are right, I changed it to cvdupdate user. I tested if all affected python packages are instalable, should be good.

#12 Updated by favogt about 1 year ago

dzedro wrote:

I thought I could access assets from o3 one week ago, but maybe it was osd.

It's essentially random when asset cleanup deletes the database, it might happen at any point in the future again.

You are right, I changed it to cvdupdate user. I tested if all affected python packages are instalable, should be good.

Great!

#13 Updated by dzedro about 1 year ago

I increased frequency of local mirror update, toi toi toi.

#14 Updated by dzedro about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Didn't see clamav failures due to local mirror lately.

#15 Updated by szarate about 1 year ago

  • Target version set to Ready

#16 Updated by szarate about 1 year ago

  • Target version changed from Ready to QE-Core: Ready

#17 Updated by dzedro about 1 year ago

I hope after this PR there will be no fail for very long time ...

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12525

Also available in: Atom PDF