Project

General

Profile

action #88696

Executing /usr/share/openqa/script/openqa-gru fails

Added by SLindoMansilla 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-02-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Verion: openQA-4.6.1613477586.fa28c153e-lp152.3672.1.noarch

# output of /usr/share/openqa/script/openqa-gru 
[2021-02-17 13:07:06.55734] [3763] [warn] Deprecated use of config key '[audit]: blacklist'. Use '[audit]: blocklist' instead
Route pattern "/children/:status" contains a reserved stash value at /usr/share/openqa/script/../lib/OpenQA/WebAPI.pm line 361.
# exit code 30

Related issues

Is duplicate of openQA Project - action #88609: Mojolicious 9.0 compatibilityResolved2021-02-152021-03-02

History

#1 Updated by okurz 5 months ago

  • Status changed from New to Feedback
  • Assignee set to okurz
  • Priority changed from Normal to High
  • Target version set to Ready

this is likely due to an update of perl-Mojolicious-9.0 you installed which is unfortunately incompatible with openQA in the current version. Also see #88609 . I suggest for the time being you can apply the patch from https://github.com/os-autoinst/openQA/pull/3726 manually in your environment or rollback to an earlier version of perl-Mojolicious.

#2 Updated by SLindoMansilla 5 months ago

  • Is duplicate of action #88609: Mojolicious 9.0 compatibility added

#3 Updated by SLindoMansilla 5 months ago

  • Category deleted (Concrete Bugs)
  • Status changed from Feedback to Closed
  • Assignee deleted (okurz)
  • Target version deleted (Ready)

Thanks for the quick answer.

Closing as duplicate

#4 Updated by okurz 5 months ago

  • Category set to Concrete Bugs
  • Status changed from Closed to Feedback
  • Assignee set to okurz
  • Target version set to Ready

Actually I would still like to keep this ticket and investigate how it could be that an update caused this for users. Can you state, do you use Tumbleweed or Leap+devel:openQA:Leap:15.2?

#5 Updated by SLindoMansilla 5 months ago

Leap 15.2 + devel:openQA:Leap:15.2

# zypper se -sx "perl-Mojolicious"

S | Name             | Type       | Version          | Arch   | Repository
--+------------------+------------+------------------+--------+--------------------------
i | perl-Mojolicious | package    | 9.01-lp152.350.1 | noarch | devel-openQA-perl-modules
v | perl-Mojolicious | package    | 8.42-lp152.1.1   | noarch | Main Repository (OSS)
  | perl-Mojolicious | srcpackage | 9.01-lp152.350.1 | noarch | devel-openQA-perl-modules

#6 Updated by okurz 5 months ago

thanks. Hm, ok. That's the limitattion of using development repositories. I assume that with openSUSE Tumbleweed this problem would not exist as updates are only shipped in a synchronous way and our tests for Tumbleweed also cover openQA. For Leap the repo devel:openQA:Leap:15.2 receives an update for a dependency as soon as it's linked source is accepted into openSUSE:Factory regardless if it breaks something else. I guess the least we can do is document that.

#7 Updated by mkittler 5 months ago

We're linking perl-Mojolicious from DLP but it would make more sense to link it from Factory. We should adjust the link when 9.01 lands in Factory.

#8 Updated by okurz 5 months ago

  • Status changed from Feedback to Blocked

agreed. Maybe we did that at some point in time as workaround. Waiting for https://build.opensuse.org/request/show/873064

#9 Updated by kraih 5 months ago

perl-Mojolicious 9.01 is now in factory.

#10 Updated by mkittler 5 months ago

  • Status changed from Blocked to Resolved

I've been updating the link within our Leap repos to point to openSUSE:Factory. (The link in the SLE15 repo already pointed to that.)

#11 Updated by SLindoMansilla 5 months ago

Confirmed, it works!
Thanks :)

#12 Updated by okurz 5 months ago

Thanks guys, you are awesome! With the fixed package link we have the additional fix so the ticket was not just a duplicate :)

Also available in: Atom PDF