Project

General

Profile

action #76741

help popup next to "Submit comment" does not work anymore

Added by okurz 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-10-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

On any job details page on the tab "Comments", when logged in, below the comment text entry field, next to "Submit comment" there is a little icon with a question mark which should show some help but neither hover nor clicking seems to work at least on o3, e.g. on https://openqa.opensuse.org/tests/1452348#comments
I tried with different browsers on two different computers

Steps to reproduce

  • On any openQA instance when logged in
  • On any test details page
  • Go to comments tab
  • Find blue question mark icon and hover over the icon and/or click on it
  • TBC Observe that there is no popup

Expected result

Popup with help text should be shown

History

#1 Updated by Xiaojing_liu 9 months ago

when the javascript function setupForAll in openqa.js is called to add events to help popup, this help popup does not exist. The comments page is loaded by using data-src="<%= url_for('test_comments', testid => $testid).
I only find one solution: load the add_comment_form_groups.html.ep first, the comments can be got using ajax when clicking the tab.
Can we init this help popup after loading the whole comment page (do not need to change the template code)? I do not know how to do that.

#2 Updated by mkittler 9 months ago

  • Assignee set to mkittler

#3 Updated by mkittler 9 months ago

  • Status changed from Workable to In Progress

Can we init this help popup after loading the whole comment page (do not need to change the template code)?

Yes, see my PR: https://github.com/os-autoinst/openQA/pull/3494

#4 Updated by cdywan 9 months ago

  • Status changed from In Progress to Feedback

#5 Updated by mkittler 9 months ago

  • Status changed from Feedback to Resolved

#6 Updated by okurz 9 months ago

  • Status changed from Resolved to Feedback

happy to see this fixed fast but: We should ensure this actually works in production or have a proper test which ensures this, see https://progress.opensuse.org/projects/qa/wiki/Wiki#Definition-of-DONE
Seems like we have neither so far. Care to add a test?

#7 Updated by mkittler 9 months ago

Wait, at some point you've said we don't necessarily have to wait with resolving tickets until the change has been deployed. I did of course a local, manual test and for a change like this it is fair to assume that there will be no difference in production.

Care to add a test?

PR: https://github.com/os-autoinst/openQA/pull/3498

#8 Updated by okurz 9 months ago

  • Status changed from Feedback to Resolved

I hope what I am saying is also aligned with what we have written down as definition of DONE :)

Yes, "we don't necessarily have to wait" for deployment but the issue had been seen in production so in these cases I think it makes more sense to wait, especially if there aren't tests added. But as said PR is merged by now we can also resolved. For any weird reason this might still fail in production though. For example waiting for the daily deployment on i3 you could have realized it's actually not broken since 12 days :D don't worry, covered in another ticket, possibly broken by me.

I think it's good practice to not only try to address the problem at hand in a ticket but also ask ourselves how it could have come to the situation that something like this breaks and we did not know. It was actually a little bit embarrassing as I was showing some openQA features to someone and wanted to show him on my shared screen that all he needs is available in the help popup ... but it did not popup :D

Also available in: Atom PDF