Project

General

Profile

action #72289

web-ui - test display is incomplete

Added by ph03nix 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-10-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

On http://openqa.qam.suse.cz/ the job display shows a incomplete listing of the Job Details - e.g. http://openqa.qam.suse.cz/tests/13129

Here the whole virtualization/universal folder and it's tests is missing. In the javascript console of the website we find the following error:

Uncaught TypeError: template is null
    renderTemplate http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:5
    renderModuleRow http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:16
    renderModuleTable http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:25
    renderTestModules http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:99
    success http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:81
    fire http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:232
    fireWith http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:238
    done http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:656
    callback http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:669

Older runs which we know that worked have now the same issue.

History

#1 Updated by ph03nix 10 months ago

Additional info:

System running openSUSE Leap 15.2 and I run a full system update+reboot today at lunchtime.

#2 Updated by mkittler 10 months ago

  • Status changed from New to In Progress
  • Assignee set to mkittler

I'll have a look. (Shouldn't be hard to fix.)

#3 Updated by okurz 10 months ago

  • Target version set to Ready

good and thank you.

ph03nix for the future please be aware that we have ticket templates that can help to provide all the necessary information and make it easier for any assignee to start: https://progress.opensuse.org/projects/openqav3/wiki#Defects . If you like you can also adjust the current ticket accordingly.

#4 Updated by ph03nix 10 months ago

Observation

On http://openqa.qam.suse.cz/ the job display shows a incomplete listing of the Job Details - e.g. http://openqa.qam.suse.cz/tests/13129

Here the whole virtualization/universal folder and it's tests is missing. In the javascript console of the website we find the following error:

Uncaught TypeError: template is null
    renderTemplate http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:5
    renderModuleRow http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:16
    renderModuleTable http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:25
    renderTestModules http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:99
    success http://openqa.qam.suse.cz/asset/0ab2d08e0e/test_result.js:81
    fire http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:232
    fireWith http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:238
    done http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:656
    callback http://openqa.qam.suse.cz/asset/7f7a677106/bootstrap.js:669

Older runs which we know that worked have now the same issue.

Steps to reproduce

Problem

Display of job test runs is incomplete, Screenshots and test results are inaccessible

Suggestion

Requesting assistance to fix the javascript error.

Workaround

Switching from plain to openSUSE branding solved the issue on our instance

/etc/openqa/openqa.ini
## type of branding - [ openSUSE, plain, openqa.suse.de ]
branding = openSUSE

Redmine peculiarities

I fail to find a way to update the original Issue description. There seems to be a way (https://www.redmine.org/projects/redmine/wiki/RedmineIssues#Editing-an-existing-issue) but I can't find it here.

#5 Updated by mkittler 10 months ago

PR: https://github.com/os-autoinst/openQA/pull/3448

This PR fixes the rendering in case some templates are not available. Note that on your instance the template for external reporting (part of the branding, e.g. templates/webapi/branding/openSUSE/external_reporting.html.ep) seems to be broken/disabled. That's also why the bug reporting links on the image previews are not available. So as a workaround I suggest fixing your branding.


It is possible to edit the initial ticket description on progress (see https://www.redmine.org/projects/redmine/wiki/RedmineIssues#Editing-an-existing-issues-Subject-or-Description). If the edit button besides the "Description" label is not present you likely just don't have the permission.

#6 Updated by ph03nix 10 months ago

Thanks Marius. We are using plain branding since ever:

/etc/openqa/openqa.ini
## type of branding - [ openSUSE, plain, openqa.suse.de ]
branding = plain

I can solve the issue by switching to openSUSE branding. Switching back to plain branding makes the issue reappear.

With that we have a viable workaround. Thanks Marius, your quick help is much appreciated +1

#7 Updated by mkittler 10 months ago

I've tested with the plain branding locally and yes, then the issue is easily reproducible. This way I could also confirm that my PR will fix the concrete issue.

#8 Updated by mkittler 10 months ago

  • Status changed from In Progress to Resolved

The PR has been merged.

Also available in: Atom PDF