Project

General

Profile

action #71026

[y] Validate updated package version with self_update

Added by ybonatakis about 1 year ago. Updated 1 day ago.

Status:
New
Priority:
Low
Assignee:
-
Target version:
Start date:
2020-09-07
Due date:
% Done:

0%

Estimated time:

Description

With the work on https://bugzilla.suse.com/show_bug.cgi?id=1175614 done, we can check what version the self update download and use in the inst-sys. Rodion has already created validation module tests/installation/validate_self_update.pm checking that the feature attempts to download some packages from the update repo but it does not check/compare the package version between the default inst-sys and the update repo. The inst-sys stores the package version in /.packages.root. With yast2-installation-4.3.16 and above we should find /.packages.self_update file which we can use to compare

packages.self_update.png (15.4 KB) packages.self_update.png ybonatakis, 2020-09-29 16:31
10522

History

#1 Updated by ybonatakis about 1 year ago

  • Subject changed from [y] Validate updated packages with self_update to [y] Validate updated package version with self_update

#2 Updated by riafarov about 1 year ago

  • Category set to Enhancement to existing tests
  • Target version set to future

#4 Updated by riafarov about 1 year ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Enhancement to existing tests)

#5 Updated by okurz 2 days ago

This ticket was set to "Normal" priority but was not updated within the SLO period for "Normal" tickets (365 days) as described on https://progress.opensuse.org/projects/openqatests/wiki/Wiki#SLOs-service-level-objectives

first reminder: Please consider picking up this ticket within the next 365 days or just set the ticket to the next lower priority of "Low" (no SLO related time period).

#6 Updated by ybonatakis 1 day ago

  • Priority changed from Normal to Low

lets make is Low as the yast team is focusing in other things atm

Also available in: Atom PDF