Project

General

Profile

action #69142

coordination #66394: [epic][y] Enable VNC+SSH Installations on aarch64

[y] Adjust bootloader for MM on aarch64

Added by ybonatakis about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-07-20
Due date:
2020-08-11
% Done:

0%

Estimated time:
5.00 h

Description

Observation

aarch64 uses uefi in the bootloader.
The bootloader for the MM tests are not setup properly the parameters as you can see for instance on remote_ssh_target_ftp in bootloader_start

the bootloader for the x86_64 loads parameters as you can find in https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/installation/bootloader.pm#L59. basically ssh and ssh.password. Other parameters might are required based on the media. for example, Online installation, might need dns.

bootloader_start uses the correct bootloader as now.

We are missing at least following boot params:
nameserver= ssh=1 sshpassword=nots3cr3t for ssh
nameserver= vnc=1 vncpassword=nots3cr3t for vnc

So we need to make sure those are added to uefi bootloader.

Don't hesitate to contact Anton Smorodsky in case you need support with MM tests on arm.

Acceptance Criteria

  • uefi bootloader passes the required parameters for networking(ssh, vnc, etc)

History

#1 Updated by riafarov about 1 year ago

  • Due date set to 2020-08-11
  • Category set to Bugs in existing tests
  • Target version set to SLE 15 SP3

#2 Updated by riafarov about 1 year ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

MM on arm test example we have: https://openqa.suse.de/tests/4341473

It boots in the image and not the installer itself.

Ask Ioannis for support server image name (see https://progress.opensuse.org/issues/68708)

#3 Updated by ybonatakis about 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to ybonatakis

#5 Updated by ybonatakis about 1 year ago

  • Status changed from In Progress to Feedback

in parallel with the fixing of the parameters not presented in the bootloader we encounter another problem with the network which the target machine could not 'see' out to the world. this was because of the iptables rules which were applied to the supportserver. I tried a few things that worked but i could not tested properly as a full autonomous MM test.
What i did was to stop the target and then connect to the controller and apply some firewall rules. The solution i present is to clean up all the rules before the configuration so the incoming connection would not be blocked.

#6 Updated by riafarov about 1 year ago

  • Status changed from Feedback to Resolved

We will continue in #66394

Also available in: Atom PDF