Project

General

Profile

Actions

action #67123

closed

coordination #88960: Design test plan for the yast2 samba module

Move yast2_samba from dev group to prod

Added by JRivrain about 4 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Target version:
-
Start date:
2020-05-21
Due date:
% Done:

0%

Estimated time:
Tags:

Description

After research in #88966 we can assume that the setup makes sense, just need more sysadmin actions by command line to create users (which is out of scope for us) so we could proceed with:

  • Move test scenario from dev group to prod and label with the bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1177302
  • Contact samba team (through William Brown possible better) about the services 'smb' and 'nmb' not restarting after applying changes (perhaps try to reproduce it manually again, the first try in a VM,services were up and running) only in openQA. We could verify if there is high load or something else in the openqa environment.
  • Optionally we could add some smoke test, but the three components which involve linux, ldap and samba account need to be configured properly to be seen as one, so to keep us in the scope of testing YaST component we could simplify it to see that something is written in ldap configuration, for example check this branch where was modified in the UI 'synchronization of password: "no" to avoid to configure properly those components and still see something written in ldap.

Related issues 2 (0 open2 closed)

Related to qe-yam - action #66871: [funcional][y] Re-enable samba test module in yast2-ncurses suiteRejected2020-05-14

Actions
Related to qe-yam - action #67363: [functional][y] Remove or adapt workaround for yast2-samba ncurses testRejected2020-05-27

Actions
Actions #1

Updated by JRivrain about 4 years ago

  • Related to action #66871: [funcional][y] Re-enable samba test module in yast2-ncurses suite added
Actions #2

Updated by JRivrain about 4 years ago

  • Description updated (diff)
Actions #3

Updated by riafarov about 4 years ago

  • Status changed from New to Rejected
  • Assignee set to riafarov

I guess we can reject this one and continue with our plan described in #67363. Please, reopen in case I miss something.

Actions #4

Updated by JRivrain about 4 years ago

  • Status changed from Rejected to New

riafarov wrote:

I guess we can reject this one and continue with our plan described in #67363. Please, reopen in case I miss something.

Hi, I guess you missed something, this is not the related to the workaround in #67363, it's something else : the code in the library yast2_widget_utils somehow stopped working, so we should try to see why.

Actions #5

Updated by riafarov about 4 years ago

  • Due date set to 2020-06-16
  • Assignee deleted (riafarov)
  • Target version set to SLE 15 SP2

JRivrain wrote:

riafarov wrote:

I guess we can reject this one and continue with our plan described in #67363. Please, reopen in case I miss something.

Hi, I guess you missed something, this is not the related to the workaround in #67363, it's something else : the code in the library yast2_widget_utils somehow stopped working, so we should try to see why.

So which one should we address first then? We have now 3 tickets and it's quite confusing what should follow what, as we haven't disable test module yet.

Actions #6

Updated by riafarov about 4 years ago

  • Due date changed from 2020-06-16 to 2020-06-30
Actions #7

Updated by riafarov about 4 years ago

  • Due date changed from 2020-06-30 to 2020-07-14
Actions #8

Updated by JRivrain almost 4 years ago

  • Related to action #67363: [functional][y] Remove or adapt workaround for yast2-samba ncurses test added
Actions #9

Updated by JRivrain almost 4 years ago

  • Description updated (diff)
Actions #10

Updated by riafarov almost 4 years ago

  • Due date deleted (2020-07-14)
  • Status changed from New to Blocked
  • Assignee set to riafarov
  • Target version changed from SLE 15 SP2 to SLE 15 SP3

We are running test in dev job group to see when patch arrives, after that we can act on this item.

Actions #11

Updated by JRivrain almost 4 years ago

  • Description updated (diff)
Actions #12

Updated by JRivrain almost 4 years ago

  • Description updated (diff)
Actions #13

Updated by riafarov almost 4 years ago

  • Due date set to 2020-10-06
  • Status changed from Blocked to New
  • Assignee deleted (riafarov)
  • Priority changed from High to Normal

Decreasing priority as reported issues do not get much attention, which decreases value of the test. But we can fix it in order to still maintain some coverage.

Actions #14

Updated by riafarov over 3 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h
Actions #15

Updated by riafarov over 3 years ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (Bugs in existing tests)
Actions #16

Updated by JERiveraMoya over 3 years ago

  • Status changed from Workable to Blocked
  • Assignee set to JERiveraMoya

Fixed multiple needles (included the ones for changing service status), settings updated in O3 for this test suite running in development group.
Test was pointing to personal branch and needles where not create in O3 even it looked like so because there was a needle dir set to something, which was really strange.

Current run fails when closing the module due to the ret code is not 0. Filed bug: boo#1177302

Actions #17

Updated by JRivrain over 3 years ago

boo#1177302 may be a duplicate of boo#1172084 ?
This ticket was filed long time ago, the description may not really stick to how it is currently.

Actions #18

Updated by riafarov over 3 years ago

  • Due date deleted (2020-10-06)
Actions #19

Updated by JERiveraMoya about 3 years ago

  • Subject changed from [functional][y]test fails in yast2_samba to Move yast2_samba from dev group to prod
  • Description updated (diff)
  • Status changed from Blocked to New
  • Assignee deleted (JERiveraMoya)
Actions #20

Updated by JERiveraMoya about 3 years ago

  • Estimated time deleted (5.00 h)
Actions #21

Updated by JERiveraMoya about 3 years ago

As discussed, we should start first by #92209.

Actions #22

Updated by riafarov about 3 years ago

  • Parent task set to #88960
Actions #23

Updated by oorlov about 3 years ago

  • Target version changed from SLE 15 SP3 to Current
Actions #24

Updated by JERiveraMoya almost 2 years ago

  • Tags set to YaST
  • Priority changed from Normal to Low

We got some info from mailing list a lot of time ago.
We will re-evaluate this in the future.

Actions #25

Updated by JERiveraMoya over 1 year ago

  • Target version changed from Current to future
Actions #26

Updated by JERiveraMoya over 1 year ago

  • Target version deleted (future)
Actions #27

Updated by JERiveraMoya 4 months ago

too old ticket, we already have some extra test coverage in migrations regarding ldap and other exotic things. Rejecting.

Actions #28

Updated by JERiveraMoya 4 months ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF