Project

General

Profile

action #63892

[functional][u][sporadic] test fails in firefox - help-menu does not show up on openQA when pressing 'alt-h'

Added by dimstar 5 months ago. Updated 1 day ago.

Status:
In Progress
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 30
Start date:
2020-02-27
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-GNOME-Live-x86_64-gnome-live@64bit fails in
firefox

The help-menu does not show up on openQA when pressing 'alt-h'
This is uniquely happening on the GNOME Live image tests; all other GNOME tests have no issue with the FF test. Also, when running the live image in a VM, I seemed not able to reproduce it (which is why I file it here - seems rather a QA specific thing than a product bug)

Suggestions

  • Firefox behaves different regarding modifier keys and menu bar. You should first press alt alone and the menu bar will be shown. Then H key can be pressed alone to open the help menu.
send_key "alt"; # shows menu bar
assert_and_click('firefox-help-menu-item');
assert_screen 'firefox-help-menu';

Reproducible

Fails since (at least) Build 20200225

Expected result

Last good: 20200224 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz 5 months ago

  • Subject changed from test fails in firefox to [functional][u][qam] test fails in firefox - help-menu does not show up on openQA when pressing 'alt-h'

#2 Updated by SLindoMansilla 5 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 30
  • Estimated time set to 42.00 h

#3 Updated by zluo 4 months ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over

#5 Updated by zluo 4 months ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10001 created.

will remove EXCLUDE_MODULES for gnome-live after merge.

#6 Updated by dimstar 4 months ago

zluo wrote:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10001 created.

will remove EXCLUDE_MODULES for gnome-live after merge.

Seems that was done BEFORE the merge though

#7 Updated by zluo 4 months ago

dimstar wrote:

zluo wrote:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10001 created.

will remove EXCLUDE_MODULES for gnome-live after merge.

Seems that was done BEFORE the merge though

yes, that was an accident, corrected now.

#8 Updated by zluo 4 months ago

  • Status changed from In Progress to Resolved

#9 Updated by dimstar 3 months ago

  • Status changed from Resolved to Workable

#10 Updated by zluo 3 months ago

  • Status changed from Workable to Resolved

are you sure about this?

https://openqa.opensuse.org/tests/overview?distri=opensuse&version=3.36.2&build=13.197&groupid=35

shows all gnome tests failed without exceptions! And they've been added to test suite and never worked before.
Please check and open a new ticket or fix this for O3, thanks!

And please see https://openqa.opensuse.org/tests/1248784#next_previous. this is normal if 1 failed and current still working.
Please don't mix different issues.

#11 Updated by dimstar 3 months ago

  • Status changed from Resolved to In Progress

And why do you focus ONLY on the gnome-next test?

I clearly also linked a TW test run:
https://openqa.opensuse.org/tests/1248784#step/firefox/10

This test is still not reliably opening the help menu.

#12 Updated by zluo 3 months ago

dimstar wrote:

And why do you focus ONLY on the gnome-next test?

I clearly also linked a TW test run:
https://openqa.opensuse.org/tests/1248784#step/firefox/10

I checked this as well and the latest test run just passed as I mentioned above. So let keep an eye on it. Re-open this ticket if this happens more than 2 time.

This test is still not reliably opening the help menu.

[2020-04-29T11:39:09.234 CEST] [debug] starting: /usr/bin/qemu-system-x86_64 -only-migratable -chardev ringbuf,id=serial0,logfile=serial0,logappend=on -serial chardev:serial0 -soundhw hda -global isa-fdc.driveA= -m 2048 -cpu qemu64 -netdev user,id=qanet0 -device virtio-net,netdev=qanet0,mac=52:54:00:12:34:56 -boot once=d -device usb-ehci -device usb-tablet -smp 1 -enable-kvm -no-shutdown -vnc :104,share=force-shared -device virtio-serial -chardev pipe,id=virtio_console,path=virtio_console,logfile=virtio_console.log,logappend=on -device virtconsole,chardev=virtio_console,name=org.openqa.console.virtio_console -chardev socket,path=qmp_socket,server,nowait,id=qmp_socket,logfile=qmp_socket.log,logappend=on -qmp chardev:qmp_socket -S -device virtio-scsi-pci,id=scsi0 -blockdev driver=file,node-name=hd0-file,filename=/var/lib/openqa/pool/14/raid/hd0,cache.no-flush=on -blockdev driver=qcow2,node-name=hd0,file=hd0-file,cache.no-flush=on -device virtio-blk,id=hd0-device,drive=hd0,serial=hd0 -blockdev driver=file,node-name=cd0-overlay0-file,filename=/var/lib/openqa/pool/14/raid/cd0-overlay0,cache.no-flush=on -blockdev driver=qcow2,node-name=cd0-overlay0,file=cd0-overlay0-file,cache.no-flush=on -device scsi-cd,id=cd0-device,drive=cd0-overlay0,serial=cd0

'-smp 1' means a single vcore is used. I really want to recommand to try with QEMUCPUS=2 in setting.

#13 Updated by zluo 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (zluo)

#14 Updated by dimstar 3 months ago

Fine - I'll add links to every occurrence that happens; I'd not have reopened it if this would have seen a single time.

#16 Updated by okurz 3 months ago

  • Priority changed from Normal to High

#17 Updated by SLindoMansilla 3 months ago

  • Assignee set to SLindoMansilla

#18 Updated by SLindoMansilla 3 months ago

  • Subject changed from [functional][u][qam] test fails in firefox - help-menu does not show up on openQA when pressing 'alt-h' to [functional][u][sporadic] test fails in firefox - help-menu does not show up on openQA when pressing 'alt-h'

#23 Updated by okurz about 1 month ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: kde-live-wayland@64bit_virtio-3G
https://openqa.opensuse.org/tests/1316794

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#24 Updated by okurz 24 days ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: kde-live-wayland@64bit_virtio-3G
https://openqa.opensuse.org/tests/1331416

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#25 Updated by szarate 24 days ago

  • Status changed from In Progress to Workable
  • Assignee deleted (szarate)

#26 Updated by zluo 24 days ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

let me check this now

#27 Updated by zluo 21 days ago

the problem is now to close the windows by send_key alt+f4.
PR created now:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10704

it needs some verifications:
https://openqa.opensuse.org/tests/1334211

#28 Updated by okurz 6 days ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: kde-live-wayland@64bit_virtio-3G
https://openqa.opensuse.org/tests/1347512

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#29 Updated by zluo 3 days ago

let check this why it still failed.

#30 Updated by zluo 2 days ago

https://openqa.opensuse.org/tests/1350774/file/firefox-dmesg.log shows call trace:

[ 2428.092043] Call Trace:
[ 2428.092073]  __schedule+0x1f6/0x560
[ 2428.092087]  ? schedule+0x4a/0xb0
[ 2428.092088]  ? io_schedule+0x41/0x70
[ 2428.092092]  ? wait_on_page_bit_common+0xfe/0x320
[ 2428.092093]  ? trace_event_raw_event_file_check_and_advance_wb_err+0xf0/0xf0
[ 2428.092095]  ? filemap_fault+0x42d/0x7a0
[ 2428.092097]  ? ext4_filemap_fault+0x2d/0x3f
[ 2428.092099]  ? __do_fault+0x36/0xd0
[ 2428.092100]  ? do_fault+0x92/0x1c0
[ 2428.092101]  ? __handle_mm_fault+0x5bc/0x780
[ 2428.092103]  ? handle_mm_fault+0xc0/0x1e0
[ 2428.092106]  ? do_user_addr_fault+0x1f9/0x490
[ 2428.092110]  ? async_page_fault+0x3e/0x50
[ 2428.092115] libinput-connec D    0  5490   5479 0x00000000
[ 2428.092116] Call Trace:
[ 2428.092118]  __schedule+0x1f6/0x560
[ 2428.092120]  ? schedule+0x4a/0xb0
[ 2428.092121]  ? io_schedule+0x41/0x70
[ 2428.092122]  ? wait_on_page_bit_common+0xfe/0x320
[ 2428.092124]  ? trace_event_raw_event_file_check_and_advance_wb_err+0xf0/0xf0
[ 2428.092125]  ? filemap_fault+0x42d/0x7a0
[ 2428.092126]  ? ext4_filemap_fault+0x2d/0x3f
[ 2428.092127]  ? __do_fault+0x36/0xd0
[ 2428.092128]  ? do_fault+0x92/0x1c0
[ 2428.092129]  ? __handle_mm_fault+0x5bc/0x780
[ 2428.092131]  ? handle_mm_fault+0xc0/0x1e0
[ 2428.092132]  ? do_user_addr_fault+0x1f9/0x490
[ 2428.092133]  ? async_page_fault+0x3e/0x50
[ 2428.092141] Xwayland        D    0  5491   5487 0x00000004
[ 2428.092142] Call Trace:
[ 2428.092144]  __schedule+0x1f6/0x560
[ 2428.092146]  ? schedule+0x4a/0xb0
[ 2428.092147]  ? io_schedule+0x41/0x70
[ 2428.092148]  ? wait_on_page_bit_common+0xfe/0x320
[ 2428.092149]  ? trace_event_raw_event_file_check_and_advance_wb_err+0xf0/0xf0
[ 2428.092150]  ? filemap_fault+0x42d/0x7a0
[ 2428.092152]  ? ext4_filemap_fault+0x2d/0x3f
[ 2428.092152]  ? __do_fault+0x36/0xd0
[ 2428.092153]  ? do_fault+0x92/0x1c0
[ 2428.092155]  ? __handle_mm_fault+0x5bc/0x780
[ 2428.092156]  ? handle_mm_fault+0xc0/0x1e0
[ 2428.092157]  ? do_user_addr_fault+0x1f9/0x490
[ 2428.092159]  ? async_page_fault+0x3e/0x50
[ 2428.092350] Privileged Cont D    0  5996   5895 0x00000100
[ 2428.092351] Call Trace:
[ 2428.092353]  __schedule+0x1f6/0x560
[ 2428.092354]  ? schedule+0x4a/0xb0
[ 2428.092355]  ? io_schedule+0x41/0x70
[ 2428.092356]  ? wait_on_page_bit_common+0xfe/0x320
[ 2428.092358]  ? trace_event_raw_event_file_check_and_advance_wb_err+0xf0/0xf0
[ 2428.092359]  ? filemap_fault+0x42d/0x7a0
[ 2428.092360]  ? ext4_filemap_fault+0x2d/0x3f
[ 2428.092361]  ? __do_fault+0x36/0xd0
[ 2428.092362]  ? do_fault+0x92/0x1c0
[ 2428.092363]  ? __handle_mm_fault+0x5bc/0x780
[ 2428.092365]  ? handle_mm_fault+0xc0/0x1e0
[ 2428.092366]  ? do_user_addr_fault+0x1f9/0x490
[ 2428.092367]  ? async_page_fault+0x3e/0x50

I can reproduce this issue:
http://10.162.23.47/tests/7933#step/firefox/20 :

firefox is not responding

I can work around by:

    send_key_until_needlematch('test-firefox-3',    'a',     9, 6);

    # close About
    send_key "alt-f4";
    assert_screen 'firefox-html-test';

but later sendkey "alt-f4" doesn't work any more because of "Not responding".

#32 Updated by szarate 1 day ago

zluo wrote:

filed:

https://bugzilla.opensuse.org/show_bug.cgi?id=1174857

It is also possible that the scenario has other problems: ssh is segfaulting, but there are no coredumps apparently

[ 1077.192158] sshd[4712]: segfault at 0000556116416543 278 ip sp 00007ffdfe662a90 error 4 in sshd[5561163d4000+74000]
[ 1077.192164] Code: 1f 84 00 00 00 00 00 48 85 ff 0f 84 d7 00 00 00 41 54 55 48 89 fd 48 83 ec 08 48 8b 87 20 01 00 00 48 85 c0 0f 84 95 00 00 00 <8b> 40 18 a8 02 75 46 a8 04 0f 85 8e 00 00 00 48 8b 7d 08 e8 15 f0
[ 1077.617196] sshd[4746]: segfault at 148 ip 000055e449750543 sp 00007ffe983be0f0 error 4 in sshd[55e44970e000+74000]
[ 1077.617204] Code: 1f 84 00 00 00 00 00 48 85 ff 0f 84 d7 00 00 00 41 54 55 48 89 fd 48 83 ec 08 48 8b 87 20 01 00 00 48 85 c0 0f 84 95 00 00 00 <8b> 40 18 a8 02 75 46 a8 04 0f 85 8e 00 00 00 48 8b 7d 08 e8 15 f0

Also available in: Atom PDF