Project

General

Profile

action #60713

left-over files in /var/lib/openqa/share/factory/tmp

Added by okurz 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2019-11-04
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

From OSD:

/assets/factory/tmp # ls -ltra *
-rw------- 1 geekotest nogroup 2000319 Oct 23 08:29 mojo.tmp.NwbPYVOkGUueddDm
-rw------- 1 geekotest nogroup  849467 Nov  5 14:55 mojo.tmp.yf0Z01V1GAjfH2If
-rw------- 1 geekotest nogroup 1179039 Nov  5 14:56 mojo.tmp.3nZWHS1WOoAgccvl
-rw------- 1 geekotest nogroup  564682 Nov  5 14:56 mojo.tmp.fclMc36mKaAWHdqb
-rw------- 1 geekotest nogroup 2000333 Nov  5 14:56 mojo.tmp.toTxw_c0LbSg8uY8
-rw------- 1 geekotest nogroup 2000365 Nov  5 14:56 mojo.tmp.Pd4JkUrgnEEB4Y_d
-rw------- 1 geekotest nogroup 2000332 Nov  5 14:56 mojo.tmp.6eRD_838khmvXaKK
-rw------- 1 geekotest nogroup 2000370 Nov  5 14:56 mojo.tmp.fNbMb4G7y4iG9l8J
-rw------- 1 geekotest nogroup  463037 Nov  6 07:21 mojo.tmp.Cv0kAJOP1MGUtCDp
-rw------- 1 geekotest nogroup  699476 Nov  6 12:26 mojo.tmp.afq1aRcNwjvjJJWU
-rw------- 1 geekotest nogroup  437577 Nov  6 12:26 mojo.tmp.ze2oi6UoIygzMMfS
-rw------- 1 geekotest nogroup 2000332 Nov  6 12:26 mojo.tmp.kPW38JWWK8uvIvxq
-rw------- 1 geekotest nogroup  488612 Nov  6 15:26 mojo.tmp.bKAEJJBIv84liCtQ
-rw------- 1 geekotest nogroup  544910 Nov  6 15:26 mojo.tmp.SuD6DNlyGO3VqL3p
-rw------- 1 geekotest nogroup 2000308 Nov  6 15:26 mojo.tmp.mMPTidlbBVCkO6Re
-rw------- 1 geekotest nogroup 2000329 Nov  6 15:26 mojo.tmp.XK_3hfcJ0laDcTJG
-rw------- 1 geekotest nogroup 2000326 Nov  6 15:26 mojo.tmp.H5KNE6KSMPimDX0i
-rw------- 1 geekotest nogroup 2000310 Nov  6 15:26 mojo.tmp.Jk1IoZkteFqh85Ku
-rw------- 1 geekotest nogroup 2000330 Nov  6 15:26 mojo.tmp.pOfKXmLahjZB4daj
-rw------- 1 geekotest nogroup  392531 Nov  6 15:26 mojo.tmp.qSN_Wn6e4RNQ6SPy
-rw------- 1 geekotest nogroup 2000317 Nov  6 15:26 mojo.tmp.nO30MAhLx8vGgDp2
-rw------- 1 geekotest nogroup  411556 Nov  6 15:26 mojo.tmp.eJMtJp_YBZ9xwuX6

private:
total 4
drwxr-xr-x 2 geekotest nogroup   10 Dec  3 22:12 .
drwxrwxr-x 4 geekotest root    4096 Dec  5 10:02 ..

public:
total 8
drwxr-xr-x 2 geekotest nogroup   71 Nov  1 14:05 SLES-15-SP2-aarch64-Build77.1@aarch64-gnome.qcow2.CHUNKS
drwxr-xr-x 2 geekotest nogroup   90 Nov  6 11:32 SLES-15-SP2-aarch64-77.1@aarch64-minimal_with_sdk77.1_xfstests.qcow2.CHUNKS
drwxr-xr-x 2 geekotest nogroup   68 Nov  6 12:27 sle-15-SP2-aarch64-80.5-textmode@aarch64.qcow2.CHUNKS
drwxr-xr-x 2 geekotest nogroup   78 Nov  6 12:29 sle-15-SP2-aarch64-80.5-textmode@aarch64-multipath.qcow2.CHUNKS
drwxr-xr-x 2 geekotest nogroup   68 Dec  2 17:36 SLES-15-SP2-aarch64-99.1@aarch64-pcm_aws.qcow2.CHUNKS
drwxr-xr-x 7 geekotest nogroup 4096 Dec  5 10:00 .
drwxrwxr-x 4 geekotest root    4096 Dec  5 10:02 ..

Accounting to 2.8G currently. I assume we can consider this a regression as we do not have older files than Oct 23 and I doubt there is any regular cleanup of this directory.

Problem

Without cleanup we might run out of space eventually.

This seems to be related to recent work by kraih.


Related issues

Copied from openQA Project - action #59008: 900GB of assets not tracked ('other' assets?)Resolved2019-11-04

History

#1 Updated by okurz 7 months ago

  • Copied from action #59008: 900GB of assets not tracked ('other' assets?) added

#2 Updated by coolo 7 months ago

I remove these files regularly

#3 Updated by okurz 7 months ago

oh, good to know. still, as openQA kinda owns this directory, shouldn't it take care of cleanup? Or should we solve it with salt for our managed instance only?

#4 Updated by okurz 7 months ago

kraih do you have an idea how to make this ticket "workable"?

#5 Updated by kraih 7 months ago

Afraid this is unrelated to my work. Mine was /var/lib/openqa/cache/tmp on the workers. Didn't someone else recently work on the cleanup gru tasks?

#6 Updated by coolo 7 months ago

  • Status changed from New to Workable
  • Target version set to Ready

man tmpfiles.d

#7 Updated by okurz 7 months ago

  • Status changed from Workable to Feedback
  • Assignee set to okurz
  • Target version changed from Ready to Current Sprint

#8 Updated by okurz 7 months ago

  • Status changed from Feedback to Workable
  • Assignee deleted (okurz)
  • Target version changed from Current Sprint to Ready

MR merged for osd at least. coolo suggest to handle this in the openQA package as "every instance has this problem". Problem is though that the (openSUSE/SLE) package would not cover "all instances".

#9 Updated by mkittler 6 months ago

  • Assignee set to mkittler

Having it in the package would still be already better. And to add it to the package we would extend the install target of the Makefile, right? So all users would benefit after all (at least those using the Makefile install target).

#10 Updated by mkittler 6 months ago

  • Status changed from Workable to In Progress

#11 Updated by cdywan 5 months ago

  • Status changed from In Progress to Resolved
  • Target version changed from Ready to Current Sprint

Also available in: Atom PDF