Project

General

Profile

action #60115

[sle][functional][u] test fails in sshd - login prompt doesn't show up on serial_terminal

Added by zluo almost 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
High
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 31
Start date:
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

I checked the logs:

[2019-11-20T18:22:01.776 CET] [debug] >>> testapi::wait_serial: (?:i2PcM-\d+-): ok
[2019-11-20T18:22:01.777 CET] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/sshd.pm:66 called opensusebasetest::select_serial_terminal
[2019-11-20T18:22:01.777 CET] [debug] <<< testapi::select_console(testapi_console='root-sut-serial')
[2019-11-20T18:22:01.778 CET] [debug] Activate console on libvirt_domain:openQA-SUT-1 devname:console port:1
[2019-11-20T18:22:01.778 CET] [debug] <<< backend::svirt::open_serial_console_via_ssh(name='openQA-SUT-1', devname='console', port=1, blocking=0)
[2019-11-20T18:22:01.778 CET] [debug] Starting SSH connection to connect to libvirt domain 'openQA-SUT-1' (cmd: 'virsh console openQA-SUT-1 console1'), full cmd: 'script -f /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u -c 'virsh console openQA-SUT-1 console1; echo "CONSOLE_EXIT_1FzvU6nyjTmkke0u: $?"''
[2019-11-20T18:22:01.778 CET] [debug] <<< backend::baseclass::run_ssh(cmd='script -f /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u -c \'virsh console openQA-SUT-1 console1; echo "CONSOLE_EXIT_1FzvU6nyjTmkke0u: $?"\'', blocking=0)
[2019-11-20T18:22:01.778 CET] [debug] <<< backend::baseclass::new_ssh_connection(blocking=0)
[2019-11-20T18:22:01.864 CET] [debug] SSH connection to root@s390p8.suse.de established
[2019-11-20T18:22:01.911 CET] [debug] <<< backend::baseclass::run_ssh_cmd(cmd='grep -q \'CONSOLE_EXIT_1FzvU6nyjTmkke0u:\' /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u', keep_open=1, wantarray=1)
[2019-11-20T18:22:01.911 CET] [debug] <<< backend::baseclass::run_ssh(cmd='grep -q \'CONSOLE_EXIT_1FzvU6nyjTmkke0u:\' /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u', wantarray=1, keep_open=1)
[2019-11-20T18:22:01.911 CET] [debug] <<< backend::baseclass::new_ssh_connection(blocking=1, keep_open=1, wantarray=1)
[2019-11-20T18:22:01.946 CET] [debug] [run_ssh_cmd(grep -q 'CONSOLE_EXIT_1FzvU6nyjTmkke0u:' /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u)] stderr:
grep: /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u: No such file or directory

[2019-11-20T18:22:01.946 CET] [debug] [run_ssh_cmd(grep -q 'CONSOLE_EXIT_1FzvU6nyjTmkke0u:' /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u)] exit-code: 2
[2019-11-20T18:22:01.946 CET] [debug] activate_console, console: root-sut-serial, type: sut-serial
[2019-11-20T18:22:01.946 CET] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/sshd.pm:66 called opensusebasetest::select_serial_terminal
[2019-11-20T18:22:01.946 CET] [debug] <<< serial_terminal::login()
[2019-11-20T18:22:01.947 CET] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/sshd.pm:66 called opensusebasetest::select_serial_terminal
[2019-11-20T18:22:01.947 CET] [debug] <<< testapi::type_string(text='
')
[2019-11-20T18:22:01.947 CET] [debug] <<< consoles::serial_screen::type_string(cmd='backend_type_string', json_cmd_token='JODgzYra', text='
')
[2019-11-20T18:22:01.948 CET] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/sshd.pm:66 called opensusebasetest::select_serial_terminal
[2019-11-20T18:22:01.948 CET] [debug] <<< testapi::wait_serial(no_regex=0, record_output=undef, quiet=undef, expect_not_found=0, timeout=90, regexp=qr/login:\s*$/ui, buffer_size=undef)
[2019-11-20T18:22:01.949 CET] [debug] <<< consoles::serial_screen::read_until(record_output=undef, no_regex=0, buffer_size=undef, json_cmd_token='POHPnRqR', pattern='(?ui:login:\s*$)', expect_not_found=0, quiet=undef, timeout=90, regexp='(?ui:login:\s*$)', cmd='backend_wait_serial')
[2019-11-20T18:23:32.060 CET] [debug] >>> testapi::wait_serial: (?ui:login:\s*$): fail
[2019-11-20T18:23:32.060 CET] [debug] Failed to wait for login prompt at /var/lib/openqa/cache/openqa.suse.de/tests/sle/lib/serial_terminal.pm line 87.

[2019-11-20T18:22:01.778 CET] [debug] Starting SSH connection to connect to libvirt domain 'openQA-SUT-1' (cmd: 'virsh console openQA-SUT-1 console1'), full cmd: 'script -f /tmp/serial_terminal.txt.1FzvU6nyjTmkke0u -c 'virsh console openQA-SUT-1 console1; echo "CONSOLE_EXIT_1FzvU6nyjTmkke0u: $?"''

run_ssh_cmd got issue with serial_terminal.txt because command 'virsh console openQA-SUT-1 console1' seems to be failed:

/tmp/serial_terminal.txt.1FzvU6nyjTmkke0u: No such file or directory

compared with successful test (sles 12 sp5) https://openqa.suse.de/tests/3576395/file/autoinst-log.txt, it looks like kvm host is not ready yet or is not in an active state.

Observation

openQA test in scenario sle-15-SP2-Online-s390x-default@s390x-kvm-sle12 fails in
sshd

Reproducible

Fails since (at least) Build 89.1

Expected result

Last good:

Further details

Always latest result in this scenario: latest


Related issues

Is duplicate of openQA Tests - action #60176: [kernel][s390x] tests look for login prompt just after they are already logged inResolved2019-11-22

History

#1 Updated by zluo almost 2 years ago

  • Description updated (diff)

#2 Updated by zluo almost 2 years ago

  • Priority changed from Normal to High

https://openqa.suse.de/tests/3613750 shows same issue. since this issue blocks other tests, set is as high for now.

#3 Updated by szarate almost 2 years ago

  • Related to action #60176: [kernel][s390x] tests look for login prompt just after they are already logged in added

#4 Updated by SLindoMansilla almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 28
  • Estimated time set to 42.00 h

#5 Updated by szarate almost 2 years ago

Just double check, but I think the linked ticket blocks this one from being workable

#6 Updated by mgriessmeier over 1 year ago

  • Status changed from Workable to Blocked
  • Target version changed from Milestone 28 to Milestone 31

blocked by #60176

#7 Updated by mgriessmeier over 1 year ago

  • Related to deleted (action #60176: [kernel][s390x] tests look for login prompt just after they are already logged in)

#8 Updated by mgriessmeier over 1 year ago

  • Blocked by action #60176: [kernel][s390x] tests look for login prompt just after they are already logged in added

#9 Updated by cfconrad over 1 year ago

The issue in #60176 was fixed with https://github.com/os-autoinst/os-autoinst/pull/1281 .
The ticket #60176 is still open, as a discussion rises, which point to multiple calles to login() which might be able to improve.

So I'm thinking this ticked isn't blocked.

#10 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: textmode+role_textmode
https://openqa.suse.de/tests/3766770

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#11 Updated by SLindoMansilla over 1 year ago

  • Status changed from Blocked to In Progress
  • Assignee set to SLindoMansilla
  • Start date deleted (2019-11-21)

#12 Updated by SLindoMansilla over 1 year ago

  • Blocked by deleted (action #60176: [kernel][s390x] tests look for login prompt just after they are already logged in)

#13 Updated by SLindoMansilla over 1 year ago

  • Is duplicate of action #60176: [kernel][s390x] tests look for login prompt just after they are already logged in added

#14 Updated by SLindoMansilla over 1 year ago

  • Status changed from In Progress to Rejected

As duplicate of #60176

Also available in: Atom PDF